aboutsummaryrefslogtreecommitdiff
path: root/www/py-hdfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-hdfs/Makefile')
-rw-r--r--www/py-hdfs/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/py-hdfs/Makefile b/www/py-hdfs/Makefile
index a5d10f808c07..3a9147ca22ae 100644
--- a/www/py-hdfs/Makefile
+++ b/www/py-hdfs/Makefile
@@ -1,6 +1,6 @@
PORTNAME= hdfs
DISTVERSIONPREFIX= v
-DISTVERSION= 2.7.2
+DISTVERSION= 2.7.3
CATEGORIES= www python
#MASTER_SITES= PYPI # no tests
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,6 +15,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docopt>0:devel/py-docopt@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.7.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}fastavro>=0.21.19:textproc/py-fastavro@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.14.1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-kerberos>=0.7.0:security/py-requests-kerberos@${PY_FLAVOR}
+
USES= python
USE_PYTHON= distutils concurrent autoplist pytest