aboutsummaryrefslogtreecommitdiff
path: root/www/py-python-multipart/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-python-multipart/Makefile')
-rw-r--r--www/py-python-multipart/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/www/py-python-multipart/Makefile b/www/py-python-multipart/Makefile
index b7ef83d318f6..782923f7d60e 100644
--- a/www/py-python-multipart/Makefile
+++ b/www/py-python-multipart/Makefile
@@ -1,23 +1,25 @@
PORTNAME= python-multipart
-PORTVERSION= 0.0.5
+PORTVERSION= 0.0.6
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python_multipart-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Streaming multipart parser for Python
-WWW= https://github.com/andrew-d/python-multipart
+WWW= https://andrew-d.github.io/python-multipart/ \
+ https://github.com/andrew-d/python-multipart
LICENSE= APACHE20
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4.0:devel/py-six@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes