aboutsummaryrefslogtreecommitdiff
path: root/www/rustypaste/Makefile.crates
diff options
context:
space:
mode:
Diffstat (limited to 'www/rustypaste/Makefile.crates')
-rw-r--r--www/rustypaste/Makefile.crates105
1 files changed, 56 insertions, 49 deletions
diff --git a/www/rustypaste/Makefile.crates b/www/rustypaste/Makefile.crates
index 80b0f647eba5..2168f166b5b6 100644
--- a/www/rustypaste/Makefile.crates
+++ b/www/rustypaste/Makefile.crates
@@ -12,6 +12,7 @@ CARGO_CRATES= actix-codec-0.5.1 \
actix-utils-3.0.1 \
actix-web-4.3.1 \
actix-web-codegen-4.2.0 \
+ addr2line-0.20.0 \
adler-1.0.2 \
ahash-0.7.6 \
ahash-0.8.3 \
@@ -21,7 +22,7 @@ CARGO_CRATES= actix-codec-0.5.1 \
android-tzdata-0.1.1 \
android_system_properties-0.1.5 \
anyhow-1.0.71 \
- arrayvec-0.7.2 \
+ arrayvec-0.7.4 \
askama_escape-0.10.3 \
async-stream-0.3.5 \
async-stream-impl-0.3.5 \
@@ -30,9 +31,11 @@ CARGO_CRATES= actix-codec-0.5.1 \
awc-3.1.1 \
axum-0.6.18 \
axum-core-0.3.4 \
+ backtrace-0.3.68 \
base64-0.13.1 \
base64-0.21.2 \
bitflags-1.3.2 \
+ bitflags-2.3.3 \
block-buffer-0.10.4 \
brotli-3.3.4 \
brotli-decompressor-2.3.4 \
@@ -48,10 +51,10 @@ CARGO_CRATES= actix-codec-0.5.1 \
convert_case-0.4.0 \
cookie-0.16.2 \
core-foundation-sys-0.8.4 \
- cpufeatures-0.2.7 \
+ cpufeatures-0.2.8 \
crc32fast-1.3.2 \
crossbeam-channel-0.5.8 \
- crossbeam-utils-0.8.15 \
+ crossbeam-utils-0.8.16 \
crypto-common-0.1.6 \
darling-0.14.4 \
darling_core-0.14.4 \
@@ -88,14 +91,14 @@ CARGO_CRATES= actix-codec-0.5.1 \
futures-task-0.3.28 \
futures-util-0.3.28 \
generic-array-0.14.7 \
- getrandom-0.2.9 \
+ getrandom-0.2.10 \
+ gimli-0.27.3 \
glob-0.3.1 \
- h2-0.3.19 \
+ h2-0.3.20 \
hashbrown-0.12.3 \
headers-0.3.8 \
headers-core-0.2.0 \
heck-0.4.1 \
- hermit-abi-0.2.6 \
hermit-abi-0.3.1 \
home-0.5.5 \
hotwatch-0.5.0 \
@@ -108,23 +111,23 @@ CARGO_CRATES= actix-codec-0.5.1 \
httpdate-1.0.2 \
humantime-2.1.0 \
humantime-serde-1.1.1 \
- hyper-0.14.26 \
+ hyper-0.14.27 \
hyper-timeout-0.4.1 \
- iana-time-zone-0.1.56 \
+ iana-time-zone-0.1.57 \
iana-time-zone-haiku-0.1.2 \
ident_case-1.0.1 \
idna-0.4.0 \
indexmap-1.9.3 \
- infer-0.13.0 \
+ infer-0.14.0 \
inotify-0.9.6 \
inotify-sys-0.1.5 \
instant-0.1.12 \
io-lifetimes-1.0.11 \
- is-terminal-0.4.7 \
+ is-terminal-0.4.8 \
itertools-0.10.5 \
itoa-1.0.6 \
jobserver-0.1.26 \
- js-sys-0.3.63 \
+ js-sys-0.3.64 \
jsonwebtoken-8.3.0 \
kqueue-1.0.7 \
kqueue-sys-1.0.3 \
@@ -132,13 +135,14 @@ CARGO_CRATES= actix-codec-0.5.1 \
lazy-regex-2.5.0 \
lazy-regex-proc_macros-2.4.1 \
lazy_static-1.4.0 \
- libc-0.2.145 \
+ libc-0.2.147 \
linked-hash-map-0.5.6 \
linux-raw-sys-0.3.8 \
+ linux-raw-sys-0.4.3 \
local-channel-0.1.3 \
local-waker-0.1.3 \
- lock_api-0.4.9 \
- log-0.4.18 \
+ lock_api-0.4.10 \
+ log-0.4.19 \
matchers-0.1.0 \
matchit-0.7.0 \
memchr-2.5.0 \
@@ -148,17 +152,18 @@ CARGO_CRATES= actix-codec-0.5.1 \
miniz_oxide-0.7.1 \
mio-0.8.8 \
nom-7.1.3 \
- notify-6.0.0 \
+ notify-6.0.1 \
notify-debouncer-full-0.1.0 \
nu-ansi-term-0.46.0 \
num-bigint-0.4.3 \
num-integer-0.1.45 \
num-traits-0.2.15 \
- num_cpus-1.15.0 \
+ num_cpus-1.16.0 \
+ object-0.31.1 \
once_cell-1.18.0 \
- openssl-0.10.54 \
+ openssl-0.10.55 \
openssl-macros-0.1.1 \
- openssl-sys-0.9.88 \
+ openssl-sys-0.9.90 \
opentelemetry-0.19.0 \
opentelemetry-http-0.8.0 \
opentelemetry-otlp-0.12.0 \
@@ -167,26 +172,26 @@ CARGO_CRATES= actix-codec-0.5.1 \
opentelemetry_sdk-0.19.0 \
overload-0.1.1 \
parking_lot-0.12.1 \
- parking_lot_core-0.9.7 \
+ parking_lot_core-0.9.8 \
parse-size-1.0.0 \
paste-1.0.12 \
pathdiff-0.2.1 \
pem-1.1.1 \
percent-encoding-2.3.0 \
petname-1.1.3 \
- pin-project-1.1.0 \
- pin-project-internal-1.1.0 \
+ pin-project-1.1.1 \
+ pin-project-internal-1.1.1 \
pin-project-lite-0.2.9 \
pin-utils-0.1.0 \
pkg-config-0.3.27 \
ppv-lite86-0.2.17 \
proc-macro-error-1.0.4 \
proc-macro-error-attr-1.0.4 \
- proc-macro2-1.0.59 \
+ proc-macro2-1.0.63 \
prost-0.11.9 \
prost-derive-0.11.9 \
prost-types-0.11.9 \
- quote-1.0.28 \
+ quote-1.0.29 \
rand-0.8.5 \
rand_chacha-0.3.1 \
rand_core-0.6.4 \
@@ -199,9 +204,11 @@ CARGO_CRATES= actix-codec-0.5.1 \
ring-0.16.20 \
rmp-0.8.11 \
rmp-serde-1.1.1 \
+ rustc-demangle-0.1.23 \
rustc-hash-1.1.0 \
rustc_version-0.4.0 \
- rustix-0.37.19 \
+ rustix-0.37.21 \
+ rustix-0.38.1 \
rustls-0.20.8 \
rustrict-0.7.7 \
rustversion-1.0.12 \
@@ -210,21 +217,21 @@ CARGO_CRATES= actix-codec-0.5.1 \
scopeguard-1.1.0 \
sct-0.7.0 \
semver-1.0.17 \
- serde-1.0.163 \
- serde_derive-1.0.163 \
- serde_json-1.0.96 \
+ serde-1.0.164 \
+ serde_derive-1.0.164 \
+ serde_json-1.0.99 \
serde_plain-1.0.1 \
serde_regex-1.1.0 \
serde_urlencoded-0.7.1 \
sha1-0.10.5 \
sharded-slab-0.1.4 \
- shuttle-actix-web-0.18.0 \
- shuttle-codegen-0.18.0 \
- shuttle-common-0.18.0 \
- shuttle-proto-0.18.0 \
- shuttle-runtime-0.18.0 \
- shuttle-service-0.18.0 \
- shuttle-static-folder-0.18.0 \
+ shuttle-actix-web-0.20.0 \
+ shuttle-codegen-0.20.0 \
+ shuttle-common-0.20.0 \
+ shuttle-proto-0.20.0 \
+ shuttle-runtime-0.20.0 \
+ shuttle-service-0.20.0 \
+ shuttle-static-folder-0.20.0 \
signal-hook-registry-1.4.1 \
simple_asn1-0.6.2 \
slab-0.4.8 \
@@ -236,19 +243,19 @@ CARGO_CRATES= actix-codec-0.5.1 \
strum-0.24.1 \
strum_macros-0.24.3 \
syn-1.0.109 \
- syn-2.0.18 \
+ syn-2.0.22 \
sync_wrapper-0.1.2 \
- tempfile-3.5.0 \
+ tempfile-3.6.0 \
termcolor-1.2.0 \
thiserror-1.0.40 \
thiserror-impl-1.0.40 \
thread_local-1.1.7 \
- time-0.3.21 \
+ time-0.3.22 \
time-core-0.1.1 \
time-macros-0.2.9 \
tinyvec-1.6.0 \
tinyvec_macros-0.1.1 \
- tokio-1.28.2 \
+ tokio-1.29.1 \
tokio-io-timeout-1.2.0 \
tokio-macros-2.1.0 \
tokio-openssl-0.6.3 \
@@ -258,11 +265,11 @@ CARGO_CRATES= actix-codec-0.5.1 \
toml-0.5.11 \
tonic-0.8.3 \
tower-0.4.13 \
- tower-http-0.4.0 \
+ tower-http-0.4.1 \
tower-layer-0.3.2 \
tower-service-0.3.2 \
tracing-0.1.37 \
- tracing-attributes-0.1.24 \
+ tracing-attributes-0.1.26 \
tracing-core-0.1.31 \
tracing-futures-0.2.5 \
tracing-log-0.1.3 \
@@ -279,19 +286,19 @@ CARGO_CRATES= actix-codec-0.5.1 \
url-2.4.0 \
urlencoding-2.1.2 \
utf8-width-0.1.6 \
- uuid-1.3.3 \
+ uuid-1.4.0 \
valuable-0.1.0 \
vcpkg-0.2.15 \
version_check-0.9.4 \
walkdir-2.3.3 \
- want-0.3.0 \
+ want-0.3.1 \
wasi-0.11.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.86 \
- wasm-bindgen-backend-0.2.86 \
- wasm-bindgen-macro-0.2.86 \
- wasm-bindgen-macro-support-0.2.86 \
- wasm-bindgen-shared-0.2.86 \
- web-sys-0.3.63 \
+ wasm-bindgen-0.2.87 \
+ wasm-bindgen-backend-0.2.87 \
+ wasm-bindgen-macro-0.2.87 \
+ wasm-bindgen-macro-support-0.2.87 \
+ wasm-bindgen-shared-0.2.87 \
+ web-sys-0.3.64 \
webpki-0.22.0 \
webpki-roots-0.22.6 \
winapi-0.3.9 \
@@ -302,7 +309,7 @@ CARGO_CRATES= actix-codec-0.5.1 \
windows-sys-0.45.0 \
windows-sys-0.48.0 \
windows-targets-0.42.2 \
- windows-targets-0.48.0 \
+ windows-targets-0.48.1 \
windows_aarch64_gnullvm-0.42.2 \
windows_aarch64_gnullvm-0.48.0 \
windows_aarch64_msvc-0.42.2 \