aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/seamonkey2/Makefile')
-rw-r--r--www/seamonkey2/Makefile131
1 files changed, 70 insertions, 61 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index c309c93d1015..ba2a734903f3 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -6,13 +6,16 @@
#
PORTNAME?= mozilla
-PORTVERSION= 1.7.a
-PORTREVISION?= 2
+PORTVERSION= 1.7.b
+PORTREVISION?= 0
PORTEPOCH?= 2
CATEGORIES?= www
-MASTER_SITES= ${MASTER_SITE_MOZILLA}
-MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.a/a/}/src
-DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.a/a/}${EXTRACT_SUFX}
+MASTER_SITES= ${MASTER_SITE_MOZILLA} \
+ ${MASTER_SITE_LOCAL:S/$/:local/}
+MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.b/b/}/src \
+ marcus/:local
+DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.b/b/}-source${EXTRACT_SUFX} \
+ libart_lgpl-moz-2.3.10${EXTRACT_SUFX}:local
MAINTAINER= gnome@FreeBSD.org
COMMENT= The open source, standards compliant web browser
@@ -31,25 +34,12 @@ MOZILLA?= mozilla-devel
MOZ_SUFX= -devel
.if defined(WITH_GTK1)
-PKGNAMESUFFIX= -gtk1
+PKGNAMESUFFIX= -gtk
USE_GNOME= gtk12 orbit
.else
USE_GNOME= gtk20 libidl
.endif
-.if !defined(WITHOUT_XFT)
-LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
-.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package.
-.endif
-.endif
-
-.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
- defined(WITHOUT_COMPOSER))
-BROKEN= "Calendar requires Composer and Mailnews support."
-.endif
-
LATEST_LINK= ${MOZILLA}
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/*\
@@ -62,6 +52,7 @@ USE_X_PREFIX= yes
USE_PERL5= yes
USE_ICONV= yes
USE_GMAKE= yes
+WANT_GNOME= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= \
@@ -92,9 +83,61 @@ CONFIGURE_ARGS= \
--with-system-jpeg=${LOCALBASE} \
--with-system-mng=${LOCALBASE} \
--with-system-png=${LOCALBASE} \
+ --with-gssapi=/usr \
--with-pthreads
-PLIST= ${WRKDIR}/pkg-plist
+PLIST= ${WRKDIR}/pkg-plist
+MOZ_EXTENSIONS= default
+CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
+ LOCALBASE=${LOCALBASE}
+
+.if defined(WITH_GTK1)
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk
+.else
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
+.endif
+
+ESD_LIB= libesd.so.2
+FREETYPE_LIB= libfreetype.so.9
+PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
+ mozilla-nspr mozilla-nss mozilla-plugin
+
+# JPI stuff. List paths to Java Plug-ins here in the order to try.
+JPI_LIST?=\
+ ${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
+
+OPTIONS=XFT "Enable Xft font anti-aliasing" on \
+ CALENDAR "Enable the Calendar module" off \
+ MAILNEWS "Enable Mail and News modules" on \
+ COMPOSER "Enable the HTML Composer module" on \
+ LDAP "Enable LDAP support for Mailnews" on \
+ CHATZILLA "Enable the Chatzilla IRC module" on \
+ XMLTERM "Enable the XMLTerm module" on \
+ JAVASCRIPT_DEBUGGER "Enable the DTD and JavaScript debuggers" off \
+ OPTIMIZED_CFLAGS "Enable -O2 optimizations" off \
+ SMB "Enable smb:// URI support using gnomevfs" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XFT)
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+=--enable-xft
+.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
+BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
+ illegibly. Please remove the mozilla-fonts package.
+.endif
+.else
+CONFIGURE_ARGS+=--disable-xft
+.endif
+
+.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+ defined(WITHOUT_COMPOSER))
+BROKEN= "Calendar requires Composer and Mailnews support."
+.endif
+
# LDAP is only used by mail and news so disable both together
.if defined(WITHOUT_MAILNEWS)
CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
@@ -106,7 +149,6 @@ CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
.endif
.endif
-MOZ_EXTENSIONS= default
.if !defined(WITHOUT_CHATZILLA)
MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
.endif
@@ -114,8 +156,6 @@ MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},xmlterm
.endif
CONFIGURE_ARGS+= --enable-extensions=${MOZ_EXTENSIONS}
-CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
- LOCALBASE=${LOCALBASE}
.if defined(WITH_JAVASCRIPT_DEBUGGER)
CONFIGURE_ARGS+= --enable-jsd \
@@ -133,32 +173,6 @@ CONFIGURE_ARGS+= --enable-calendar
CONFIGURE_ARGS+= --disable-composer
.endif
-.if defined(WITH_GTK1)
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk
-.else
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-.endif
-
-.if !defined(WITHOUT_XFT)
-CONFIGURE_ARGS+= --enable-xft
-.else
-CONFIGURE_ARGS+= --disable-xft
-.endif
-
-ESD_LIB= libesd.so.2
-FREETYPE_LIB= libfreetype.so.9
-PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
- mozilla-nspr mozilla-nss mozilla-plugin
-
-# JPI stuff. List paths to Java Plug-ins here in the order to try.
-JPI_LIST?=\
- ${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
- ${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
- ${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
- ${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
-
-.include <bsd.port.pre.mk>
-
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
@@ -171,6 +185,13 @@ CONFIGURE_ARGS+= --enable-reorder
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
.endif
+.if defined(WITH_SMB)
+USE_GNOME+= gnomevfs2
+RUN_DEPENDS+= ${X11BASE}/lib/gnome-vfs-2.0/modules/libsmb.so:${PORTSDIR}/devel/gnomevfs-extras
+.else
+CONFIGURE_ARGS+=--disable-gnomevfs
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O2
CONFIGURE_ARGS+= --enable-optimize=-O2
@@ -185,18 +206,6 @@ BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installi
.endif
pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Mozilla has the following tunable option(s):"
- @${ECHO_MSG} " WITHOUT_XFT=yes Disables Xft anti-aliasing support"
- @${ECHO_MSG} " WITH_CALENDAR=yes Enables the Calendar module (requires Mailnews and Composer modules)"
- @${ECHO_MSG} " WITHOUT_MAILNEWS=yes Disables the Mail and News modules"
- @${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
- @${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
- @${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
- @${ECHO_MSG} " WITHOUT_XMLTERM=yes Disable the XMLTerm module"
- @${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
- @${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
- @${ECHO_MSG} ""
.if defined(WITH_CALENDAR)
@${ECHO_MSG} ""
@${ECHO_MSG} "Calendar is still beta software."