aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/apache-forrest/Makefile2
-rw-r--r--www/axis/Makefile2
-rw-r--r--www/cocoon/Makefile2
-rw-r--r--www/dojo-shrinksafe/Makefile2
-rw-r--r--www/extsm/Makefile2
-rw-r--r--www/helma/Makefile2
-rw-r--r--www/htmlcompressor/Makefile2
-rw-r--r--www/jetspeed/Makefile2
-rw-r--r--www/jetty/Makefile2
-rw-r--r--www/myfaces/Makefile2
-rw-r--r--www/paros/Makefile2
-rw-r--r--www/resin2/Makefile2
-rw-r--r--www/resin3/Makefile2
-rw-r--r--www/rssowl/Makefile2
-rw-r--r--www/tomcat41/Makefile2
-rw-r--r--www/tomcat55/Makefile2
-rw-r--r--www/yuicompressor/Makefile2
17 files changed, 17 insertions, 17 deletions
diff --git a/www/apache-forrest/Makefile b/www/apache-forrest/Makefile
index b4c25f487305..9478083d356b 100644
--- a/www/apache-forrest/Makefile
+++ b/www/apache-forrest/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= nivit@FreeBSD.org
COMMENT= A tool for rapid development of small sites
USE_JAVA= yes
-JAVA_VERSION= 1.4 1.5
+JAVA_VERSION= 1.5
REPLACE_FILES= ${WRKSRC}/bin/forrest ${WRKSRC}/tools/ant/bin/ant
diff --git a/www/axis/Makefile b/www/axis/Makefile
index d7a0bd1d933f..6dc17be810ec 100644
--- a/www/axis/Makefile
+++ b/www/axis/Makefile
@@ -34,7 +34,7 @@ RUN_DEPENDS+= ${LOCALBASE}/tomcat5.5:${PORTSDIR}/www/tomcat55
NO_BUILD= YES
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
USER= www
GROUP= www
diff --git a/www/cocoon/Makefile b/www/cocoon/Makefile
index 77a0e88da18f..8d4cc933250e 100644
--- a/www/cocoon/Makefile
+++ b/www/cocoon/Makefile
@@ -18,7 +18,7 @@ COMMENT= XML Web Development Framework
USE_RC_SUBR= ${PORTNAME}.sh
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
USE_PYTHON= 1.6+
MAKE_ENV= JAVA_HOME=${JAVA_HOME}
WRKSRC= ${WRKDIR}/${PDISTNAME}
diff --git a/www/dojo-shrinksafe/Makefile b/www/dojo-shrinksafe/Makefile
index e502d48a5def..63807d6cf087 100644
--- a/www/dojo-shrinksafe/Makefile
+++ b/www/dojo-shrinksafe/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= glarkin@FreeBSD.org
COMMENT= A Javascript code compressor
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
PLIST_FILES= bin/${PKGNAMEPREFIX}${PORTNAME} %%DATADIR%%/shrinksafe.jar \
diff --git a/www/extsm/Makefile b/www/extsm/Makefile
index 6227eafd8385..0f75d322b434 100644
--- a/www/extsm/Makefile
+++ b/www/extsm/Makefile
@@ -18,7 +18,7 @@ COMMENT= Extensible Site Manager (XSM)
RUN_DEPENDS= mvn:${PORTSDIR}/devel/maven2
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/xsm
diff --git a/www/helma/Makefile b/www/helma/Makefile
index d14a0b93d218..3949c85f3241 100644
--- a/www/helma/Makefile
+++ b/www/helma/Makefile
@@ -21,7 +21,7 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
USE_RC_SUBR= helma
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
USE_ANT= yes
ALL_TARGET= clean jar
diff --git a/www/htmlcompressor/Makefile b/www/htmlcompressor/Makefile
index 78a9d2383ed1..8f27c91a423f 100644
--- a/www/htmlcompressor/Makefile
+++ b/www/htmlcompressor/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
PLIST_FILES= bin/htmlcompressor %%DATADIR%%/htmlcompressor.jar
diff --git a/www/jetspeed/Makefile b/www/jetspeed/Makefile
index 3400d4a91692..23d94ca17019 100644
--- a/www/jetspeed/Makefile
+++ b/www/jetspeed/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/ant:${PORTSDIR}/devel/apache-ant \
WRKSRC= ${WRKDIR}/${DISTNAME:C/-war//}
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
diff --git a/www/jetty/Makefile b/www/jetty/Makefile
index 5d5b7003f038..1d7d56caedf1 100644
--- a/www/jetty/Makefile
+++ b/www/jetty/Makefile
@@ -16,7 +16,7 @@ COMMENT= Full-featured web server implemented entirely in java
USE_RC_SUBR= ${PORTNAME}
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
USE_PYTHON= 1.6+
PLIST= ${WRKDIR}/pkg-plist
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/www/myfaces/Makefile b/www/myfaces/Makefile
index df99da534f8a..d4816cde76a6 100644
--- a/www/myfaces/Makefile
+++ b/www/myfaces/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Free open source JavaServer(tm) Faces implementation
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
diff --git a/www/paros/Makefile b/www/paros/Makefile
index 96cc6095d3e8..fd17f10f4940 100644
--- a/www/paros/Makefile
+++ b/www/paros/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_JAVA= yes
JAVA_RUN= yes
-JAVA_VERSION= 1.4+1.5
+JAVA_VERSION= 1.5
USE_ZIP= yes
NO_BUILD= yes
diff --git a/www/resin2/Makefile b/www/resin2/Makefile
index 69d05143c8b3..d7960f5f6b41 100644
--- a/www/resin2/Makefile
+++ b/www/resin2/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= boris@tagnet.ru
COMMENT= Resin, a Java-based Application Server, 2.x branch
USE_JAVA= yes
-JAVA_VERSION= 1.2+
+JAVA_VERSION= 1.5+
HAS_CONFIGURE= yes
USE_PYTHON= yes
USE_OPENSSL= yes
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 69f921046891..5292864300d4 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Resin, a Java-based Application Server, 3.x branch
USE_JAVA= yes
-JAVA_VERSION= 1.2+
+JAVA_VERSION= 1.5+
HAS_CONFIGURE= yes
USE_PYTHON= yes
USE_OPENSSL= yes
diff --git a/www/rssowl/Makefile b/www/rssowl/Makefile
index dc3cf5cb8564..ccb898cef7eb 100644
--- a/www/rssowl/Makefile
+++ b/www/rssowl/Makefile
@@ -23,7 +23,7 @@ BUILD_WRKSRC= ${WRKSRC}/src
ONLY_FOR_ARCHS= i386 amd64
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
JAVA_OS= native
JAVA_RUN= yes
diff --git a/www/tomcat41/Makefile b/www/tomcat41/Makefile
index e930e6900b26..94cc39c6449a 100644
--- a/www/tomcat41/Makefile
+++ b/www/tomcat41/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Open-source Java web server by Apache, stable 4.1.x branch
USE_JAVA= yes
-JAVA_VERSION= 1.2+
+JAVA_VERSION= 1.5+
NO_BUILD= YES
LATEST_LINK= ${APP_SHORTNAME}
diff --git a/www/tomcat55/Makefile b/www/tomcat55/Makefile
index 3455a8ce2879..33d385dd605d 100644
--- a/www/tomcat55/Makefile
+++ b/www/tomcat55/Makefile
@@ -20,7 +20,7 @@ OPTIONS= CRONOLOG "Use Cronolog for Log Processing" Off \
CRONOLOG_DEVEL "Use Cronlog-Devel for Log Processing" Off
USE_JAVA= yes
-JAVA_VERSION?= 1.4+
+JAVA_VERSION?= 1.5+
JAVA_VENDOR?= freebsd
NO_BUILD= YES
diff --git a/www/yuicompressor/Makefile b/www/yuicompressor/Makefile
index e242bf761a08..85622e201d5c 100644
--- a/www/yuicompressor/Makefile
+++ b/www/yuicompressor/Makefile
@@ -15,7 +15,7 @@ COMMENT= The Yahoo! JavaScript and CSS Compressor
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
PLIST_FILES= bin/yuicompressor %%DATADIR%%/yuicompressor.jar