aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/get_flash_videos/Makefile2
-rw-r--r--www/p5-Any-URI-Escape/Makefile3
-rw-r--r--www/p5-Apache-Htgroup/Makefile3
-rw-r--r--www/p5-Business-PayPal/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-DevPopup/Makefile3
-rw-r--r--www/p5-CGI-Emulate-PSGI/Makefile3
-rw-r--r--www/p5-CIF-Client/Makefile3
-rw-r--r--www/p5-Catalyst-Component-InstancePerContext/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Log-Dispatch/Makefile3
-rw-r--r--www/p5-Facebook-Graph/Makefile3
-rw-r--r--www/p5-HTML-RSSAutodiscovery/Makefile3
-rw-r--r--www/p5-HTML-Summary/Makefile3
-rw-r--r--www/p5-HTTP-Engine/Makefile3
-rw-r--r--www/p5-HTTP-Exception/Makefile3
-rw-r--r--www/p5-HTTPD-Log-Filter/Makefile3
-rw-r--r--www/p5-Plack-Handler-AnyEvent-ReverseHTTP/Makefile3
-rw-r--r--www/p5-PodToHTML/Makefile3
-rw-r--r--www/p5-TestGen4Web-Runner/Makefile3
-rw-r--r--www/p5-WWW-Shorten-isgd/Makefile3
19 files changed, 37 insertions, 19 deletions
diff --git a/www/get_flash_videos/Makefile b/www/get_flash_videos/Makefile
index e22c271b1cef..c713cd455884 100644
--- a/www/get_flash_videos/Makefile
+++ b/www/get_flash_videos/Makefile
@@ -29,7 +29,7 @@ RUN_DEPENDS= \
rtmpdump>=2.4.0:${PORTSDIR}/multimedia/rtmpdump
FETCH_ARGS= -Fpr # work around 302 redirect at github
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/www/p5-Any-URI-Escape/Makefile b/www/p5-Any-URI-Escape/Makefile
index eaec6036cedd..bf706b9d005a 100644
--- a/www/p5-Any-URI-Escape/Makefile
+++ b/www/p5-Any-URI-Escape/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS:= p5-URI-Escape-XS>=0:${PORTSDIR}/www/p5-URI-Escape-XS
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Any::URI::Escape.3
diff --git a/www/p5-Apache-Htgroup/Makefile b/www/p5-Apache-Htgroup/Makefile
index 36c039f43365..a7d502a9c285 100644
--- a/www/p5-Apache-Htgroup/Makefile
+++ b/www/p5-Apache-Htgroup/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= otaviof@gmail.com
COMMENT= Manage Apache authentication group files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Apache::Htgroup.3
diff --git a/www/p5-Business-PayPal/Makefile b/www/p5-Business-PayPal/Makefile
index 65b92c0213e2..533fa2526184 100644
--- a/www/p5-Business-PayPal/Makefile
+++ b/www/p5-Business-PayPal/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= p5-Net-SSLeay>=1.35:${PORTSDIR}/security/p5-Net-SSLeay \
p5-Digest-MD5>=2.52:${PORTSDIR}/security/p5-Digest-MD5
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::PayPal.3
diff --git a/www/p5-CGI-Application-Plugin-DevPopup/Makefile b/www/p5-CGI-Application-Plugin-DevPopup/Makefile
index e62cee76c329..7fe957b96581 100644
--- a/www/p5-CGI-Application-Plugin-DevPopup/Makefile
+++ b/www/p5-CGI-Application-Plugin-DevPopup/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-CGI-Application>=4.01:${PORTSDIR}/www/p5-CGI-Application \
p5-IO-stringy>0:${PORTSDIR}/devel/p5-IO-stringy
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Application::Plugin::DevPopup.3 \
CGI::Application::Plugin::DevPopup::HTTPHeaders.3 \
diff --git a/www/p5-CGI-Emulate-PSGI/Makefile b/www/p5-CGI-Emulate-PSGI/Makefile
index d49dcb78b397..75b1d7e080f9 100644
--- a/www/p5-CGI-Emulate-PSGI/Makefile
+++ b/www/p5-CGI-Emulate-PSGI/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= \
p5-libwww>0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Emulate::PSGI.3 \
CGI::Parse::PSGI.3
diff --git a/www/p5-CIF-Client/Makefile b/www/p5-CIF-Client/Makefile
index 103251175f1d..5b1755757249 100644
--- a/www/p5-CIF-Client/Makefile
+++ b/www/p5-CIF-Client/Makefile
@@ -34,7 +34,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0.31:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Text-Table>=1.114:${PORTSDIR}/textproc/p5-Text-Table
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CIF::Client.3
diff --git a/www/p5-Catalyst-Component-InstancePerContext/Makefile b/www/p5-Catalyst-Component-InstancePerContext/Makefile
index 2ef24027b4d1..4d40ce10ce59 100644
--- a/www/p5-Catalyst-Component-InstancePerContext/Makefile
+++ b/www/p5-Catalyst-Component-InstancePerContext/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Component::InstancePerContext.3
diff --git a/www/p5-Catalyst-Plugin-Log-Dispatch/Makefile b/www/p5-Catalyst-Plugin-Log-Dispatch/Makefile
index 53e260bae7a4..397331e20444 100644
--- a/www/p5-Catalyst-Plugin-Log-Dispatch/Makefile
+++ b/www/p5-Catalyst-Plugin-Log-Dispatch/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Log-Dispatch>=2.13:${PORTSDIR}/devel/p5-Log-Dispatch \
p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::Log::Dispatch.3
diff --git a/www/p5-Facebook-Graph/Makefile b/www/p5-Facebook-Graph/Makefile
index d2e5ca17b55e..5a621d752567 100644
--- a/www/p5-Facebook-Graph/Makefile
+++ b/www/p5-Facebook-Graph/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= \
p5-URI>=1.54:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Facebook::Graph.3 \
Facebook::Graph::AccessToken.3 \
diff --git a/www/p5-HTML-RSSAutodiscovery/Makefile b/www/p5-HTML-RSSAutodiscovery/Makefile
index 7c9ea44ca25e..31aca87e5141 100644
--- a/www/p5-HTML-RSSAutodiscovery/Makefile
+++ b/www/p5-HTML-RSSAutodiscovery/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::RSSAutodiscovery.3
diff --git a/www/p5-HTML-Summary/Makefile b/www/p5-HTML-Summary/Makefile
index c87f9ece03af..784025962c64 100644
--- a/www/p5-HTML-Summary/Makefile
+++ b/www/p5-HTML-Summary/Makefile
@@ -16,7 +16,8 @@ COMMENT= Produces summaries from the textual content of web pages
BUILD_DEPENDS= p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Summary.3 Text::Sentence.3 Lingua::JA::Jtruncate.3
diff --git a/www/p5-HTTP-Engine/Makefile b/www/p5-HTTP-Engine/Makefile
index c7b53c36dc52..0916e0eea9a3 100644
--- a/www/p5-HTTP-Engine/Makefile
+++ b/www/p5-HTTP-Engine/Makefile
@@ -31,7 +31,8 @@ TEST_DEPENDS= \
p5-IO-stringy>0:${PORTSDIR}/devel/p5-IO-stringy \
p5-MouseX-Types>=0.05:${PORTSDIR}/devel/p5-MouseX-Types
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Engine.3 \
HTTP::Engine::Cookbook.3 \
diff --git a/www/p5-HTTP-Exception/Makefile b/www/p5-HTTP-Exception/Makefile
index fdca9aef1521..0945271e3d00 100644
--- a/www/p5-HTTP-Exception/Makefile
+++ b/www/p5-HTTP-Exception/Makefile
@@ -22,7 +22,8 @@ TEST_DEPENDS= \
p5-Test-Exception>=0.29:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-NoWarnings>=1.04:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Exception.3 \
HTTP::Exception::1XX.3 \
diff --git a/www/p5-HTTPD-Log-Filter/Makefile b/www/p5-HTTPD-Log-Filter/Makefile
index 89df4d371ee6..a897234b1321 100644
--- a/www/p5-HTTPD-Log-Filter/Makefile
+++ b/www/p5-HTTPD-Log-Filter/Makefile
@@ -18,7 +18,8 @@ COMMENT= Perl module to filter entries out of an httpd log
BUILD_DEPENDS= p5-IO-Zlib>=0:${PORTSDIR}/archivers/p5-IO-Zlib
RUN_DEPENDS= p5-IO-Zlib>=0:${PORTSDIR}/archivers/p5-IO-Zlib
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= exclude_robots.1
MAN3= HTTPD::Log::Filter.3
diff --git a/www/p5-Plack-Handler-AnyEvent-ReverseHTTP/Makefile b/www/p5-Plack-Handler-AnyEvent-ReverseHTTP/Makefile
index cd79d48aa2a1..63a3611344f8 100644
--- a/www/p5-Plack-Handler-AnyEvent-ReverseHTTP/Makefile
+++ b/www/p5-Plack-Handler-AnyEvent-ReverseHTTP/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
p5-Plack>=0.99:${PORTSDIR}/www/p5-Plack
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Handler::AnyEvent::ReverseHTTP.3
diff --git a/www/p5-PodToHTML/Makefile b/www/p5-PodToHTML/Makefile
index afb53b0f9a25..e921e00fb55b 100644
--- a/www/p5-PodToHTML/Makefile
+++ b/www/p5-PodToHTML/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-HTML-Format>=0:${PORTSDIR}/textproc/p5-HTML-Format
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= podtohtml.1
MAN3= Pod::HTML_Elements.3 \
diff --git a/www/p5-TestGen4Web-Runner/Makefile b/www/p5-TestGen4Web-Runner/Makefile
index 6a8a9846553f..bad5c3a8877a 100644
--- a/www/p5-TestGen4Web-Runner/Makefile
+++ b/www/p5-TestGen4Web-Runner/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= TestGen4Web::Runner.3
diff --git a/www/p5-WWW-Shorten-isgd/Makefile b/www/p5-WWW-Shorten-isgd/Makefile
index a76cbca2d28c..5278a3d7837e 100644
--- a/www/p5-WWW-Shorten-isgd/Makefile
+++ b/www/p5-WWW-Shorten-isgd/Makefile
@@ -17,7 +17,8 @@ COMMENT= Abstract interface to is.gd, one of URL shortening sites
BUILD_DEPENDS= p5-WWW-Shorten>=1.97:${PORTSDIR}/www/p5-WWW-Shorten
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Shorten::isgd.3