aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/dpsearch/Makefile2
-rw-r--r--www/epiphany/Makefile4
-rw-r--r--www/mod_encoding/Makefile4
-rw-r--r--www/mod_log_sql2-dtc/Makefile7
-rw-r--r--www/mod_log_sql2/Makefile2
-rw-r--r--www/shttpd/Makefile2
-rw-r--r--www/sitecopy/Makefile5
-rw-r--r--www/webalizer/Makefile4
-rw-r--r--www/wwwoffle/Makefile2
9 files changed, 14 insertions, 18 deletions
diff --git a/www/dpsearch/Makefile b/www/dpsearch/Makefile
index ccdf6de74908..4082d51e5236 100644
--- a/www/dpsearch/Makefile
+++ b/www/dpsearch/Makefile
@@ -40,7 +40,7 @@ EXTRACT_DESC= Enable libextractor support
CONFIGURE_ENV+= PORTNAME="${PORTNAME}"
THREADS_CONFIGURE_ENABLE= pthreads
-THREADS_CONFIGURE_ENV= LIBS="-pthread"
+THREADS_LIBS= -pthread
ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
#ASPELL_CONFIGURE_WITH= aspell
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index a32f6b3c5992..ca5f378ef586 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -35,8 +35,8 @@ INSTALLS_OMF= yes
CONFIGURE_ARGS+=--enable-introspection \
--enable-compile-warnings=no \
--with-ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -pthread ${EXTRA_LIBS}"
-CPPFLAGS+= -I${LOCALBASE}/include ${EXTRA_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= epiphany-lockdown.schemas epiphany.schemas
diff --git a/www/mod_encoding/Makefile b/www/mod_encoding/Makefile
index bd79bea48588..727696c6f4ad 100644
--- a/www/mod_encoding/Makefile
+++ b/www/mod_encoding/Makefile
@@ -25,9 +25,9 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--includedir=${APACHEINCLUDEDIR} \
--with-apxs=${APXS}
-CONFIGURE_ENV= LIBS='-L${LOCALBASE}/lib' \
- PATH="${PREFIX}/bin:${PREFIX}/sbin:${PATH}"
+CONFIGURE_ENV= PATH="${PREFIX}/bin:${PREFIX}/sbin:${PATH}"
CPPFLAGS+= -I${APACHEINCLUDEDIR} -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
EXTRA_PATCHES= ${PATCHDIR}/apache22_patch
diff --git a/www/mod_log_sql2-dtc/Makefile b/www/mod_log_sql2-dtc/Makefile
index 393bbcdb09f5..efc7f58413da 100644
--- a/www/mod_log_sql2-dtc/Makefile
+++ b/www/mod_log_sql2-dtc/Makefile
@@ -20,16 +20,13 @@ DBI_CONFIGURE_ON= --with-dbi=${LOCALBASE}
DBI_CONFIGURE_OFF= --without-dbi
DBI_LIB_DEPENDS= libdbi.so:${PORTSDIR}/databases/libdbi
-LATEST_LINK= mod_log_sql2-dtc
GNU_CONFIGURE= yes
USES= gmake tar:bzip2
USE_APACHE= 22
USE_MYSQL= yes
-.include <bsd.port.pre.mk>
-
CONFIGURE_ARGS+= --with-apxs=${APXS}
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
+LIBS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql
post-patch:
${REINPLACE_CMD} -e 's|@APXS_STAGE@|-S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR}|' \
@@ -38,4 +35,4 @@ post-patch:
pre-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mod_log_sql2/Makefile b/www/mod_log_sql2/Makefile
index ed9315e098f3..b9dc5f34ac95 100644
--- a/www/mod_log_sql2/Makefile
+++ b/www/mod_log_sql2/Makefile
@@ -21,7 +21,7 @@ PLIST_SUB+= SSL=${SSL_PLIST} APACHE2X=${APACHE2X}
USE_MYSQL= yes
USE_APACHE= 22
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
+LIBS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql
.include <bsd.port.pre.mk>
diff --git a/www/shttpd/Makefile b/www/shttpd/Makefile
index b578000925ef..fe95af8d6f56 100644
--- a/www/shttpd/Makefile
+++ b/www/shttpd/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= valenok@gmail.com
COMMENT= Small, fast, embeddable web server with CGI, SSL, Authorization
ALL_TARGET= unix
-MAKE_ENV= LIBS=-lpthread
+LIBS+= -lpthread
BUILD_WRKSRC= ${WRKSRC}/src
PLIST_FILES= bin/shttpd man/man1/shttpd.1.gz
diff --git a/www/sitecopy/Makefile b/www/sitecopy/Makefile
index a28932334f0c..f7a5ee6a07a5 100644
--- a/www/sitecopy/Makefile
+++ b/www/sitecopy/Makefile
@@ -15,9 +15,8 @@ COMMENT= Maintains remote websites, uses FTP or WebDAV to sync up w/ local copy
LIB_DEPENDS= neon.27:${PORTSDIR}/www/neon29
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" \
- LIBS="${LIBS}"
-LIBS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-neon --with-libxml2
USE_GNOME= libxml2
USES= gmake
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 82faa7e785c6..0f1a459a0424 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -129,8 +129,8 @@ USES+= iconv
# see http://tyche.pu-toyama.ac.jp/~a-urasim/webalizer/
EXTRA_PATCHES+= ${FILESDIR}/webalizer-a-urasim_2.patch
CONFIGURE_ARGS+= --enable-mininls
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}"
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}
.endif
.if ${PORT_OPTIONS:MFULL_CGI_REFS}
diff --git a/www/wwwoffle/Makefile b/www/wwwoffle/Makefile
index bc61fe105c3e..0bc3f5d5904d 100644
--- a/www/wwwoffle/Makefile
+++ b/www/wwwoffle/Makefile
@@ -25,7 +25,7 @@ WWWOFFLE_SPOOL?= /var/spool/wwwoffle
PLIST_SUB+= WWWOFFLE_SPOOL=${WWWOFFLE_SPOOL}
HAS_CONFIGURE= yes
-CONFIGURE_ENV= LIBS=-lmd
+LIBS+= -lmd
CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc --with-ipv6 \
--with-gnutls=${LOCALBASE} \
--with-spooldir=${WWWOFFLE_SPOOL} \