aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/Makefile27
1 files changed, 25 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index 017beb636ae6..94c2ad810b2b 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -14,8 +14,31 @@ USE_XORG= xf86driproto xineramaproto xf86miscproto glproto
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1000051 || !defined(WITH_NEW_XORG) || \
- (${ARCH} != i386 && ${ARCH} != amd64)
+.if (${OSVERSION} >= 902508 && ${OSVERSION} < 1000000) || ${OSVERSION} >= 1000051
+# 902508: Radeon kernel driver imported in FreeBSD 9.x
+# 1000051: Radeon kernel driver imported in FreeBSD 10.x
+. if defined(WITH_NEW_XORG)
+NEW_ATI_DRIVER= yes
+. else
+NEW_ATI_DRIVER= no
+. endif
+.else
+# FreeBSD < 902508 doesn't have the Radeon kernel driver. No need to
+# check for WITH_NEW_XORG. But we do support a flag to force the usage
+# of the KMS-only DDX: this is used by the build cluster only.
+. if defined(FORCE_KMS_ONLY_DDX)
+NEW_ATI_DRIVER= yes
+. else
+NEW_ATI_DRIVER= no
+. endif
+.endif
+
+.if (${ARCH} != i386 && ${ARCH} != amd64)
+# No Radeon kernel driver on non-x86 and PC98.
+NEW_ATI_DRIVER= no
+.endif
+
+.if ${NEW_ATI_DRIVER} == no
ATI_VERSION= 6.14.6
ATI_REVISION= 3
CONFIGURE_ARGS+=--disable-kms