aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/worker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/worker/Makefile')
-rw-r--r--x11-fm/worker/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-fm/worker/Makefile b/x11-fm/worker/Makefile
index a79de80f8c95..59e93e8b2060 100644
--- a/x11-fm/worker/Makefile
+++ b/x11-fm/worker/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= worker
-PORTVERSION= 2.6.1
+PORTVERSION= 2.7.0
CATEGORIES= x11-fm
MASTER_SITES= http://www.boomerangsworld.de/worker/downloads/ \
http://www.informatik.uni-halle.de/~hoffmanr/worker/downloads/
@@ -15,13 +15,15 @@ MAINTAINER= simond@irrelevant.org
GNU_CONFIGURE= yes
USE_XLIB= yes
+USE_REINPLACE= yes
MAN1= worker.1
CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ARGS= --disable-libxpkmaster
pre-configure:
- @${PERL} -pi.orig -e 's:-lpthread:${PTHREAD_LIBS}:g' \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
.include <bsd.port.mk>