aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/noto-sans-runic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/noto-sans-runic/Makefile')
-rw-r--r--x11-fonts/noto-sans-runic/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-fonts/noto-sans-runic/Makefile b/x11-fonts/noto-sans-runic/Makefile
new file mode 100644
index 000000000000..141062a45e86
--- /dev/null
+++ b/x11-fonts/noto-sans-runic/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= noto
+PORTVERSION= 2.002
+CATEGORIES= x11-fonts
+MASTER_SITES= https://github.com/notofonts/notofonts.github.io/raw/NotoSansRunic-v${PORTVERSION}/fonts/ \
+ https://github.com/notofonts/notofonts.github.io/raw/NotoSansRunic-v${PORTVERSION}/fonts/NotoSansRunic/hinted/ttf/:fonts
+PKGNAMESUFFIX= -sans-runic
+DISTFILES= LICENSE \
+ ${FONTS:S|$|:fonts|}
+DIST_SUBDIR= Noto/SansRunic/${PORTVERSION}
+EXTRACT_ONLY= # empty
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Noto Sans Runic
+WWW= https://fonts.google.com/noto \
+ https://notofonts.github.io/ \
+ https://github.com/notofonts/runic \
+ https://github.com/notofonts/notofonts.github.io/tree/main/fonts/NotoSansRunic
+
+LICENSE= OFL11
+LICENSE_FILE= ${DISTDIR}/${DIST_SUBDIR}/LICENSE
+
+USES= fonts
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= ${FONTSDIR}/NotoSansRunic-Regular.ttf
+
+FONTS= NotoSansRunic-Regular.ttf
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${FONTS} ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>