aboutsummaryrefslogtreecommitdiff
path: root/x11-servers/xorg-server-snap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-servers/xorg-server-snap/Makefile')
-rw-r--r--x11-servers/xorg-server-snap/Makefile170
1 files changed, 39 insertions, 131 deletions
diff --git a/x11-servers/xorg-server-snap/Makefile b/x11-servers/xorg-server-snap/Makefile
index 38907d90fe68..6f53725843cb 100644
--- a/x11-servers/xorg-server-snap/Makefile
+++ b/x11-servers/xorg-server-snap/Makefile
@@ -6,91 +6,67 @@
#
PORTNAME= xorg-server
-PORTVERSION= 6.8.99.903
+PORTVERSION= 1.2.99.903
PORTREVISION= 1
+PORTEPOCH= 1
CATEGORIES= x11-servers
-MASTER_SITES= http://xorg.freedesktop.org/snapshots/
-DISTNAME= xorg-x11-${PORTVERSION}
+MASTER_SITES= http://xorg.freedesktop.org/releases/individual/xserver/:fdo \
+ ${MASTER_SITE_SOURCEFORGE:S/$/:mesa/}
+MASTER_SITE_SUBDIR=mesa3d/:mesa
+DISTFILES= xorg-server-${PORTVERSION}.tar.bz2:fdo \
+ MesaLib-6.5.2.tar.bz2:mesa
MAINTAINER= x11@FreeBSD.org
-COMMENT= X.Org X server development snapshot and related programs
+COMMENT= X.Org X server and related programs
-USE_BZIP2= yes
-.if !defined(WITH_MODULAR)
-USE_XLIB= yes
-.else
-LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xdmcp.pc:${PORTSDIR}/x11/libXdmcp \
- ${X11BASE}/libdata/pkgconfig/xau.pc:${PORTSDIR}/x11/libXau
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- GL.1:${PORTSDIR}/x11/libGL
-BUILD_DEPENDS= ${X11BASE}/include/X11/extensions/XKMformat.h:${PORTSDIR}/x11/libxkbfile \
- ${LIB_PC_DEPENDS}
-RUN_DEPENDS= ${LIB_PC_DEPENDS}
+LIB_DEPENDS= drm:${PORTSDIR}/graphics/libdrm
+RUN_DEPENDS= ${X11BASE}/share/X11/xkb/rules/base.xml:${PORTSDIR}/x11/xkeyboard-config
+
+CONFLICTS= XFree86-Server-*
+
+XORG_CAT= xserver
+
+USE_XORG= xf86driproto glproto xdmcp x11 xkbfile xxf86misc xxf86vm xaw7 \
+ xmu xt xpm xext randrproto renderproto fixesproto damageproto \
+ xcmiscproto xextproto xproto xtrans xf86miscproto \
+ xf86vidmodeproto xf86bigfontproto scrnsaverproto bigreqsproto \
+ resourceproto fontsproto inputproto xf86dgaproto \
+ videoproto compositeproto trapproto recordproto xineramaproto \
+ evieproto xfont fontenc xkbui
+
+USE_PERL5_BUILD=yes
+CONFIGURE_ARGS= --with-mesa-source=${WRKDIR}/Mesa-6.5.2 \
+ --disable-dmx --disable-xvfb --disable-xnest --disable-xprint \
+ --localstatedir=/var
+
+.if !defined(WITHOUT_AIGLX)
+CONFIGURE_ARGS+= --enable-aiglx=yes
.endif
-CONFLICTS= XFree86-Server-* xorg-server-6.[79].* xorg-server-6.8.[012]*
+.if !defined(NO_SUID_XSERVER) || ${NO_SUID_XSERVER} == NO
+CONFIGURE_ARGS+=--enable-install-setuid
+.endif
-SCRIPTS_ENV= WITH_DEBUG="${WITH_DEBUG}"
MAN1= Xorg.1 \
- getconfig.1 \
+ Xserver.1 \
+ cvt.1 \
gtf.1 \
- kbd_mode.1 \
pcitweak.1 \
xorgcfg.1 \
xorgconfig.1
-MAN4= citron.4x \
- dmc.4x \
- dynapro.4x \
- elographics.4x \
- fbdevhw.4x \
- fpit.4x \
- glint.4x \
- js_x.4x \
- kbd.4x \
- keyboard.4x \
- mga.4x \
- microtouch.4x \
- mouse.4x \
- mutouch.4x \
- palmax.4x \
- penmount.4x \
- r128.4x \
- radeon.4x \
- tdfx.4x \
- tek4957.4x \
- vga.4x \
- void.4x \
- wacom.4x
-MAN5= getconfig.5 \
- xorg.conf.5
-
-XBUILD_DIRS= lib/font programs/Xserver
-XINCLUDE_DIRS= lib/xtrans
-XMAN_DIRS= programs/Xserver
-LATEST_LINK= ${PORTNAME}-snap
+MAN4= exa.4 \
+ fbdevhw.4
+MAN5= xorg.conf.5
NOT_FOR_ARCHS= ia64
-.include "${.CURDIR}/../../x11-servers/xorg-server/Makefile.inc"
.include <bsd.port.pre.mk>
-.if ${X_WINDOW_SYSTEM:L} != xorg
-IGNORE= is part of X.Org and you have ${X_WINDOW_SYSTEM} set for X11\
- distribution. See The X Window System and Virtual Consoles chapter\
- of FAQ for more information
-.endif
-
.if ${ARCH} == alpha
PLIST_SUB+= ALPHA_NA="@comment "
.else
PLIST_SUB+= ALPHA_NA=""
.endif
-.if ${ARCH} == ia64
-PLIST_SUB+= IA64_NA="@comment "
-.else
-PLIST_SUB+= IA64_NA=""
-.endif
-
.if ${ARCH} == powerpc
PLIST_SUB+= PPC_NA="@comment "
MAN4+= nv.4x
@@ -99,84 +75,20 @@ PLIST_SUB+= PPC_NA=""
.endif
.if ${ARCH} == sparc64
-BROKEN= Does not compile on sparc64
PLIST_SUB+= SPARC64=""
PLIST_SUB+= SPARC64_NA="@comment "
-MAN4+= apm.4x \
- chips.4x \
- cirrus.4x \
- i128.4x \
- i740.4x \
- i810.4x \
- imstt.4x \
- neomagic.4x \
- newport.4x \
- nv.4x \
- rendition.4x \
- s3virge.4x \
- savage.4x \
- siliconmotion.4x \
- sunbw2.4x \
- suncg14.4x \
- suncg3.4x \
- suncg6.4x \
- sunffb.4x \
- sunleo.4x \
- suntcx.4x \
- trident.4x \
- vmware.4x
.else
PLIST_SUB+= SPARC64="@comment "
PLIST_SUB+= SPARC64_NA=""
.endif
-.if ${ARCH} != powerpc && ${ARCH} != sparc64
-MAN4+= cirrus.4x \
- nv.4x \
- rendition.4x \
- s3virge.4x \
- savage.4x \
- siliconmotion.4x
-.endif
-
-.if ${ARCH} != powerpc && ${ARCH} != alpha
-MAN4+= vesa.4x
-.endif
-
-.if ${ARCH} == i386
-PLIST_SUB+= I386=""
-MAN1+= scanpci.1
-MAN4+= i740.4x \
- imstt.4x \
- newport.4x \
- nsc.4x \
- via.4x
-.else
-PLIST_SUB+= I386="@comment "
-.endif
-
.if ${ARCH} == amd64 || ${ARCH} == i386
PLIST_SUB+= AMD64_I386=""
-MAN4+= apm.4x \
- chips.4x \
- cyrix.4x \
- i128.4x \
- i810.4x \
- neomagic.4x \
- sis.4x \
- trident.4x \
- tseng.4x \
- vmware.4x
+MAN1+= scanpci.1
.else
PLIST_SUB+= AMD64_I386="@comment "
.endif
-pre-everything::
- @${ECHO_MSG} "This X Server installs with development DRI DDX drivers. These drivers are"
- @${ECHO_MSG} "considered insecure by their authors and may allow privilege escalation by"
- @${ECHO_MSG} "local X clients with DRI privileges."
- @${ECHO_MSG} ""
-
.if !defined(NO_SUID_XSERVER) || ${NO_SUID_XSERVER} == NO
pre-everything::
@${ECHO_MSG} "By default, the X Server installs as a set-user-id root binary. When run by"
@@ -185,10 +97,6 @@ pre-everything::
@${ECHO_MSG} "of this, but still want to run an X Server (for example using xdm/kdm/gdm,"
@${ECHO_MSG} "which will still run the server as root), you can cancel the build and set"
@${ECHO_MSG} "NO_SUID_XSERVER=YES in /etc/make.conf."
-
-SCRIPTS_ENV+= SUID_XSERVER=YES
-.else
-SCRIPTS_ENV+= SUID_XSERVER=NO
.endif
.include <bsd.port.post.mk>