aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/mate-icon-theme/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/mate-icon-theme/Makefile')
-rw-r--r--x11-themes/mate-icon-theme/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/mate-icon-theme/Makefile b/x11-themes/mate-icon-theme/Makefile
new file mode 100644
index 000000000000..dee50aadf317
--- /dev/null
+++ b/x11-themes/mate-icon-theme/Makefile
@@ -0,0 +1,32 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-icon-theme
+PORTVERSION= 1.6.2
+CATEGORIES= x11-themes mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Collection of icons for the MATE desktop
+
+BUILD_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
+ icon-naming-utils>=0.8.7:${PORTSDIR}/x11-themes/icon-naming-utils
+RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_GNOME= intlhack
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+pre-install:
+ @${REINPLACE_CMD} -e 's|install: install-data|install:|g' \
+ ${WRKSRC}/po/Makefile
+
+.include <bsd.port.mk>