aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gnustep-gui
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gnustep-gui')
-rw-r--r--x11-toolkits/gnustep-gui/Makefile12
-rw-r--r--x11-toolkits/gnustep-gui/distinfo6
-rw-r--r--x11-toolkits/gnustep-gui/files/AudioOutputSink.m.patch10
-rw-r--r--x11-toolkits/gnustep-gui/files/GNUmakefile.patch10
-rw-r--r--x11-toolkits/gnustep-gui/files/GNUmakefile.speech.patch11
-rw-r--r--x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrintInfo.m12
-rw-r--r--x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrintOperation.m12
-rw-r--r--x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrinter.m12
-rw-r--r--x11-toolkits/gnustep-gui/pkg-plist23
9 files changed, 27 insertions, 81 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index 70e3e8147dac..7ee5f6a5f71e 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= gnustep-gui
-PORTVERSION= 0.25.1
-PORTREVISION= 7
+PORTVERSION= 0.27.0
CATEGORIES= x11-toolkits gnustep
-MASTER_SITES= GNUSTEP/core
MAINTAINER= theraven@FreeBSD.org
COMMENT= GNUstep GUI library
@@ -13,6 +11,11 @@ COMMENT= GNUstep GUI library
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
+USE_GITHUB= yes
+GH_ACCOUNT= gnustep
+GH_PROJECT= libs-gui
+GH_TAGNAME= gui-${PORTVERSION:S/./_/g}
+
LIB_DEPENDS+= libtiff.so:graphics/tiff
LIB_DEPENDS+= libpng.so:graphics/png
LIB_DEPENDS+= libgif.so:graphics/giflib
@@ -41,9 +44,6 @@ USES= gnustep jpeg pkgconfig
USE_GNUSTEP= base build
USE_XORG= x11 xt
-EXTRA_PATCHES+= ${FILESDIR}/GNUmakefile.patch
-EXTRA_PATCHES+= ${FILESDIR}/GNUmakefile.speech.patch
-EXTRA_PATCHES+= ${FILESDIR}/AudioOutputSink.m.patch
MAKE_FLAGS+= OPTFLAG="${CFLAGS}"
PLIST_SUB+= BASEVERSION=${PORTVERSION:C/[.][0-9]*$//1}
diff --git a/x11-toolkits/gnustep-gui/distinfo b/x11-toolkits/gnustep-gui/distinfo
index 619219772feb..847e3eab8bd7 100644
--- a/x11-toolkits/gnustep-gui/distinfo
+++ b/x11-toolkits/gnustep-gui/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1495189097
-SHA256 (gnustep-gui-0.25.1.tar.gz) = 3aacb277976014cfd4394084066187430100657dea234da91d9ae5015e747c66
-SIZE (gnustep-gui-0.25.1.tar.gz) = 2888779
+TIMESTAMP = 1549118107
+SHA256 (gnustep-libs-gui-0.27.0-gui-0_27_0_GH0.tar.gz) = a00d15f0356602ae561e04308b8c56ac50ed40ea41a158ec737bfe5e402a5845
+SIZE (gnustep-libs-gui-0.27.0-gui-0_27_0_GH0.tar.gz) = 2868998
diff --git a/x11-toolkits/gnustep-gui/files/AudioOutputSink.m.patch b/x11-toolkits/gnustep-gui/files/AudioOutputSink.m.patch
deleted file mode 100644
index 4610c84a9431..000000000000
--- a/x11-toolkits/gnustep-gui/files/AudioOutputSink.m.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- Tools/sound/AudioOutputSink.m.orig 2010-06-06 18:12:07.000000000 +0200
-+++ Tools/sound/AudioOutputSink.m 2010-06-06 18:12:53.000000000 +0200
-@@ -72,6 +72,7 @@
- return nil;
- }
-
-+ memset(&_format, 0, sizeof(_format));
- _format.channels = (int)channelCount;
- _format.rate = (int)sampleRate;
-
diff --git a/x11-toolkits/gnustep-gui/files/GNUmakefile.patch b/x11-toolkits/gnustep-gui/files/GNUmakefile.patch
deleted file mode 100644
index aea59ed45b14..000000000000
--- a/x11-toolkits/gnustep-gui/files/GNUmakefile.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- Documentation/GNUmakefile.orig Fri Jun 11 20:58:40 2004
-+++ Documentation/GNUmakefile Sun Jun 13 09:42:28 2004
-@@ -77,6 +77,7 @@
- DOCUMENT_NAME += Gui GuiAdditions
- Gui_DOC_INSTALL_DIR = Developer/Gui/Reference
- GuiAdditions_DOC_INSTALL_DIR = Developer/Gui/Additions
-+GuiUser_DOC_INSTALL_DIR = Developer/Gui/GuiUser
-
- -include GNUmakefile.preamble
-
diff --git a/x11-toolkits/gnustep-gui/files/GNUmakefile.speech.patch b/x11-toolkits/gnustep-gui/files/GNUmakefile.speech.patch
deleted file mode 100644
index 49032e3a22ee..000000000000
--- a/x11-toolkits/gnustep-gui/files/GNUmakefile.speech.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Tools/speech/GNUmakefile.orig 2013-07-11 15:50:51.000000000 +0000
-+++ Tools/speech/GNUmakefile 2013-07-11 15:51:07.000000000 +0000
-@@ -28,6 +28,6 @@
- -lflite_usenglish -lflite_cmulex -lflite
- endif
-
--GSSpeechServer_OBJCFLAGS = -std=c99 -g -Werror
-+GSSpeechServer_OBJCFLAGS = -std=c99 -g
-
- include $(GNUSTEP_MAKEFILES)/application.make
-
diff --git a/x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrintInfo.m b/x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrintInfo.m
deleted file mode 100644
index 7c664f3a833e..000000000000
--- a/x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrintInfo.m
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./Printing/GSCUPS/GSCUPSPrintInfo.m.orig 2011-02-07 18:08:33.000000000 +0000
-+++ ./Printing/GSCUPS/GSCUPSPrintInfo.m 2014-03-31 15:14:03.000000000 +0000
-@@ -32,7 +32,9 @@
- #import "AppKit/NSPrinter.h"
- #import "GSCUPSPrintInfo.h"
- #import "GSCUPSPrinter.h"
-+#undef __BLOCKS__
- #include <cups/cups.h>
-+#define __BLOCKS__
-
-
- @implementation GSCUPSPrintInfo
diff --git a/x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrintOperation.m b/x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrintOperation.m
deleted file mode 100644
index 9391911c04ee..000000000000
--- a/x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrintOperation.m
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./Printing/GSCUPS/GSCUPSPrintOperation.m.orig 2011-03-13 23:38:47.000000000 +0000
-+++ ./Printing/GSCUPS/GSCUPSPrintOperation.m 2014-03-31 15:14:03.000000000 +0000
-@@ -41,7 +41,9 @@
- #import <AppKit/NSPrintOperation.h>
- #import "GSGuiPrivate.h"
- #import "GSCUPSPrintOperation.h"
-+#undef __BLOCKS__
- #include <cups/cups.h>
-+#define __BLOCKS__
-
-
- //A subclass of GSPrintOperation, NOT NSPrintOperation.
diff --git a/x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrinter.m b/x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrinter.m
deleted file mode 100644
index 63da5df389fe..000000000000
--- a/x11-toolkits/gnustep-gui/files/patch-Printing__GSCUPS__GSCUPSPrinter.m
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./Printing/GSCUPS/GSCUPSPrinter.m.orig 2011-03-14 21:45:39.000000000 +0000
-+++ ./Printing/GSCUPS/GSCUPSPrinter.m 2014-03-31 15:14:03.000000000 +0000
-@@ -48,7 +48,9 @@
- #import "GNUstepGUI/GSPrinting.h"
- #import "GSCUPSPrinter.h"
-
-+#undef __BLOCKS__
- #include <cups/cups.h>
-+#define __BLOCKS__
-
-
- NSString *GSCUPSDummyPrinterName = @"GSCUPSDummyPrinter";
diff --git a/x11-toolkits/gnustep-gui/pkg-plist b/x11-toolkits/gnustep-gui/pkg-plist
index 48249b4267ed..d8aa70f33f45 100644
--- a/x11-toolkits/gnustep-gui/pkg-plist
+++ b/x11-toolkits/gnustep-gui/pkg-plist
@@ -335,11 +335,6 @@ GNUstep/System/Library/ColorPickers/WheelPicker.bundle/stamp.make
%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/ReleaseNotes/ReleaseNotes.html
%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/ReleaseNotes/ReleaseNotes.igsdoc
%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/ReleaseNotes/dependencies
-%%PORTDOCS%%GNUstep/System/Library/Documentation/User/Gui/GuiUser/DefaultsSummary.html
-%%PORTDOCS%%GNUstep/System/Library/Documentation/User/Gui/GuiUser/GuiUser.igsdoc
-%%PORTDOCS%%GNUstep/System/Library/Documentation/User/Gui/GuiUser/KeyboardSetup.html
-%%PORTDOCS%%GNUstep/System/Library/Documentation/User/Gui/GuiUser/LanguageSetup.html
-%%PORTDOCS%%GNUstep/System/Library/Documentation/User/Gui/GuiUser/dependencies
%%PORTDOCS%%GNUstep/System/Library/Documentation/info/AppKit.info
GNUstep/System/Library/Documentation/man/man1/GSSpeechServer.1.gz
%%PORTDOCS%%GNUstep/System/Library/Documentation/man/man1/gclose.1.gz
@@ -855,3 +850,21 @@ GNUstep/System/Tools/make_services
GNUstep/System/Tools/say
GNUstep/System/Tools/set_show_service
@dir GNUstep/System/Library/Themes
+GNUstep/System/Library/Documentation/User/Gui/DefaultsSummary.html
+GNUstep/System/Library/Documentation/User/Gui/GuiUser.igsdoc
+GNUstep/System/Library/Documentation/User/Gui/KeyboardSetup.html
+GNUstep/System/Library/Documentation/User/Gui/LanguageSetup.html
+GNUstep/System/Library/Documentation/User/Gui/dependencies
+GNUstep/System/Library/Headers/AppKit/NSAccessibility.h
+GNUstep/System/Library/Headers/AppKit/NSAccessibilityConstants.h
+GNUstep/System/Library/Headers/AppKit/NSGestureRecognizer.h
+GNUstep/System/Library/Headers/AppKit/NSPasteboardItem.h
+GNUstep/System/Library/Headers/AppKit/NSRunningApplication.h
+GNUstep/System/Library/Headers/AppKit/NSSharingService.h
+GNUstep/System/Library/Headers/AppKit/NSTextAlternatives.h
+GNUstep/System/Library/Headers/AppKit/NSUserInterfaceItemIdentification.h
+GNUstep/System/Library/Headers/AppKit/NSUserInterfaceLayout.h
+GNUstep/System/Library/Headers/AppKit/NSVisualEffectView.h
+GNUstep/System/Library/Libraries/gnustep-gui/Versions/%%BASEVERSION%%/Resources/Japanese.lproj/Localizable.strings
+GNUstep/System/Library/Libraries/gnustep-gui/Versions/%%BASEVERSION%%/Resources/Polish.lproj/Localizable.strings
+