aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/kf5-kdesignerplugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/kf5-kdesignerplugin/Makefile')
-rw-r--r--x11-toolkits/kf5-kdesignerplugin/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11-toolkits/kf5-kdesignerplugin/Makefile b/x11-toolkits/kf5-kdesignerplugin/Makefile
new file mode 100644
index 000000000000..52d1b0fa4130
--- /dev/null
+++ b/x11-toolkits/kf5-kdesignerplugin/Makefile
@@ -0,0 +1,19 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= kdesignerplugin
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= x11-toolkits kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 integration of Frameworks widgets in Qt Designer/Creator
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= auth bookmarks codecs completion config configwidgets \
+ coreaddons doctools ecm i18n iconthemes itemviews \
+ jobwidgets kdewebkit kio plotting service solid sonnet \
+ textwidgets widgetsaddons xmlgui
+USE_QT5= buildtools_build core dbus designer gui linguisttools \
+ network qmake_build webkit widgets xml
+
+.include <bsd.port.mk>