aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ocaml-lablgtk2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/ocaml-lablgtk2/Makefile')
-rw-r--r--x11-toolkits/ocaml-lablgtk2/Makefile40
1 files changed, 32 insertions, 8 deletions
diff --git a/x11-toolkits/ocaml-lablgtk2/Makefile b/x11-toolkits/ocaml-lablgtk2/Makefile
index d425b769dfc2..c2fc56fb268c 100644
--- a/x11-toolkits/ocaml-lablgtk2/Makefile
+++ b/x11-toolkits/ocaml-lablgtk2/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= lablgtk2
-PORTVERSION= 2.4.0
-PORTREVISION= 4
+PORTVERSION= 2.6.0
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.kurims.kyoto-u.ac.jp/pub/lang/olabl/ \
http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/ \
@@ -24,6 +23,14 @@ RUN_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml
USE_GMAKE= yes
USE_GNOME= gtk20
+OPTIONS= GLADE "With glade support" OFF \
+ GNOMECANVAS "With gnomecanvas support" OFF \
+ GNOMEPANEL "With gnomepanel support" OFF \
+ GNOMEUI "With gnomeui support" OFF \
+ GTKSPELL "With gtkspell support" OFF \
+ GTKTL "With gtkglarea support" ON \
+ RSVG "With rsvg support" OFF
+
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
@@ -32,9 +39,15 @@ ALL_TARGET= all opt
CONFIGURE_ARGS= --prefix=${PREFIX} --with-libdir=${PREFIX}/lib/ocaml
+.if !defined(NOPORTDOCS)
+PORTDOCS= \
+ COPYING \
+ README
+.endif
+
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/bin/lablgl) && exists(${X11BASE}/libdata/pkgconfig/gtkgl-2.0.pc)
+.if (exists(${LOCALBASE}/bin/lablgl) && exists(${X11BASE}/libdata/pkgconfig/gtkgl-2.0.pc)) || defined(WITH_GTKTL)
CONFIGURE_ARGS+= --with-gl
BUILD_DEPENDS+= lablgl:${PORTSDIR}/graphics/ocaml-lablgl
RUN_DEPENDS+= lablgl:${PORTSDIR}/graphics/ocaml-lablgl
@@ -46,7 +59,7 @@ CONFIGURE_ARGS+= --without-gl
PLIST_SUB+= GL="@comment "
.endif
-.if exists(${X11BASE}/libdata/pkgconfig/libglade-2.0.pc)
+.if (exists(${X11BASE}/libdata/pkgconfig/libglade-2.0.pc)) || defined(WITH_GLADE)
CONFIGURE_ARGS+= --with-glade
USE_GNOME+= libglade2
WITH_GLADE= yes
@@ -56,7 +69,7 @@ CONFIGURE_ARGS+= --without-glade
PLIST_SUB+= GLADE="@comment "
.endif
-.if exists(${X11BASE}/libdata/pkgconfig/libgnomeui-2.0.pc)
+.if (exists(${X11BASE}/libdata/pkgconfig/libgnomeui-2.0.pc)) || defined(WITH_GNOMEUI)
CONFIGURE_ARGS+= --with-gnomeui
USE_GNOME+= libgnomeui
WITH_GNOMEUI= yes
@@ -66,7 +79,7 @@ CONFIGURE_ARGS+= --without-gnomeui
PLIST_SUB+= GNOMEUI="@comment "
.endif
-.if exists(${X11BASE}/libdata/pkgconfig/libgnomecanvas-2.0.pc)
+.if (exists(${X11BASE}/libdata/pkgconfig/libgnomecanvas-2.0.pc)) || defined(WITH_GNOMECANVAS)
CONFIGURE_ARGS+= --with-gnomecanvas
USE_GNOME+= libgnomecanvas
PLIST_SUB+= GNOMECANVAS=""
@@ -76,7 +89,7 @@ CONFIGURE_ARGS+= --without-gnomecanvas
PLIST_SUB+= GNOMECANVAS="@comment "
.endif
-.if exists(${X11BASE}/libdata/pkgconfig/librsvg-2.0.pc)
+.if (exists(${X11BASE}/libdata/pkgconfig/librsvg-2.0.pc)) || defined(WITH_RSVG)
CONFIGURE_ARGS+= --with-rsvg
USE_GNOME+= librsvg2
WITH_RSVG= yes
@@ -86,7 +99,7 @@ CONFIGURE_ARGS+= --without-rsvg
PLIST_SUB+= RSVG="@comment "
.endif
-.if exists(${X11BASE}/libdata/pkgconfig/libpanelapplet-2.0.pc)
+.if (exists(${X11BASE}/libdata/pkgconfig/libpanelapplet-2.0.pc)) || defined(WITH_GNOMEPANEL)
CONFIGURE_ARGS+= --with-panel
USE_GNOME+= gnomepanel
WITH_PANEL= yes
@@ -96,6 +109,17 @@ CONFIGURE_ARGS+= --without-panel
PLIST_SUB+= PANEL="@comment "
.endif
+.if (exists(${X11BASE}/libdata/pkgconfig/gtkspell-2.0.pc)) || defined(WITH_GTKSPELL)
+LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
+
+CONFIGURE_ARGS+= --with-gtkspell
+PLIST_SUB+= GTKSPELL=""
+WITH_GTKSPELL= yes
+.else
+CONFIGURE_ARGS+= --without-gtkspell
+PLIST_SUB+= GTKSPELL="@comment "
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}