aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/awesome2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/awesome2/Makefile')
-rw-r--r--x11-wm/awesome2/Makefile75
1 files changed, 38 insertions, 37 deletions
diff --git a/x11-wm/awesome2/Makefile b/x11-wm/awesome2/Makefile
index bf7133cdbafd..baa6ebbe0908 100644
--- a/x11-wm/awesome2/Makefile
+++ b/x11-wm/awesome2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= awesome
-PORTVERSION= 2.3.4
+PORTVERSION= 3.1.1
CATEGORIES= x11-wm
MASTER_SITES= http://awesome.naquadah.org/download/
@@ -14,49 +14,50 @@ MAINTAINER= ntarmos@ceid.upatras.gr
COMMENT= A tiling window manager initially based on a dwm code rewriting
BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
- xmlto:${PORTSDIR}/textproc/xmlto
-LIB_DEPENDS= confuse.0:${PORTSDIR}/devel/libconfuse \
- cairo.2:${PORTSDIR}/graphics/cairo \
- freetype.9:${PORTSDIR}/print/freetype2
+ xmlto:${PORTSDIR}/textproc/xmlto \
+ xcb-util>=0.3.3:${PORTSDIR}/x11/xcb-util \
+ xproto>=7.0.11:${PORTSDIR}/x11/xproto \
+ gperf>=3.0.3:${PORTSDIR}/devel/gperf
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
+ ev.3:${PORTSDIR}/devel/libev \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ xcb.2:${PORTSDIR}/x11/libxcb \
+ xcb-event.1:${PORTSDIR}/x11/xcb-util
USE_ICONV= yes
-GNU_CONFIGURE= yes
+USE_CMAKE= yes
+CMAKE_ARGS+= -DSYSCONFDIR=${PREFIX}/etc
+CMAKE_ENV+= PATH=${LOCALBASE}:\${PATH}
USE_EFL= imlib2
-USE_GNOME= pango
-USE_XORG= x11 xft xext xinerama xt xrandr xproto
+USE_GNOME= glib20 pango
+USE_LUA= 5.1+
+USE_XORG= pixman x11 xau xdmcp xext xft xinerama xrandr xrender xproto
MAN1= awesome.1 \
awesome-client.1 \
- awesome-menu.1 \
- awesome-message.1
+ awsetbg.1
MAN5= awesomerc.5
-PORTDOCS= AUTHORS LICENSE README STYLE UPGRADE
-PORTEXAMPLES= awesomerc
-
-post-patch:
- @${REINPLACE_CMD} -e 's, "$$(DESTDIR)$$(docdir)";,;,g' \
- -e 's,\([[:space:]]\)install-docDATA ,\1,g' \
- ${WRKSRC}/Makefile.in
-
-post-configure:
- @${REINPLACE_CMD} -E '/^awesome_(message_)?LDADD/s/$$/ -liconv/g; \
- /^doc_DATA/s/=.*$$/=/g' \
- ${WRKSRC}/Makefile
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
- @${MKDIR} ${DOCSDIR}
-. for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-. endfor
+MANCOMPRESSED= yes
+PORTDOCS= AUTHORS BUGS LICENSE README
+
+.include <bsd.port.pre.mk>
+
+.if (exists(${LOCALBASE}/libdata/pkgconfig/cairo.pc) && \
+ !exists(${LOCALBASE}/libdata/pkgconfig/cairo-xcb.pc))
+IGNORE= cannot find dependency: The cairo exists but not with XCB support. Please reinstall graphics/cairo with XCB support
.endif
-.if !defined(NOPORTEXAMPLES)
- @${ECHO_MSG} "installing example config file to ${EXAMPLESDIR}"
- @${MKDIR} ${EXAMPLESDIR}
-. for example in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${example} ${EXAMPLESDIR}
-. endfor
+
+pre-configure:
+ @${REINPLACE_CMD} \
+ -e 's/"generate luadoc" ON/\"generate luadoc" OFF/g' \
+ ${WRKSRC}/awesomeConfig.cmake
+ @${REINPLACE_CMD} \
+ -e 's,gperf,${LOCALBASE}/bin/gperf,g' \
+ ${WRKSRC}/build-utils/gperf.sh
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} \
+ -e 's/"install port docs" ON/\"install port docs" OFF/g' \
+ ${WRKSRC}/awesomeConfig.cmake
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>