aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/beryl-plugins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/beryl-plugins/Makefile')
-rw-r--r--x11-wm/beryl-plugins/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-wm/beryl-plugins/Makefile b/x11-wm/beryl-plugins/Makefile
new file mode 100644
index 000000000000..fdfc9e713a16
--- /dev/null
+++ b/x11-wm/beryl-plugins/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: beryl-plugins
+# Date created: Oct 29 2006
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beryl-plugins
+PORTVERSION= 0.2.1
+PORTREVISION= 1
+CATEGORIES= x11-wm
+MASTER_SITES= http://releases.beryl-project.org/${PORTVERSION}/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= flz/beryl/
+
+MAINTAINER= rnoland@2hip.net
+COMMENT= Plugins for Beryl Composite/Window Manager
+
+# XXX - Might depends on graphics/libsvg-cairo instead.
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/beryl.pc:${PORTSDIR}/x11-wm/beryl-core \
+ ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_GL= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 librsvg2
+USE_XORG= glproto
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.mk>