aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/beryl-settings-bindings/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/beryl-settings-bindings/Makefile')
-rw-r--r--x11-wm/beryl-settings-bindings/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-wm/beryl-settings-bindings/Makefile b/x11-wm/beryl-settings-bindings/Makefile
new file mode 100644
index 000000000000..d8e295d0797a
--- /dev/null
+++ b/x11-wm/beryl-settings-bindings/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: beryl-settings-bindings
+# Date created: Jan 29 2007
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beryl-settings-bindings
+PORTVERSION= 0.2.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://releases.beryl-project.org/${PORTVERSION}/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= flz/beryl/
+
+MAINTAINER= rnoland@2hip.net
+COMMENT= Beryl Settings Bindings
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/berylsettings.pc:${PORTSDIR}/x11-wm/beryl-core \
+ ${PYTHON_SITELIBDIR}/Pyrex/Distutils/__init__.py:${PORTSDIR}/devel/pyrex
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_XORG= x11
+USE_GNOME= glib20 gnomehack
+USE_PYTHON= 2.4+
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>