aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/metacity/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/metacity/Makefile')
-rw-r--r--x11-wm/metacity/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
index 621b1ee30554..24968d47e69c 100644
--- a/x11-wm/metacity/Makefile
+++ b/x11-wm/metacity/Makefile
@@ -1,7 +1,7 @@
# Created by: Garrett Rooney <rooneg@electricjellyfish.net>
PORTNAME= metacity
-PORTVERSION= 3.36.1
+PORTVERSION= 3.40.0
CATEGORIES= x11-wm
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
@@ -11,26 +11,28 @@ COMMENT= Window manager for the adult in you
LICENSE= GPLv2
-BUILD_DEPENDS= zenity>=3.0.0:x11/zenity \
+BUILD_DEPENDS= gsettings-desktop-schemas>=3.3.0:devel/gsettings-desktop-schemas \
itstool:textproc/itstool \
- gsettings-desktop-schemas>=3.3.0:devel/gsettings-desktop-schemas
-LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
+ zenity>=3.0.0:x11/zenity
+LIB_DEPENDS= libcanberra-gtk3.so:audio/libcanberra-gtk3 \
libgtop-2.0.so:devel/libgtop \
- libcanberra-gtk3.so:audio/libcanberra-gtk3
-RUN_DEPENDS= zenity>=3.0.0:x11/zenity \
- gsettings-desktop-schemas>=3.3.0:devel/gsettings-desktop-schemas
+ libstartup-notification-1.so:x11/startup-notification
+RUN_DEPENDS= gsettings-desktop-schemas>=3.3.0:devel/gsettings-desktop-schemas \
+ zenity>=3.0.0:x11/zenity
PORTSCOUT= limitw:1,even
-USES= compiler:c11 gettext gmake gnome libtool \
- localbase pathfix pkgconfig tar:xz xorg
+USES= compiler:c11 gettext gmake gnome libtool localbase pathfix \
+ pkgconfig tar:xz xorg
GNU_CONFIGURE= yes
-USE_XORG= x11 xcomposite xdamage xrender xcursor xinerama xext xrandr
+USE_XORG= x11 xcomposite xcursor xdamage xext xinerama xpresent xrandr \
+ xrender xres
USE_GNOME= gnomeprefix gtk30 intlhack libxml2:build
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-GLIB_SCHEMAS= org.gnome.metacity.gschema.xml \
+GLIB_SCHEMAS= org.gnome.metacity.enums.xml \
+ org.gnome.metacity.gschema.xml \
org.gnome.metacity.keybindings.gschema.xml \
org.gnome.metacity.theme.gschema.xml