aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/sawfish/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/sawfish/Makefile')
-rw-r--r--x11-wm/sawfish/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-wm/sawfish/Makefile b/x11-wm/sawfish/Makefile
index bb5bcf56f3d3..a25a299be471 100644
--- a/x11-wm/sawfish/Makefile
+++ b/x11-wm/sawfish/Makefile
@@ -1,7 +1,7 @@
# Created by: Yukihiro Nakai <nakai@FreeBSD.org>
PORTNAME= sawfish
-DISTVERSION= 1.12.90
+DISTVERSION= 1.13.0
CATEGORIES= x11-wm
MASTER_SITES= http://download.tuxfamily.org/sawfish/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -13,16 +13,18 @@ LICENSE= ART20 GPLv2
LICENSE_COMB= multi
BUILD_DEPENDS= rep-gtk2>=0.90:x11-toolkits/rep-gtk2
-LIB_DEPENDS= librep.so:lang/librep \
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libgmp.so:math/gmp \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+ libharfbuzz.so:print/harfbuzz \
+ librep.so:lang/librep
+
RUN_DEPENDS= rep-gtk2>=0.90:x11-toolkits/rep-gtk2
USES= autoreconf gmake gnome libtool localbase makeinfo pathfix \
pkgconfig tar:xz xorg
USE_XORG= ice sm x11 xft xinerama xrandr xtst xrender xext
-USE_GNOME= cairo gtk20
+USE_GNOME= cairo gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share \
--datadir=${PREFIX}/share
@@ -42,8 +44,6 @@ post-patch:
@${REINPLACE_CMD} -e \
'/dnsdomainname/d' ${WRKSRC}/build-info
@${REINPLACE_CMD} -e \
- '/KDEDIR/s|^|#|g' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e \
's|prog_name|program_name|g' ${WRKSRC}/src/main.c
post-build: