aboutsummaryrefslogtreecommitdiff
path: root/x11/appmenu-registrar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/appmenu-registrar/Makefile')
-rw-r--r--x11/appmenu-registrar/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11/appmenu-registrar/Makefile b/x11/appmenu-registrar/Makefile
new file mode 100644
index 000000000000..3c781fe46898
--- /dev/null
+++ b/x11/appmenu-registrar/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= appmenu-registrar
+DISTVERSION= 0.7.6
+CATEGORIES= x11
+
+MAINTAINER= ericbsd@FreeBSD.org
+COMMENT= Appmenu DBusMenu registrar
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libbamf3.so:sysutils/bamf
+BUILD_DEPENDS= valac:lang/vala
+
+USES= meson gnome pkgconfig gettext
+
+MESON_ARGS= -Dvalapanel=disabled \
+ -Dxfce=disabled \
+ -Dmate=disabled \
+ -Dbudgie=disabled \
+ -Djayatana=disabled \
+ -Dregistrar=enabled \
+ -Dappmenu-gtk-module=disabled
+
+USE_GNOME= gtk30 glib20 gtk20 gdkpixbuf2
+# GLIB_SCHEMAS= org.appmenu.gtk-module.gschema.xml
+
+USE_GITLAB= yes
+GL_ACCOUNT= vala-panel-project
+GL_PROJECT= vala-panel-appmenu
+GL_COMMIT= 4e362c22ab3a23c98f13fb379c782786ee057cf6
+
+.include <bsd.port.mk>