aboutsummaryrefslogtreecommitdiff
path: root/x11/deforaos-locker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/deforaos-locker/Makefile')
-rw-r--r--x11/deforaos-locker/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/x11/deforaos-locker/Makefile b/x11/deforaos-locker/Makefile
index ee1414433a00..1827a7abff0f 100644
--- a/x11/deforaos-locker/Makefile
+++ b/x11/deforaos-locker/Makefile
@@ -3,6 +3,7 @@
PORTNAME= locker
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://www.defora.org/os/download/download/3703/
PKGNAMEPREFIX= deforaos-
@@ -13,19 +14,16 @@ COMMENT= DeforaOS desktop screensaver
LICENSE= GPLv3
-LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
- Desktop:${PORTSDIR}/x11/deforaos-libdesktop \
- Xss:${PORTSDIR}/x11/libXScrnSaver
+LIB_DEPENDS= libSystem.so:${PORTSDIR}/devel/deforaos-libsystem \
+ libDesktop.so:${PORTSDIR}/x11/deforaos-libdesktop \
+ libXss.so:${PORTSDIR}/x11/libXScrnSaver
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/Panel.pc:${PORTSDIR}/x11/deforaos-panel \
xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
-USE_GNOME= gtk20 desktopfileutils
-USES= pkgconfig gettext
+USE_GNOME= gtk20
+USES= desktop-file-utils gettext pkgconfig
MAKE_ARGS+= PREFIX=${PREFIX}
-MAKE_ENV+= MANDIR=${MANPREFIX}/man
+MAKE_ENV+= MANDIR=${STAGEDIR}${MANPREFIX}/man
-MAN1= locker.1 lockerctl.1
-
-NO_STAGE= yes
.include <bsd.port.mk>