aboutsummaryrefslogtreecommitdiff
path: root/x11/dzen2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/dzen2/Makefile')
-rw-r--r--x11/dzen2/Makefile26
1 files changed, 25 insertions, 1 deletions
diff --git a/x11/dzen2/Makefile b/x11/dzen2/Makefile
index ebac74836431..eb85450c24ad 100644
--- a/x11/dzen2/Makefile
+++ b/x11/dzen2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dzen2
PORTVERSION= 0.8.5
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://gotmor.googlepages.com/
@@ -17,8 +18,31 @@ USE_XORG= x11
PLIST_FILES= bin/${PORTNAME}
+OPTIONS= XPM "Enable XPM support" On \
+ XINERAMA "Enable Xinerama support" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XPM)
+USE_XORG+= xpm
+.endif
+
+.if !defined(WITHOUT_XINERAMA)
+USE_XORG+= xinerama
+.endif
+
post-patch:
+.if !defined(WITHOUT_XPM)
+ ${REINPLACE_CMD} -e 's/^LIBS =\(.*\)$$/LIBS =\1 -lXpm/g' \
+ -e 's/^CFLAGS =\(.*\)$$/CFLAGS =\1 -DDZEN_XPM/g' \
+ ${WRKSRC}/config.mk
+.endif
+.if !defined(WITHOUT_XINERAMA)
+ ${REINPLACE_CMD} -e 's/^LIBS =\(.*\)$$/LIBS =\1 -lXinerama/g' \
+ -e 's/^CFLAGS =\(.*\)$$/CFLAGS =\1 -DDZEN_XINERAMA/g' \
+ ${WRKSRC}/config.mk
+.endif
${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
${WRKSRC}/config.mk
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>