aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomedesktop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnomedesktop/Makefile')
-rw-r--r--x11/gnomedesktop/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/x11/gnomedesktop/Makefile b/x11/gnomedesktop/Makefile
index cc11fda744cc..f35b0147eb41 100644
--- a/x11/gnomedesktop/Makefile
+++ b/x11/gnomedesktop/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnomedesktop/Makefile,v 1.74 2005/10/03 15:18:36 ahze Exp $
+# $MCom: ports/x11/gnomedesktop/Makefile,v 1.90 2006/04/13 07:52:40 bland Exp $
#
PORTNAME= gnomedesktop
-PORTVERSION= 2.12.3
-PORTREVISION= 1
+PORTVERSION= 2.14.1.1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-desktop/2.12
+MASTER_SITE_SUBDIR= sources/gnome-desktop/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-desktop-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -21,15 +20,15 @@ COMMENT= Additional UI API for GNOME 2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
-USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui gnomedocutils \
ltverhack
GNOME_DESKTOP_VERSION=2
+USE_GETTEXT= yes
USE_GMAKE= yes
USE_BISON= yes
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-gnome-distributor="FreeBSD GNOME Project" \
--with-kde-datadir=${LOCALBASE}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \