aboutsummaryrefslogtreecommitdiff
path: root/x11/menulibre
diff options
context:
space:
mode:
Diffstat (limited to 'x11/menulibre')
-rw-r--r--x11/menulibre/Makefile34
-rw-r--r--x11/menulibre/distinfo3
-rw-r--r--x11/menulibre/pkg-descr4
-rw-r--r--x11/menulibre/pkg-plist101
4 files changed, 142 insertions, 0 deletions
diff --git a/x11/menulibre/Makefile b/x11/menulibre/Makefile
new file mode 100644
index 000000000000..e3c06a1a845d
--- /dev/null
+++ b/x11/menulibre/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= menulibre
+PORTVERSION= 2.2.0
+CATEGORIES= x11
+MASTER_SITES= https://launchpad.net/menulibre/${PORTVERSION:R}/${PORTVERSION}/+download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= madpilot@FreeBSD.org
+COMMENT= Advanced menu editor
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-distutils-extra>=2.38:devel/py-python-distutils-extra@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=2.0:sysutils/py-psutil@${FLAVOR}
+LIB_DEPENDS= libgnome-menu-3.so:x11/gnome-menus
+RUN_DEPENDS= xdg-open:devel/xdg-utils \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=2.0:sysutils/py-psutil@${FLAVOR}
+
+USES= desktop-file-utils gettext gnome python:3.4+
+USE_GNOME= intltool pygobject3
+USE_PYTHON= distutils
+INSTALLS_ICONS= yes
+
+.include <bsd.port.pre.mk>
+
+PYDISTUTILS_INSTALLARGS:= ${PYDISTUTILS_INSTALLARGS:N--single-version-externally-managed}
+
+post-install:
+ ${MV} ${STAGEDIR}${PREFIX}/share/man/man1 ${STAGEDIR}${PREFIX}/man
+ ${RMDIR} ${STAGEDIR}${PREFIX}/share/man
+ ${GZIP_CMD} ${STAGEDIR}${PREFIX}/man/man1/*
+
+.include <bsd.port.post.mk>
diff --git a/x11/menulibre/distinfo b/x11/menulibre/distinfo
new file mode 100644
index 000000000000..6b0abc2a25d1
--- /dev/null
+++ b/x11/menulibre/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527348390
+SHA256 (menulibre-2.2.0.tar.gz) = 546fec87f451c8f5c220d02b1f36dd850f4ce9ab607f8e9711ed8f2009e349fe
+SIZE (menulibre-2.2.0.tar.gz) = 430567
diff --git a/x11/menulibre/pkg-descr b/x11/menulibre/pkg-descr
new file mode 100644
index 000000000000..683d89884d10
--- /dev/null
+++ b/x11/menulibre/pkg-descr
@@ -0,0 +1,4 @@
+MenuLibre is an advanced FreeDesktop.org compliant menu editor that
+provides modern features in a clean, easy-to-use interface.
+
+WWW: https://bluesabre.org/projects/menulibre/
diff --git a/x11/menulibre/pkg-plist b/x11/menulibre/pkg-plist
new file mode 100644
index 000000000000..e47cecce86fa
--- /dev/null
+++ b/x11/menulibre/pkg-plist
@@ -0,0 +1,101 @@
+bin/menulibre
+bin/menulibre-menu-validate
+%%PYTHON_SITELIBDIR%%/menulibre/Dialogs.py
+%%PYTHON_SITELIBDIR%%/menulibre/MenuEditor.py
+%%PYTHON_SITELIBDIR%%/menulibre/MenulibreApplication.py
+%%PYTHON_SITELIBDIR%%/menulibre/MenulibreHistory.py
+%%PYTHON_SITELIBDIR%%/menulibre/MenulibreIconSelection.py
+%%PYTHON_SITELIBDIR%%/menulibre/MenulibreLog.py
+%%PYTHON_SITELIBDIR%%/menulibre/MenulibreStackSwitcher.py
+%%PYTHON_SITELIBDIR%%/menulibre/MenulibreTreeview.py
+%%PYTHON_SITELIBDIR%%/menulibre/MenulibreXdg.py
+%%PYTHON_SITELIBDIR%%/menulibre/XmlMenuElementTree.py
+%%PYTHON_SITELIBDIR%%/menulibre/__init__.py
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/Dialogs.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/Dialogs.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenuEditor.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenuEditor.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreApplication.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreApplication.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreHistory.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreHistory.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreIconSelection.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreIconSelection.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreLog.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreLog.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreStackSwitcher.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreStackSwitcher.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreTreeview.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreTreeview.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreXdg.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/MenulibreXdg.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/XmlMenuElementTree.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/XmlMenuElementTree.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/__init__.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/__init__.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/util.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre/__pycache__/util.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre/util.py
+%%PYTHON_SITELIBDIR%%/menulibre_lib/__init__.py
+%%PYTHON_SITELIBDIR%%/menulibre_lib/__pycache__/__init__.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre_lib/__pycache__/__init__.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre_lib/__pycache__/helpers.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre_lib/__pycache__/helpers.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre_lib/__pycache__/menulibreconfig.cpython-36.%%PYTHON_PYOEXTENSION%%
+%%PYTHON_SITELIBDIR%%/menulibre_lib/__pycache__/menulibreconfig.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/menulibre_lib/helpers.py
+%%PYTHON_SITELIBDIR%%/menulibre_lib/menulibreconfig.py
+man/man1/menulibre-menu-validate.1.gz
+man/man1/menulibre.1.gz
+share/applications/menulibre.desktop
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/icons/hicolor/16x16/apps/menulibre.svg
+share/icons/hicolor/24x24/apps/menulibre.svg
+share/icons/hicolor/32x32/apps/menulibre.svg
+share/icons/hicolor/48x48/apps/menulibre.svg
+share/icons/hicolor/64x64/apps/menulibre.svg
+share/icons/hicolor/scalable/apps/menulibre.svg
+share/locale/ca/LC_MESSAGES/menulibre.mo
+share/locale/cs/LC_MESSAGES/menulibre.mo
+share/locale/da/LC_MESSAGES/menulibre.mo
+share/locale/de/LC_MESSAGES/menulibre.mo
+share/locale/el/LC_MESSAGES/menulibre.mo
+share/locale/en_AU/LC_MESSAGES/menulibre.mo
+share/locale/en_GB/LC_MESSAGES/menulibre.mo
+share/locale/eo/LC_MESSAGES/menulibre.mo
+share/locale/es/LC_MESSAGES/menulibre.mo
+share/locale/eu/LC_MESSAGES/menulibre.mo
+share/locale/fi/LC_MESSAGES/menulibre.mo
+share/locale/fr/LC_MESSAGES/menulibre.mo
+share/locale/fy/LC_MESSAGES/menulibre.mo
+share/locale/gl/LC_MESSAGES/menulibre.mo
+share/locale/he/LC_MESSAGES/menulibre.mo
+share/locale/hr/LC_MESSAGES/menulibre.mo
+share/locale/is/LC_MESSAGES/menulibre.mo
+share/locale/it/LC_MESSAGES/menulibre.mo
+share/locale/ja/LC_MESSAGES/menulibre.mo
+share/locale/kk/LC_MESSAGES/menulibre.mo
+share/locale/ko/LC_MESSAGES/menulibre.mo
+share/locale/lt/LC_MESSAGES/menulibre.mo
+share/locale/ml/LC_MESSAGES/menulibre.mo
+share/locale/ms/LC_MESSAGES/menulibre.mo
+share/locale/nb/LC_MESSAGES/menulibre.mo
+share/locale/nl/LC_MESSAGES/menulibre.mo
+share/locale/pl/LC_MESSAGES/menulibre.mo
+share/locale/pt/LC_MESSAGES/menulibre.mo
+share/locale/pt_BR/LC_MESSAGES/menulibre.mo
+share/locale/pt_PT/LC_MESSAGES/menulibre.mo
+share/locale/ru/LC_MESSAGES/menulibre.mo
+share/locale/si/LC_MESSAGES/menulibre.mo
+share/locale/sk/LC_MESSAGES/menulibre.mo
+share/locale/sl/LC_MESSAGES/menulibre.mo
+share/locale/sr/LC_MESSAGES/menulibre.mo
+share/locale/sv/LC_MESSAGES/menulibre.mo
+share/locale/tr/LC_MESSAGES/menulibre.mo
+share/locale/uk/LC_MESSAGES/menulibre.mo
+share/locale/zh_CN/LC_MESSAGES/menulibre.mo
+share/locale/zh_HK/LC_MESSAGES/menulibre.mo
+share/locale/zh_TW/LC_MESSAGES/menulibre.mo
+%%DATADIR%%/ui/MenulibreWindow.ui
+share/pixmaps/menulibre.png