aboutsummaryrefslogtreecommitdiff
path: root/x11/openrgb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/openrgb/Makefile')
-rw-r--r--x11/openrgb/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11/openrgb/Makefile b/x11/openrgb/Makefile
new file mode 100644
index 000000000000..7fcc3f35e238
--- /dev/null
+++ b/x11/openrgb/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= openrgb
+PORTVERSION= 0.8
+CATEGORIES= x11
+
+MAINTAINER= vidar@karlsen.tech
+COMMENT= Software to control a multitude of RGB devices
+WWW= https://openrgb.org
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= git>0:devel/git \
+ hidapi>0:comms/hidapi \
+ mbedtls>0:security/mbedtls \
+ qt5-qmake>0:devel/qt5-qmake
+LIB_DEPENDS= libGL.so:graphics/libglvnd \
+ libhidapi.so:comms/hidapi \
+ libmbedcrypto.so:security/mbedtls \
+ libmbedtls.so:security/mbedtls \
+ libmbedx509.so:security/mbedtls
+
+USES= gmake gl qmake qt:5
+
+USE_GITLAB= yes
+GL_ACCOUNT= CalcProgrammer1
+GL_PROJECT= OpenRGB
+GL_TAGNAME= fb88964b8e514cdf4eb22da314e13f8db06a3636
+
+USE_GL= gl
+USE_QT= buildtools core gui linguisttools widgets
+
+PLIST_FILES= bin/openrgb
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/openrgb ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>