aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/alacritty/Makefile2
-rw-r--r--x11/albert/Makefile2
-rw-r--r--x11/autorandr/Makefile2
-rw-r--r--x11/dsbxinput/Makefile2
-rw-r--r--x11/gnome-desktop/Makefile2
-rw-r--r--x11/gnome-session/Makefile2
-rw-r--r--x11/gnome-shell-extensions/Makefile2
-rw-r--r--x11/gnome-shell/Makefile2
-rw-r--r--x11/gnome-terminal/Makefile2
-rw-r--r--x11/guake/Makefile2
-rw-r--r--x11/jgmenu/Makefile2
-rw-r--r--x11/kitty/Makefile2
-rw-r--r--x11/mate-dock-applet/Makefile2
-rw-r--r--x11/menulibre/Makefile2
-rw-r--r--x11/plasma5-plasma-desktop/Makefile2
-rw-r--r--x11/polybar/Makefile2
-rw-r--r--x11/py-caffeine-ng/Makefile2
-rw-r--r--x11/py-i3-quickterm/Makefile2
-rw-r--r--x11/py-i3ipc/Makefile2
-rw-r--r--x11/py-mouseinfo/Makefile2
-rw-r--r--x11/py-pyautogui/Makefile2
-rw-r--r--x11/py-pynput/Makefile2
-rw-r--r--x11/py-pyscreenshot/Makefile2
-rw-r--r--x11/py-pyscreeze/Makefile2
-rw-r--r--x11/py-pyvirtualdisplay/Makefile2
-rw-r--r--x11/py-screeninfo/Makefile2
-rw-r--r--x11/py-xcffib/Makefile2
-rw-r--r--x11/py-xdot/Makefile2
-rw-r--r--x11/terminator/Makefile2
-rw-r--r--x11/terminology/Makefile2
-rw-r--r--x11/ulauncher/Makefile2
-rw-r--r--x11/virglrenderer/Makefile2
-rw-r--r--x11/wezterm/Makefile2
-rw-r--r--x11/workrave/Makefile2
-rw-r--r--x11/xfce4-screensaver/Makefile2
-rw-r--r--x11/xfce4-windowck-plugin/Makefile2
-rw-r--r--x11/xkeyboard-config/Makefile2
-rw-r--r--x11/xpra-html5/Makefile2
-rw-r--r--x11/xpra/Makefile2
39 files changed, 39 insertions, 39 deletions
diff --git a/x11/alacritty/Makefile b/x11/alacritty/Makefile
index 48556608b53a..ff74e0d0aca0 100644
--- a/x11/alacritty/Makefile
+++ b/x11/alacritty/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libxkbcommon.so:x11/libxkbcommon
TEST_DEPENDS= dejavu>0:x11-fonts/dejavu
-USES= cargo localbase:ldflags python:3.6+,build ssl:build
+USES= cargo localbase:ldflags python:build ssl:build
USE_GITHUB= yes
CARGO_CRATES= adler-1.0.2 \
diff --git a/x11/albert/Makefile b/x11/albert/Makefile
index 70f4d6e777a1..a43e44b0d2a1 100644
--- a/x11/albert/Makefile
+++ b/x11/albert/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libmuparser.so:math/muparser \
libqalculate.so:math/libqalculate
RUN_DEPENDS= play:audio/sox
-USES= cmake compiler:c++20-lang gl localbase:ldflags pkgconfig python:3.7+ qt:6 xorg
+USES= cmake compiler:c++20-lang gl localbase:ldflags pkgconfig python qt:6 xorg
USE_GL= gl opengl
USE_QT= base declarative scxml svg
diff --git a/x11/autorandr/Makefile b/x11/autorandr/Makefile
index 1bbe602ef878..68a21b035c51 100644
--- a/x11/autorandr/Makefile
+++ b/x11/autorandr/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/gpl-3.0.txt
BUILD_DEPENDS= gsed:textproc/gsed
RUN_DEPENDS= xrandr:x11/xrandr
-USES= gmake pkgconfig python:3.3-3.10 shebangfix xorg
+USES= gmake pkgconfig python:3.8-3.10 shebangfix xorg
# Use GitHub instead of MASTER_SITES=PYPI to get additional files like
# the manual page and the license.
USE_GITHUB= yes
diff --git a/x11/dsbxinput/Makefile b/x11/dsbxinput/Makefile
index b0cddc918695..37503f05c981 100644
--- a/x11/dsbxinput/Makefile
+++ b/x11/dsbxinput/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= xinput:x11/xinput
-USES= pyqt:5 python:3.8+ qt:5
+USES= pyqt:5 python qt:5
USE_QT= linguisttools:build
USE_GITHUB= yes
GH_ACCOUNT= mrclksr
diff --git a/x11/gnome-desktop/Makefile b/x11/gnome-desktop/Makefile
index 728bfde1d34f..eb9c3907e626 100644
--- a/x11/gnome-desktop/Makefile
+++ b/x11/gnome-desktop/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
xkeyboard-config>=0:x11/xkeyboard-config
USES= bison cpe gettext gnome localbase:ldflags meson \
- pkgconfig python:3.4+ tar:xz xorg
+ pkgconfig python tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gtk30 gtk40 intltool introspection:build
USE_XORG= x11
USE_LDCONFIG= yes
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
index 582fc24e9e73..34803627a6d7 100644
--- a/x11/gnome-session/Makefile
+++ b/x11/gnome-session/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/console-kit-daemon:sysutils/consolekit2 \
PORTSCOUT= limitw:1,even
USES= compiler:c11 gettext gl gnome localbase:ldflags meson \
- pkgconfig python:3.6+,build tar:xz xorg
+ pkgconfig python:build tar:xz xorg
USE_GNOME= gnomedesktop3 gtk30
USE_XORG= ice sm x11 xcomposite xtrans
USE_GL= egl gl glesv2
diff --git a/x11/gnome-shell-extensions/Makefile b/x11/gnome-shell-extensions/Makefile
index ec969073855c..8948b2eca7ab 100644
--- a/x11/gnome-shell-extensions/Makefile
+++ b/x11/gnome-shell-extensions/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= gnome-shell>=42.0:x11/gnome-shell
PORTSCOUT= limitw:1,even
NO_ARCH= yes
-USES= gettext gnome meson pkgconfig python:3.8+ tar:xz
+USES= gettext gnome meson pkgconfig python tar:xz
USE_GNOME= glib20 gnomedesktop3
USE_LDCONFIG= yes
MESON_ARGS= -Dextension_set=all \
diff --git a/x11/gnome-shell/Makefile b/x11/gnome-shell/Makefile
index 1759eb4c83a5..c6d0c93fd969 100644
--- a/x11/gnome-shell/Makefile
+++ b/x11/gnome-shell/Makefile
@@ -43,7 +43,7 @@ RUN_DEPENDS= gdm:x11/gdm \
PORTSCOUT= limitw:1,even
USES= compiler:c11 cpe gettext gl gnome gstreamer libtool localbase \
- meson pathfix perl5 pkgconfig python:3.4+ shebangfix tar:xz \
+ meson pathfix perl5 pkgconfig python shebangfix tar:xz \
webplugin:native xorg
USE_GNOME= cairo evolutiondataserver3 gdkpixbuf2 gnomedesktop3 gtk40 \
introspection libxml2 libxslt:build
diff --git a/x11/gnome-terminal/Makefile b/x11/gnome-terminal/Makefile
index c8680ede7c47..e3a94cfc582f 100644
--- a/x11/gnome-terminal/Makefile
+++ b/x11/gnome-terminal/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
PORTSCOUT= limitw:1,even
-USES= cpe gettext gnome localbase meson pathfix pkgconfig python:3.7+ \
+USES= cpe gettext gnome localbase meson pathfix pkgconfig python \
tar:bz2 vala:build xorg
USE_GNOME= cairo dconf gdkpixbuf2 gtk30 intltool vte3
USE_XORG= x11
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index bf5758bb23f4..e3a44a810a9f 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
keybinder>0:x11/keybinder \
libnotify>0:devel/libnotify
-USES= cpe gmake gnome libtool localbase pathfix python:3.5+ \
+USES= cpe gmake gnome libtool localbase pathfix python \
shebangfix
USE_GNOME= glib20 gtk30 intltool vte3
USE_PYTHON= distutils noflavors
diff --git a/x11/jgmenu/Makefile b/x11/jgmenu/Makefile
index 38e343ed2002..298030fc5373 100644
--- a/x11/jgmenu/Makefile
+++ b/x11/jgmenu/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libharfbuzz.so:print/harfbuzz \
libpng.so:graphics/png
-USES= compiler:c11 gmake gnome pkgconfig python:3.4+ shebangfix xorg
+USES= compiler:c11 gmake gnome pkgconfig python shebangfix xorg
USE_GITHUB= yes
GH_ACCOUNT= johanmalm
USE_GNOME= cairo gdkpixbuf2 glib20 librsvg2 libxml2 pango
diff --git a/x11/kitty/Makefile b/x11/kitty/Makefile
index 1be55ed442a7..f14183f324ca 100644
--- a/x11/kitty/Makefile
+++ b/x11/kitty/Makefile
@@ -31,7 +31,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libxkbcommon.so:x11/libxkbcommon
USES= compiler:c11 cpe desktop-file-utils gettext-runtime gl gmake \
- go:modules pkgconfig python:3.5+ shebangfix ssl tar:xz terminfo \
+ go:modules pkgconfig python shebangfix ssl tar:xz terminfo \
xorg
CPE_VENDOR= kitty_project
GH_TUPLE= ALTree:bigfloat:38c8b72a9924:altree_bigfloat/vendor/github.com/ALTree/bigfloat \
diff --git a/x11/mate-dock-applet/Makefile b/x11/mate-dock-applet/Makefile
index 696b3dc0f2dc..034ad6463269 100644
--- a/x11/mate-dock-applet/Makefile
+++ b/x11/mate-dock-applet/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=0:graphics/py-cairo@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-xlib>=0:x11-toolkits/py-python-xlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}xdg>=0:devel/py-xdg@${PY_FLAVOR}
-USES= python:3.7+ autoreconf gettext gmake gnome libtool localbase \
+USES= python autoreconf gettext gmake gnome libtool localbase \
pkgconfig shebangfix tar:xz
USE_GITHUB= yes
diff --git a/x11/menulibre/Makefile b/x11/menulibre/Makefile
index 00dcdc9e5540..cc91bdbb98a1 100644
--- a/x11/menulibre/Makefile
+++ b/x11/menulibre/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
pkexec:sysutils/polkit \
${PYTHON_PKGNAMEPREFIX}psutil>=2.0:sysutils/py-psutil@${PY_FLAVOR}
-USES= desktop-file-utils gettext gnome python:3.4+
+USES= desktop-file-utils gettext gnome python
USE_GNOME= intltool pygobject3
USE_PYTHON= distutils
diff --git a/x11/plasma5-plasma-desktop/Makefile b/x11/plasma5-plasma-desktop/Makefile
index a141ebca0445..a629eac4b65a 100644
--- a/x11/plasma5-plasma-desktop/Makefile
+++ b/x11/plasma5-plasma-desktop/Makefile
@@ -29,7 +29,7 @@ BUILD_DEPENDS= xf86-input-evdev>0:x11-drivers/xf86-input-evdev \
wayland-protocols>=1.18:graphics/wayland-protocols
USES= cmake compiler:c++11-lib cpe desktop-file-utils gettext gnome \
- kde:5 pkgconfig python:3.5+,run qt:5 shebangfix tar:xz xorg
+ kde:5 pkgconfig python:run qt:5 shebangfix tar:xz xorg
USE_GNOME= glib20
USE_KDE= activities activities-stats archive attica auth baloo \
bookmarks codecs completion config configwidgets coreaddons \
diff --git a/x11/polybar/Makefile b/x11/polybar/Makefile
index 9f15c1d047e6..c0de6b457108 100644
--- a/x11/polybar/Makefile
+++ b/x11/polybar/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
# compiler:c++11-lang is needed for powerpc64
USES= cmake compiler:c++11-lang gnome localbase:ldflags \
- pkgconfig python:3.5+,build xorg
+ pkgconfig python:build xorg
USE_GNOME= cairo
USE_XORG= xcb
diff --git a/x11/py-caffeine-ng/Makefile b/x11/py-caffeine-ng/Makefile
index e640753e3ca6..8f7ae1ef21ae 100644
--- a/x11/py-caffeine-ng/Makefile
+++ b/x11/py-caffeine-ng/Makefile
@@ -29,7 +29,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}flake8-bugbear>0:devel/py-flake8-bugbear@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}flake8-import-order>0:devel/py-flake8-import-order@${PY_FLAVOR}
-USES= desktop-file-utils gettext-tools gnome python:3.6-3.9
+USES= desktop-file-utils gettext-tools gnome python:3.8-3.9
USE_GNOME= gdkpixbuf2 gtk30 pygobject3
USE_PYTHON= autoplist distutils
diff --git a/x11/py-i3-quickterm/Makefile b/x11/py-i3-quickterm/Makefile
index 4db283eccfde..bd07d681c8e1 100644
--- a/x11/py-i3-quickterm/Makefile
+++ b/x11/py-i3-quickterm/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/lbonn/i3-quickterm
LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}i3ipc>2.0:x11/py-i3ipc@${PY_FLAVOR}
-USES= python:3.4+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/x11/py-i3ipc/Makefile b/x11/py-i3ipc/Makefile
index fa202ec0c0f2..b9f22e1957cd 100644
--- a/x11/py-i3ipc/Makefile
+++ b/x11/py-i3ipc/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-xlib>0:x11-toolkits/py-python-xlib@${PY_FLAVOR}
NO_ARCH= yes
-USES= python:3.4+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/x11/py-mouseinfo/Makefile b/x11/py-mouseinfo/Makefile
index f9a9fd9710c5..19be24cfd71d 100644
--- a/x11/py-mouseinfo/Makefile
+++ b/x11/py-mouseinfo/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-xlib>0:x11-toolkits/py-python-xlib@${
${PYTHON_PKGNAMEPREFIX}pyperclip>0:devel/py-pyperclip@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-USES= dos2unix python:3.6+
+USES= dos2unix python
USE_PYTHON= autoplist distutils
DOS2UNIX_GLOB= *.py
diff --git a/x11/py-pyautogui/Makefile b/x11/py-pyautogui/Makefile
index bea1a35ccb8b..7d021e8325c1 100644
--- a/x11/py-pyautogui/Makefile
+++ b/x11/py-pyautogui/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-xlib>0:x11-toolkits/py-python-xlib@${
${PYTHON_PKGNAMEPREFIX}pyscreeze>0:x11/py-pyscreeze@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mouseinfo>0:x11/py-mouseinfo@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/x11/py-pynput/Makefile b/x11/py-pynput/Makefile
index ded00786224e..8c8445987b03 100644
--- a/x11/py-pynput/Makefile
+++ b/x11/py-pynput/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.3.1:textproc/py-sphinx@${PY_FLAV
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-xlib>0:x11-toolkits/py-python-xlib@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/x11/py-pyscreenshot/Makefile b/x11/py-pyscreenshot/Makefile
index 7b5276421de6..52685a042a47 100644
--- a/x11/py-pyscreenshot/Makefile
+++ b/x11/py-pyscreenshot/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}easyprocess>0:devel/py-easyprocess@${PY_FLAVOR} \
${PY_PILLOW}
-USES= magick:6,run python:3.6+
+USES= magick:6,run python
NO_ARCH= yes
USE_PYTHON= autoplist distutils
diff --git a/x11/py-pyscreeze/Makefile b/x11/py-pyscreeze/Makefile
index 5594119b63c4..e298483e47d6 100644
--- a/x11/py-pyscreeze/Makefile
+++ b/x11/py-pyscreeze/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-USES= dos2unix python:3.6+
+USES= dos2unix python
USE_PYTHON= autoplist distutils
DOS2UNIX_GLOB= *.py
diff --git a/x11/py-pyvirtualdisplay/Makefile b/x11/py-pyvirtualdisplay/Makefile
index 95b88797643f..24bf684e0bb3 100644
--- a/x11/py-pyvirtualdisplay/Makefile
+++ b/x11/py-pyvirtualdisplay/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cog>=2.3:devel/py-cog@${PY_FLAVOR} \
${PY_PILLOW} \
xauth>0:x11/xauth
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist distutils
OPTIONS_SINGLE= BACKEND
diff --git a/x11/py-screeninfo/Makefile b/x11/py-screeninfo/Makefile
index da964ca5a0b3..17b01e901fb8 100644
--- a/x11/py-screeninfo/Makefile
+++ b/x11/py-screeninfo/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/rr-/screeninfo
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= python:3.6+
+USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/x11/py-xcffib/Makefile b/x11/py-xcffib/Makefile
index 6ae96edd4345..4786a3c6a255 100644
--- a/x11/py-xcffib/Makefile
+++ b/x11/py-xcffib/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:devel/py-cffi@${PY_FLAVOR} \
LIB_DEPENDS= libxcb.so:x11/libxcb
RUN_DEPENDS= ${BUILD_DEPENDS}
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/x11/py-xdot/Makefile b/x11/py-xdot/Makefile
index 12a3a6e24553..3641d8bdf81a 100644
--- a/x11/py-xdot/Makefile
+++ b/x11/py-xdot/Makefile
@@ -14,7 +14,7 @@ LICENSE= LGPL3+
RUN_DEPENDS= dot:graphics/graphviz \
${PYNUMPY}
-USES= gnome python:3.4+
+USES= gnome python
USE_PYTHON= autoplist distutils
USE_GNOME= cairo gtk30 pygobject3
diff --git a/x11/terminator/Makefile b/x11/terminator/Makefile
index 7276e12de518..902062acb12a 100644
--- a/x11/terminator/Makefile
+++ b/x11/terminator/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libkeybinder-3.0.so:x11/keybinder-gtk3 \
${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR} \
gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
-USES= gnome python:3.5+ shebangfix gettext
+USES= gnome python shebangfix gettext
USE_GNOME= intltool pygobject3 vte3
USE_PYTHON= autoplist distutils noflavors
diff --git a/x11/terminology/Makefile b/x11/terminology/Makefile
index 0e4d155486b9..7af99a9a4e31 100644
--- a/x11/terminology/Makefile
+++ b/x11/terminology/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libefl.so:devel/efl
-USES= compiler:c11 cpe meson pkgconfig tar:xz python:3.4+
+USES= compiler:c11 cpe meson pkgconfig tar:xz python
BINARY_ALIAS= python3=${PYTHON_CMD}
CPE_VENDOR= enlightenment
diff --git a/x11/ulauncher/Makefile b/x11/ulauncher/Makefile
index 20f167a141f7..4bb235401d61 100644
--- a/x11/ulauncher/Makefile
+++ b/x11/ulauncher/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
${LOCALBASE}/share/gir-1.0/WebKit2-4.0.gir:www/webkit2-gtk3 \
wmctrl:x11/wmctrl
-USES= gettext-tools gnome python:3.6+
+USES= gettext-tools gnome python
USE_GNOME= gtk30 intltool pygobject3
USE_PYTHON= autoplist distutils noflavors
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/x11/virglrenderer/Makefile b/x11/virglrenderer/Makefile
index d694418baf65..12081d6c4dba 100644
--- a/x11/virglrenderer/Makefile
+++ b/x11/virglrenderer/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libdrm.so:graphics/libdrm \
libepoxy.so:graphics/libepoxy
-USES= compiler:c++11-lang cpe gl meson pkgconfig python:3.5+
+USES= compiler:c++11-lang cpe gl meson pkgconfig python
CPE_VENDOR= ${PORTNAME}_project
USE_GITLAB= yes
USE_GL= gbm
diff --git a/x11/wezterm/Makefile b/x11/wezterm/Makefile
index eab7cc6a8888..dd1d2f8de2cf 100644
--- a/x11/wezterm/Makefile
+++ b/x11/wezterm/Makefile
@@ -50,7 +50,7 @@ PLIST_FILES+= share/site-terminfo/${PORTNAME:C,^.,&/&,}
OPTIONS_DEFINE= DOCS
-DOCS_USES= python:3.4+,build
+DOCS_USES= python:build
DOCS_BUILD_DEPENDS= mdbook:textproc/mdbook \
mdbook-linkcheck:textproc/mdbook-linkcheck \
mdbook-mermaid:textproc/mdbook-mermaid
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 85eac222f089..5afcffcef212 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -59,7 +59,7 @@ DISTRIBUTION_DESC= Build with networking support
DBUS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
boost-libs>0:devel/boost-libs
-DBUS_USES= python:3.5+,build
+DBUS_USES= python:build
DBUS_CONFIGURE_ENABLE= dbus
DISTRIBUTION_CONFIGURE_ENABLE= distribution
diff --git a/x11/xfce4-screensaver/Makefile b/x11/xfce4-screensaver/Makefile
index feadbc6b5dbd..5be8e5727f01 100644
--- a/x11/xfce4-screensaver/Makefile
+++ b/x11/xfce4-screensaver/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libxklavier.so:x11/libxklavier \
libharfbuzz.so:print/harfbuzz
-USES= compiler:c11 gettext-tools gl gmake gnome pkgconfig python:3.5+ \
+USES= compiler:c11 gettext-tools gl gmake gnome pkgconfig python \
shebangfix tar:bzip2 xfce xorg
USE_GL= gl
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool libwnck3
diff --git a/x11/xfce4-windowck-plugin/Makefile b/x11/xfce4-windowck-plugin/Makefile
index 6ab4ae0c44fb..edeaaf373476 100644
--- a/x11/xfce4-windowck-plugin/Makefile
+++ b/x11/xfce4-windowck-plugin/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
BUILD_DEPENDS= xdt-csource:devel/xfce4-dev-tools
-USES= gettext-tools gmake gnome libtool python:3.7+,build pkgconfig \
+USES= gettext-tools gmake gnome libtool python:build pkgconfig \
shebangfix tar:bzip2 xfce xorg
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 libwnck3 intltool
USE_XFCE= panel
diff --git a/x11/xkeyboard-config/Makefile b/x11/xkeyboard-config/Makefile
index 97062518d681..d92c17abc89a 100644
--- a/x11/xkeyboard-config/Makefile
+++ b/x11/xkeyboard-config/Makefile
@@ -11,7 +11,7 @@ WWW= https://freedesktop.org/wiki/Software/XKeyboardConfig/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake gnome localbase pathfix perl5 python:3.6+,build \
+USES= gmake gnome localbase pathfix perl5 python:build \
shebangfix xorg-cat:data
NO_ARCH= yes
diff --git a/x11/xpra-html5/Makefile b/x11/xpra-html5/Makefile
index 216d9fd7c26d..16ea3bd06ffd 100644
--- a/x11/xpra-html5/Makefile
+++ b/x11/xpra-html5/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= brotli:archivers/brotli
-USES= python:3.6+,build
+USES= python:build
OPTIONS_DEFAULT= YUICOMPRESSOR
diff --git a/x11/xpra/Makefile b/x11/xpra/Makefile
index 58ff5ff590ac..2b314488e03a 100644
--- a/x11/xpra/Makefile
+++ b/x11/xpra/Makefile
@@ -34,7 +34,7 @@ RUN_DEPENDS= ${PY_PILLOW} \
Xvfb:x11-servers/xorg-server@xvfb
USES= desktop-file-utils gettext-runtime gnome localbase pkgconfig \
- python:3.6+ shared-mime-info shebangfix tar:xz xorg
+ python shared-mime-info shebangfix tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gtk30 pygobject3
USE_PYTHON= cython distutils noflavors