aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 03:39:21 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 04:19:04 +0000
commit042bcd8ac40e44a2b5f348a2524a3616610a4dd1 (patch)
tree7bc4d2952b9389c473da98fd03503e00770b3dc5
parent6916df3fc01a63dce046c1c324310b099a6593a6 (diff)
downloadports-042bcd8ac40e44a2b5f348a2524a3616610a4dd1.tar.gz
ports-042bcd8ac40e44a2b5f348a2524a3616610a4dd1.zip
security/py-oscrypto: Add py-oscrypto 1.2.1
oscrypto is a compilation-free, always up-to-date encryption library for Python that works on Windows, OS X, Linux and BSD. The library integrates with the encryption library that is part of the operating system. This means that a compiler is never needed, and OS security updates take care of patching vulnerabilities. WWW: https://github.com/wbond/oscrypto
-rw-r--r--security/Makefile1
-rw-r--r--security/py-oscrypto/Makefile22
-rw-r--r--security/py-oscrypto/distinfo3
-rw-r--r--security/py-oscrypto/pkg-descr8
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 02a89b045220..ea1be53cfb77 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -909,6 +909,7 @@
SUBDIR += py-oauthlib
SUBDIR += py-onlykey
SUBDIR += py-openssl
+ SUBDIR += py-oscrypto
SUBDIR += py-ospd
SUBDIR += py-ospd-openvas
SUBDIR += py-paramiko
diff --git a/security/py-oscrypto/Makefile b/security/py-oscrypto/Makefile
new file mode 100644
index 000000000000..801a6bcb2d63
--- /dev/null
+++ b/security/py-oscrypto/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= oscrypto
+PORTVERSION= 1.2.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Cryptographic operations using the OS crypto libraries
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=1.0.0:devel/py-asn1crypto@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-oscrypto/distinfo b/security/py-oscrypto/distinfo
new file mode 100644
index 000000000000..adeb9299aa72
--- /dev/null
+++ b/security/py-oscrypto/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1649423654
+SHA256 (oscrypto-1.2.1.tar.gz) = 7d2cca6235d89d1af6eb9cfcd4d2c0cb405849868157b2f7b278beb644d48694
+SIZE (oscrypto-1.2.1.tar.gz) = 180998
diff --git a/security/py-oscrypto/pkg-descr b/security/py-oscrypto/pkg-descr
new file mode 100644
index 000000000000..18ddb629aeb1
--- /dev/null
+++ b/security/py-oscrypto/pkg-descr
@@ -0,0 +1,8 @@
+oscrypto is a compilation-free, always up-to-date encryption library for Python
+that works on Windows, OS X, Linux and BSD.
+
+The library integrates with the encryption library that is part of the operating
+system. This means that a compiler is never needed, and OS security updates take
+care of patching vulnerabilities.
+
+WWW: https://github.com/wbond/oscrypto