aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-11-02 16:22:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-11-03 12:09:18 +0000
commit0b2033c53d9343a663f62171900c2d71fa5e9bb4 (patch)
tree83604281d793a1084fd73e1ca44cb1c56bab29f9
parent78cfe65ee0c8b6f73a06b8ca4333b2aa40e15f54 (diff)
downloadports-0b2033c53d9343a663f62171900c2d71fa5e9bb4.tar.gz
ports-0b2033c53d9343a663f62171900c2d71fa5e9bb4.zip
*/*: update conflicts on bin/xls2csv in 4 ports
Conflicting ports: - databases/xls2txt - math/libxls - textproc/catdoc - textproc/p5-Spreadsheet-Read PR: 248294 Reported by: jbeich
-rw-r--r--databases/xls2txt/Makefile2
-rw-r--r--math/libxls/Makefile2
-rw-r--r--textproc/catdoc/Makefile2
-rw-r--r--textproc/p5-Spreadsheet-Read/Makefile3
4 files changed, 6 insertions, 3 deletions
diff --git a/databases/xls2txt/Makefile b/databases/xls2txt/Makefile
index 21e4fd999705..4c811cbb2e31 100644
--- a/databases/xls2txt/Makefile
+++ b/databases/xls2txt/Makefile
@@ -61,6 +61,8 @@ EXECUTABLES= ${PORTNAME} xls2csv
PLIST_FILES= ${EXECUTABLES:S/^/bin\//}
+CONFLICTS_INSTALL= catdoc libxls p5-Spreadsheet-Read
+
post-install:
cd ${STAGEDIR}${PREFIX}/bin && ${STRIP_CMD} ${EXECUTABLES}
diff --git a/math/libxls/Makefile b/math/libxls/Makefile
index 7e7d2add3b0f..46b5cc343aea 100644
--- a/math/libxls/Makefile
+++ b/math/libxls/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD2CLAUSE
USES= compiler:c++11-lang cpe libtool
CPE_VENDOR= ${PORTNAME}_project
-CONFLICTS_INSTALL= catdoc
+CONFLICTS_INSTALL= catdoc p5-Spreadsheet-Read xls2txt
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/textproc/catdoc/Makefile b/textproc/catdoc/Makefile
index e593a403a661..e5cf8b95eed3 100644
--- a/textproc/catdoc/Makefile
+++ b/textproc/catdoc/Makefile
@@ -16,7 +16,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-install-root="${STAGEDIR}"
CPE_VENDOR= fossies
-CONFLICTS_INSTALL= libxls
+CONFLICTS_INSTALL= libxls p5-Spreadsheet-Read xls2txt
PORTDATA= *
diff --git a/textproc/p5-Spreadsheet-Read/Makefile b/textproc/p5-Spreadsheet-Read/Makefile
index 2ce04d3a1f7b..22386030b4fb 100644
--- a/textproc/p5-Spreadsheet-Read/Makefile
+++ b/textproc/p5-Spreadsheet-Read/Makefile
@@ -22,7 +22,8 @@ TEST_DEPENDS= p5-Test-NoWarnings>0:devel/p5-Test-NoWarnings
USES= perl5 tar:tgz
USE_PERL5= configure
-
NO_ARCH= yes
+CONFLICTS_INSTALL= catdoc libxls xls2txt
+
.include <bsd.port.mk>