aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/xls2txt/Makefile2
-rw-r--r--math/libxls/Makefile2
-rw-r--r--textproc/catdoc/Makefile2
-rw-r--r--textproc/p5-Spreadsheet-Read/Makefile3
4 files changed, 6 insertions, 3 deletions
diff --git a/databases/xls2txt/Makefile b/databases/xls2txt/Makefile
index 21e4fd999705..4c811cbb2e31 100644
--- a/databases/xls2txt/Makefile
+++ b/databases/xls2txt/Makefile
@@ -61,6 +61,8 @@ EXECUTABLES= ${PORTNAME} xls2csv
PLIST_FILES= ${EXECUTABLES:S/^/bin\//}
+CONFLICTS_INSTALL= catdoc libxls p5-Spreadsheet-Read
+
post-install:
cd ${STAGEDIR}${PREFIX}/bin && ${STRIP_CMD} ${EXECUTABLES}
diff --git a/math/libxls/Makefile b/math/libxls/Makefile
index 7e7d2add3b0f..46b5cc343aea 100644
--- a/math/libxls/Makefile
+++ b/math/libxls/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD2CLAUSE
USES= compiler:c++11-lang cpe libtool
CPE_VENDOR= ${PORTNAME}_project
-CONFLICTS_INSTALL= catdoc
+CONFLICTS_INSTALL= catdoc p5-Spreadsheet-Read xls2txt
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/textproc/catdoc/Makefile b/textproc/catdoc/Makefile
index e593a403a661..e5cf8b95eed3 100644
--- a/textproc/catdoc/Makefile
+++ b/textproc/catdoc/Makefile
@@ -16,7 +16,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-install-root="${STAGEDIR}"
CPE_VENDOR= fossies
-CONFLICTS_INSTALL= libxls
+CONFLICTS_INSTALL= libxls p5-Spreadsheet-Read xls2txt
PORTDATA= *
diff --git a/textproc/p5-Spreadsheet-Read/Makefile b/textproc/p5-Spreadsheet-Read/Makefile
index 2ce04d3a1f7b..22386030b4fb 100644
--- a/textproc/p5-Spreadsheet-Read/Makefile
+++ b/textproc/p5-Spreadsheet-Read/Makefile
@@ -22,7 +22,8 @@ TEST_DEPENDS= p5-Test-NoWarnings>0:devel/p5-Test-NoWarnings
USES= perl5 tar:tgz
USE_PERL5= configure
-
NO_ARCH= yes
+CONFLICTS_INSTALL= catdoc libxls xls2txt
+
.include <bsd.port.mk>