aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-25 16:33:10 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-25 16:34:17 +0000
commit0ddbe884d6cb61533e4946ab827937a1f1c4d23b (patch)
tree44d76502fbdb08df43e53ac1ab6e370d56c360d6
parentbcf8e8efee0a09688980876efa565921169bdbca (diff)
downloadports-0ddbe884d6cb61533e4946ab827937a1f1c4d23b.tar.gz
ports-0ddbe884d6cb61533e4946ab827937a1f1c4d23b.zip
UNBREAK some ports with php80
- Pet portclippy/portfmt Approved by: portmgr (blanket infrastructure) Sponsored by: Bounce Experts
-rw-r--r--audio/ampache/Makefile2
-rw-r--r--deskutils/moregroupware/Makefile24
-rw-r--r--dns/dns-ui/Makefile2
-rw-r--r--mail/roundcube-automatic_addressbook/Makefile9
-rw-r--r--mail/roundcube-calendar-kolab/Makefile2
-rw-r--r--mail/roundcube-carddav/Makefile2
-rw-r--r--mail/roundcube-html5_notifier/Makefile11
-rw-r--r--mail/roundcube-login_info/Makefile12
-rw-r--r--mail/roundcube-mobilecube/Makefile9
-rw-r--r--mail/roundcube-mvision2/Makefile6
-rw-r--r--mail/roundcube-sauserprefs/Makefile8
-rw-r--r--mail/roundcube-thunderbird_labels/Makefile11
-rw-r--r--mail/roundcube-umich/Makefile8
-rw-r--r--mail/roundcube-veximaccountadmin/Makefile12
-rw-r--r--mail/roundcube-yubikey_auth/Makefile11
-rw-r--r--net/pear-Auth_RADIUS/Makefile3
-rw-r--r--www/glpi/Makefile2
-rw-r--r--www/mediawiki135/Makefile1
-rw-r--r--www/moodle310/Makefile4
-rw-r--r--www/moodle311/Makefile4
-rw-r--r--www/moodle39/Makefile4
-rw-r--r--www/phpgroupware/Makefile2
22 files changed, 72 insertions, 77 deletions
diff --git a/audio/ampache/Makefile b/audio/ampache/Makefile
index a998f8480eee..5c64920cb9ca 100644
--- a/audio/ampache/Makefile
+++ b/audio/ampache/Makefile
@@ -14,7 +14,7 @@ LICENSE= AGPLv3+
USES= cpe zip gettext php:flavors mysql
USE_PHP= pdo pdo_mysql hash session json intl simplexml curl dom xml
-IGNORE_WITH_PHP=73 80
+IGNORE_WITH_PHP=73
CONFLICTS_INSTALL= ampache-php* # etc/periodic/daily/500.ampache-cron man/man1/ampache.1.gz
diff --git a/deskutils/moregroupware/Makefile b/deskutils/moregroupware/Makefile
index b2688f51e9db..587c1b913fcd 100644
--- a/deskutils/moregroupware/Makefile
+++ b/deskutils/moregroupware/Makefile
@@ -10,34 +10,30 @@ DISTNAME= ${PORTNAME}-core-${PORTVERSION}
MAINTAINER= eksffa@freebsdbrasil.com.br
COMMENT= Web based GroupWare system
-USES= gettext php:mod
+USES= gettext php:mod
WANT_PGSQL= server
# php extensions
-USE_PHP= curl \
- gd \
- pcre \
- session \
- xml
-IGNORE_WITH_PHP= 80 81
+USE_PHP= curl gd pcre session xml
+IGNORE_WITH_PHP= 81
SHAREOWN= ${WWWOWN}
SHAREGRP= ${WWWGRP}
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS_DEFINE= ADDONS NLS
+OPTIONS_DEFINE= ADDONS NLS
OPTIONS_DEFAULT= MYSQL
-OPTIONS_SINGLE= DB
-OPTIONS_SINGLE_DB= PGSQL MYSQL
-OPTIONS_SUB= yes
+OPTIONS_SINGLE= DB
+OPTIONS_SINGLE_DB= MYSQL PGSQL
+OPTIONS_SUB= yes
ADDONS_DESC= install additional workgroup features (addons)
ADDONS_DISTFILES= ${PORTNAME}-addons-${PORTVERSION}${EXTRACT_SUFX}
-MYSQL_USES= mysql:server
+MYSQL_USES= mysql:server
NLS_USES= gettext
-PGSQL_USES= pgsql
+PGSQL_USES= pgsql
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
diff --git a/dns/dns-ui/Makefile b/dns/dns-ui/Makefile
index 667802901c5d..a826cff26164 100644
--- a/dns/dns-ui/Makefile
+++ b/dns/dns-ui/Makefile
@@ -11,7 +11,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= pgsql php:mod,cli
-IGNORE_WITH_PHP= 80 81
+IGNORE_WITH_PHP= 81
SUB_FILES= pkg-message
diff --git a/mail/roundcube-automatic_addressbook/Makefile b/mail/roundcube-automatic_addressbook/Makefile
index 9cd38f1342e9..4694481de524 100644
--- a/mail/roundcube-automatic_addressbook/Makefile
+++ b/mail/roundcube-automatic_addressbook/Makefile
@@ -12,18 +12,19 @@ LICENSE= GPLv3
RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.8:mail/roundcube@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=80 81
USE_GITHUB= yes
GH_ACCOUNT= sblaisot
+IGNORE_WITH_PHP= 81
-NO_BUILD= yes
+WWWDIR= ${RCDIR}/plugins/automatic_addressbook
NO_ARCH= yes
+NO_BUILD= yes
RCDIR= ${PREFIX}/www/roundcube
-WWWDIR= ${RCDIR}/plugins/automatic_addressbook
SUB_FILES= pkg-message
-SUB_LIST= RCDIR=${RCDIR} PLUGINDIR=${WWWDIR}
+SUB_LIST= PLUGINDIR=${WWWDIR} \
+ RCDIR=${RCDIR}
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
diff --git a/mail/roundcube-calendar-kolab/Makefile b/mail/roundcube-calendar-kolab/Makefile
index 8befb02baf4c..d39ca777c304 100644
--- a/mail/roundcube-calendar-kolab/Makefile
+++ b/mail/roundcube-calendar-kolab/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=80 81
+IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/roundcube-carddav/Makefile b/mail/roundcube-carddav/Makefile
index 47201a70b408..4ae6e494e660 100644
--- a/mail/roundcube-carddav/Makefile
+++ b/mail/roundcube-carddav/Makefile
@@ -23,7 +23,7 @@ NO_BUILD= yes
NO_ARCH= yes
USE_PHP= curl dom simplexml sockets tokenizer xml xmlreader xmlwriter
-IGNORE_WITH_PHP=80 81
+IGNORE_WITH_PHP=81
WWWDIR= ${PREFIX}/www/roundcube/plugins/carddav
diff --git a/mail/roundcube-html5_notifier/Makefile b/mail/roundcube-html5_notifier/Makefile
index c87fc8ffaa22..69f8472b927e 100644
--- a/mail/roundcube-html5_notifier/Makefile
+++ b/mail/roundcube-html5_notifier/Makefile
@@ -10,18 +10,17 @@ COMMENT= HTML5 desktop notifier plugin for roundcube
LICENSE= GPLv3
-RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
BUILD_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
-USES= php:flavors
-IGNORE_WITH_PHP=80 81
+USES= php:flavors
USE_GITHUB= yes
GH_ACCOUNT= stremlau
-
-NO_BUILD= yes
-NO_ARCH= yes
+IGNORE_WITH_PHP= 81
WWWDIR= ${PREFIX}/www/roundcube/plugins/${PORTNAME}
+NO_ARCH= yes
+NO_BUILD= yes
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
diff --git a/mail/roundcube-login_info/Makefile b/mail/roundcube-login_info/Makefile
index 5e39c3c6d647..55c6d035b549 100644
--- a/mail/roundcube-login_info/Makefile
+++ b/mail/roundcube-login_info/Makefile
@@ -16,15 +16,17 @@ LICENSE= GPLv2
RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.5:mail/roundcube@${PHP_FLAVOR}
-USES= php:flavors
-IGNORE_WITH_PHP=80 81
-NO_BUILD= yes
-NO_ARCH= yes
+USES= php:flavors
+IGNORE_WITH_PHP= 81
WWWDIR= ${LOCALBASE}/www/roundcube
+NO_ARCH= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/login_info
+
PLUGDIR= ${WWWDIR}/plugins/login_info
PLIST_SUB+= PLUGDIR="www/roundcube/plugins/login_info"
-WRKSRC= ${WRKDIR}/login_info
do-install:
@${ECHO} "Installing in ${PLUGDIR}"
diff --git a/mail/roundcube-mobilecube/Makefile b/mail/roundcube-mobilecube/Makefile
index db5c932e0d82..9e3b437c9b11 100644
--- a/mail/roundcube-mobilecube/Makefile
+++ b/mail/roundcube-mobilecube/Makefile
@@ -5,8 +5,8 @@ PORTVERSION= ${THEME_VERSION}.${THEME_BUILD}
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${THEME_VERSION}%20Beta/Build%20%23${THEME_BUILD}/
PKGNAMEPREFIX= roundcube-
-DISTNAME= MobileCubeBeta%23${THEME_BUILD}
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+DISTNAME= MobileCubeBeta%23${THEME_BUILD}
MAINTAINER= ports@FreeBSD.org
COMMENT= Theme for RoundCube Web Mail
@@ -17,12 +17,13 @@ THEME_VERSION?= 3.1.0
THEME_BUILD?= 030110A
USES= php:flavors zip
-IGNORE_WITH_PHP=80 81
-NO_BUILD= yes
+IGNORE_WITH_PHP= 81
+
+WWWDIR?= ${PREFIX}/www/roundcube/skins/MobileCube
NO_ARCH= yes
+NO_BUILD= yes
WRKSRC= ${WRKDIR}/MobileCubeBeta\#${THEME_BUILD}
-WWWDIR?= ${PREFIX}/www/roundcube/skins/MobileCube
post-patch:
${FIND} ${WRKSRC} -type f -name '*.orig' -or -name '.DS_Store' -delete
diff --git a/mail/roundcube-mvision2/Makefile b/mail/roundcube-mvision2/Makefile
index 43d4a0320a1d..81a02ac49ea7 100644
--- a/mail/roundcube-mvision2/Makefile
+++ b/mail/roundcube-mvision2/Makefile
@@ -15,11 +15,11 @@ COMMENT= Theme for RoundCube Web Mail
RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.2:mail/roundcube@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=80 81
-NO_BUILD= yes
-NO_ARCH= yes
+IGNORE_WITH_PHP= 81
WWWDIR?= ${PREFIX}/www/roundcube/skins/mvision2_en
+NO_ARCH= yes
+NO_BUILD= yes
SUB_FILES= pkg-message
diff --git a/mail/roundcube-sauserprefs/Makefile b/mail/roundcube-sauserprefs/Makefile
index 573db90381f4..91edda8bb0b4 100644
--- a/mail/roundcube-sauserprefs/Makefile
+++ b/mail/roundcube-sauserprefs/Makefile
@@ -17,12 +17,12 @@ LICENSE= GPLv3
RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.8:mail/roundcube@${PHP_FLAVOR}
-USES= php:flavors
-IGNORE_WITH_PHP=80 81
-NO_BUILD= yes
-NO_ARCH= yes
+USES= php:flavors
+IGNORE_WITH_PHP= 81
WWWDIR= ${PREFIX}/www/roundcube/plugins/sauserprefs
+NO_ARCH= yes
+NO_BUILD= yes
do-install:
${MKDIR} ${STAGEDIR}/${WWWDIR}
diff --git a/mail/roundcube-thunderbird_labels/Makefile b/mail/roundcube-thunderbird_labels/Makefile
index 1aeda69878cd..c4bdc84f1097 100644
--- a/mail/roundcube-thunderbird_labels/Makefile
+++ b/mail/roundcube-thunderbird_labels/Makefile
@@ -15,15 +15,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.4.0:mail/roundcube@${PHP_FLAVOR}
-USES= php:flavors
-IGNORE_WITH_PHP=80 81
-
-NO_BUILD= yes
-NO_ARCH= yes
-
+USES= php:flavors
USE_GITHUB= yes
GH_ACCOUNT= mike-kfed
GH_PROJECT= roundcube-thunderbird_labels
+IGNORE_WITH_PHP= 81
+
+NO_ARCH= yes
+NO_BUILD= yes
PLUGINDIR= ${WWWDIR:S,/${PORTNAME}$$,,}/roundcube/plugins/${PORTNAME}
PLUGINDIR_REL= ${WWWDIR_REL:S,/${PORTNAME}$$,,}/roundcube/plugins/${PORTNAME}
diff --git a/mail/roundcube-umich/Makefile b/mail/roundcube-umich/Makefile
index 1e6d080bfc81..55544f4c9c20 100644
--- a/mail/roundcube-umich/Makefile
+++ b/mail/roundcube-umich/Makefile
@@ -10,16 +10,16 @@ PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Theme for RoundCube Web Mail
-LICENSE= GPLv3+ # same as roundcube's
+LICENSE= GPLv3+ # same as roundcube's
RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.2:mail/roundcube@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=80 81
-NO_BUILD= yes
-NO_ARCH= yes
+IGNORE_WITH_PHP= 81
WWWDIR?= ${PREFIX}/www/roundcube/skins/umich
+NO_ARCH= yes
+NO_BUILD= yes
post-patch:
@${FIND} ${WRKSRC} -type f -name '*.orig' -delete
diff --git a/mail/roundcube-veximaccountadmin/Makefile b/mail/roundcube-veximaccountadmin/Makefile
index 6e340fe3e892..fae67c6954ae 100644
--- a/mail/roundcube-veximaccountadmin/Makefile
+++ b/mail/roundcube-veximaccountadmin/Makefile
@@ -16,15 +16,17 @@ LICENSE= GPLv3
RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.9:mail/roundcube@${PHP_FLAVOR}
-USES= php:flavors
-IGNORE_WITH_PHP=80 81
+USES= php:flavors
+IGNORE_WITH_PHP= 81
+
+WWWDIR= ${PREFIX}/www/roundcube
+REINPLACE_ARGS= -i ''
NO_BUILD= yes
+WRKSRC= ${WRKDIR}/veximaccountadmin
+
PLIST_SUB+= PLUGINDIR="${PLUGINDIR}"
-WWWDIR= ${PREFIX}/www/roundcube
PLUGINDIR= ${WWWDIR}/plugins/${PORTNAME}
-WRKSRC= ${WRKDIR}/veximaccountadmin
-REINPLACE_ARGS=-i ''
post-patch:
@${REINPLACE_CMD} -e 's/new rcube_mdb2/new rcube_db/g' ${WRKSRC}/veximaccountadmin.php
diff --git a/mail/roundcube-yubikey_auth/Makefile b/mail/roundcube-yubikey_auth/Makefile
index 1b73edd33102..17991e7a02ce 100644
--- a/mail/roundcube-yubikey_auth/Makefile
+++ b/mail/roundcube-yubikey_auth/Makefile
@@ -15,19 +15,16 @@ BUILD_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=80 81
-
-USE_PHP= curl
-
USE_GITHUB= yes
GH_ACCOUNT= northox
GH_PROJECT= roundcube-yubikey-plugin
GH_TAGNAME= 383bbb3
-
-NO_BUILD= yes
-NO_ARCH= yes
+USE_PHP= curl
+IGNORE_WITH_PHP= 81
WWWDIR= ${PREFIX}/www/roundcube/plugins/roundcube_yubikey_authentication
+NO_ARCH= yes
+NO_BUILD= yes
post-patch:
${REINPLACE_CMD} -e 's/roundcube_yubikey_plugin/YubiKey OTP/g' \
diff --git a/net/pear-Auth_RADIUS/Makefile b/net/pear-Auth_RADIUS/Makefile
index 08cafa055872..5436203c35bd 100644
--- a/net/pear-Auth_RADIUS/Makefile
+++ b/net/pear-Auth_RADIUS/Makefile
@@ -9,8 +9,7 @@ COMMENT= PEAR wrapper classes for the RADIUS PECL
LICENSE= BSD3CLAUSE
-USE_PHP= radius
USES= pear php:flavors
-IGNORE_WITH_PHP= 80
+USE_PHP= radius
.include <bsd.port.mk>
diff --git a/www/glpi/Makefile b/www/glpi/Makefile
index 9894bc8f3210..d9a1f7097595 100644
--- a/www/glpi/Makefile
+++ b/www/glpi/Makefile
@@ -15,7 +15,7 @@ USES= cpe gettext php tar:tgz
CPE_VENDOR= glpi-project
USE_PHP= bz2 ctype curl exif fileinfo gd iconv intl json mbstring \
mysqli opcache openssl session simplexml sodium xml xmlrpc zip zlib
-IGNORE_WITH_PHP= 80 81
+IGNORE_WITH_PHP= 81
NO_ARCH= yes
NO_BUILD= yes
diff --git a/www/mediawiki135/Makefile b/www/mediawiki135/Makefile
index 18314ab06358..a8a77c14b580 100644
--- a/www/mediawiki135/Makefile
+++ b/www/mediawiki135/Makefile
@@ -23,7 +23,6 @@ hhvm_OLD_CMD= /usr/bin/hhvm
hhvm_CMD= ${LOCALBASE}/bin/hhvm # not installed by anything yet
USE_PHP= ctype dom fileinfo filter hash iconv intl json mbstring openssl \
pcre readline session xml xmlreader zlib
-IGNORE_WITH_PHP=80
MEDIAWIKIDIR?= www/mediawiki
NO_BUILD= yes
diff --git a/www/moodle310/Makefile b/www/moodle310/Makefile
index 9334981b9d06..d8afd81eba3b 100644
--- a/www/moodle310/Makefile
+++ b/www/moodle310/Makefile
@@ -17,9 +17,9 @@ USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
xml xmlreader xmlrpc zip zlib
-WRKSRC= ${WRKDIR}/moodle
+IGNORE_WITH_PHP= 81
-IGNORE_WITH_PHP= 80 81
+WRKSRC= ${WRKDIR}/moodle
OPTIONS_SINGLE= BACKEND
OPTIONS_SINGLE_BACKEND= MYSQL PGSQL MSSQL
diff --git a/www/moodle311/Makefile b/www/moodle311/Makefile
index da861747fbdd..e655b0439233 100644
--- a/www/moodle311/Makefile
+++ b/www/moodle311/Makefile
@@ -17,9 +17,9 @@ USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap sodium spl tokenizer \
xml xmlreader xmlrpc zip zlib
-WRKSRC= ${WRKDIR}/moodle
+IGNORE_WITH_PHP= 81
-IGNORE_WITH_PHP= 80 81
+WRKSRC= ${WRKDIR}/moodle
OPTIONS_SINGLE= BACKEND
OPTIONS_SINGLE_BACKEND= MYSQL PGSQL MSSQL
diff --git a/www/moodle39/Makefile b/www/moodle39/Makefile
index 350610058946..82eb91c883d0 100644
--- a/www/moodle39/Makefile
+++ b/www/moodle39/Makefile
@@ -17,9 +17,9 @@ USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
xml xmlreader xmlrpc zip zlib
-WRKSRC= ${WRKDIR}/moodle
+IGNORE_WITH_PHP= 81
-IGNORE_WITH_PHP= 80 81
+WRKSRC= ${WRKDIR}/moodle
OPTIONS_SINGLE= BACKEND
OPTIONS_SINGLE_BACKEND= MYSQL PGSQL MSSQL
diff --git a/www/phpgroupware/Makefile b/www/phpgroupware/Makefile
index 908f5603c7e1..f7ce450b1d1f 100644
--- a/www/phpgroupware/Makefile
+++ b/www/phpgroupware/Makefile
@@ -7,7 +7,7 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= Web based GroupWare system
USES= php:mod tar:bzip2
-IGNORE_WITH_PHP= 80 81
+IGNORE_WITH_PHP= 81
NO_BUILD= yes
NO_ARCH= yes