aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-12-14 17:58:11 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-12-14 18:07:00 +0000
commit0ee4d03db38fe6b927e6531d039841c985306106 (patch)
tree891494108f3a9b06952bbfd031b0c002e1a1067d
parent31b0a37de2f4de1b1b33a4a0856e538321954ede (diff)
downloadports-0ee4d03db38fe6b927e6531d039841c985306106.tar.gz
ports-0ee4d03db38fe6b927e6531d039841c985306106.zip
devel/bullet: update to 3.21 release
While here, take maintainership Approved by: acm (previous maintainer, by mail) Sponsored by: Netzkommune GmbH
-rw-r--r--devel/bullet/Makefile35
-rw-r--r--devel/bullet/distinfo6
-rw-r--r--devel/bullet/files/patch-CMakeLists.txt17
-rw-r--r--devel/bullet/files/patch-MANIFEST.in19
-rw-r--r--devel/bullet/files/patch-examples_CMakeLists.txt12
-rw-r--r--devel/bullet/files/patch-examples_ThirdPartyLibs_Gwen_Macros.h26
-rw-r--r--devel/bullet/pkg-plist115
7 files changed, 134 insertions, 96 deletions
diff --git a/devel/bullet/Makefile b/devel/bullet/Makefile
index 3a6d18fbf4bb..41c96146bc0f 100644
--- a/devel/bullet/Makefile
+++ b/devel/bullet/Makefile
@@ -1,36 +1,55 @@
# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
PORTNAME= bullet
-PORTVERSION= 2.86.1
-PORTREVISION= 5
+PORTVERSION= 3.21
CATEGORIES= devel
-MAINTAINER= acm@FreeBSD.org
+MAINTAINER= fluffy@FreeBSD.org
COMMENT= 3D collision detection and rigid body dynamics library
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USE_GITHUB= yes
-GH_ACCOUNT= bulletphysics
-GH_PROJECT= bullet3
-
USES= cmake compiler:c++11-lang gl xorg
USE_GL= gl glu glut
USE_LDCONFIG= yes
USE_XORG= x11
+USE_GITHUB= yes
+GH_ACCOUNT= bulletphysics
+GH_PROJECT= bullet3
+
CMAKE_ARGS= -DBUILD_SHARED_LIBS:BOOL=ON \
-DINSTALL_LIBS:BOOL=ON \
-DINSTALL_EXTRA_LIBS:BOOL=ON \
+ -DBUILD_EXTRAS:BOOL=OFF \
+ -DUSE_DOUBLE_PRECISION:BOOL=ON \
+ -DUSE_GRAPHICAL_BENCHMARK:BOOL=OFF \
+ -DENABLE_VHACD:BOOL=OFF \
+ -DBUILD_BULLET3:BOOL=ON \
+ -DBUILD_CPU_DEMOS:BOOL=OFF \
-DBUILD_BULLET2_DEMOS:BOOL=OFF \
-DBUILD_BULLET3_DEMOS:BOOL=OFF \
- -DBUILD_UNIT_TESTS:BOOL=OFF
+ -DBUILD_PYBULLET:BOOL=OFF \
+ -DBUILD_OPENGL3_DEMOS:BOOL=OFF \
+ -DBUILD_BULLET_ROBOTICS_GUI_EXTRA:BOOL=OFF \
+ -DBUILD_UNIT_TESTS:BOOL=OFF \
+ -DBULLET2_MULTITHREADING:BOOL=ON \
+ -DBULLET2_USE_OPEN_MP_MULTITHREADING:BOOL=ON
+# -DBULLET2_USE_TBB_MULTITHREADING:BOOL=ON
PORTDOCS= *
OPTIONS_DEFINE= DOCS
+PLIST_SUB= LIB_VERSION=3.20
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e '/pybullet/d' \
+ ${WRKSRC}/MANIFEST.in
+ @${RM} -r ${WRKSRC}/examples/pybullet
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}/${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/*.pdf ${STAGEDIR}/${DOCSDIR}
diff --git a/devel/bullet/distinfo b/devel/bullet/distinfo
index b25b6434ff95..c2a020bb1b9c 100644
--- a/devel/bullet/distinfo
+++ b/devel/bullet/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500496996
-SHA256 (bulletphysics-bullet3-2.86.1_GH0.tar.gz) = c058b2e4321ba6adaa656976c1a138c07b18fc03b29f5b82880d5d8228fbf059
-SIZE (bulletphysics-bullet3-2.86.1_GH0.tar.gz) = 26065278
+TIMESTAMP = 1639487007
+SHA256 (bulletphysics-bullet3-3.21_GH0.tar.gz) = 49d1ee47aa8cbb0bc6bb459f0a4cfb9579b40e28f5c7d9a36c313e3031fb3965
+SIZE (bulletphysics-bullet3-3.21_GH0.tar.gz) = 133046747
diff --git a/devel/bullet/files/patch-CMakeLists.txt b/devel/bullet/files/patch-CMakeLists.txt
index de79033592ee..ebf05df310f7 100644
--- a/devel/bullet/files/patch-CMakeLists.txt
+++ b/devel/bullet/files/patch-CMakeLists.txt
@@ -1,6 +1,19 @@
---- CMakeLists.txt.orig 2016-01-08 22:36:41 UTC
+--- CMakeLists.txt.orig 2021-05-07 18:04:02 UTC
+++ CMakeLists.txt
-@@ -254,7 +254,7 @@ IF(INSTALL_LIBS)
+@@ -429,9 +429,9 @@ ENDIF(BUILD_OPENGL3_DEMOS)
+ OPTION(BUILD_BULLET2_DEMOS "Set when you want to build the Bullet 2 demos" ON)
+ IF(BUILD_BULLET2_DEMOS)
+
+- IF(EXISTS ${BULLET_PHYSICS_SOURCE_DIR}/examples AND IS_DIRECTORY ${BULLET_PHYSICS_SOURCE_DIR}/examples)
+- SUBDIRS(examples)
+- ENDIF()
++# IF(EXISTS ${BULLET_PHYSICS_SOURCE_DIR}/examples AND IS_DIRECTORY ${BULLET_PHYSICS_SOURCE_DIR}/examples)
++# SUBDIRS(examples)
++# ENDIF()
+
+ ENDIF(BUILD_BULLET2_DEMOS)
+
+@@ -470,7 +470,7 @@ IF(INSTALL_LIBS)
SET (LIB_DESTINATION "lib${LIB_SUFFIX}" CACHE STRING "Library directory name")
## the following are directories where stuff will be installed to
SET(INCLUDE_INSTALL_DIR "include/bullet/" CACHE PATH "The subdirectory to the header prefix")
diff --git a/devel/bullet/files/patch-MANIFEST.in b/devel/bullet/files/patch-MANIFEST.in
new file mode 100644
index 000000000000..4e326445dfa2
--- /dev/null
+++ b/devel/bullet/files/patch-MANIFEST.in
@@ -0,0 +1,19 @@
+--- MANIFEST.in.orig 2021-11-24 21:59:22 UTC
++++ MANIFEST.in
+@@ -1,16 +1,11 @@
+ include MANIFEST.in *.txt
+-recursive-include examples *.h
+-recursive-include examples *.hpp
+ recursive-include Extras *.h
+ recursive-include Extras *.hpp
+ recursive-include Extras *.inl
+ recursive-include src *.h
+ recursive-include src *.hpp
+ recursive-include src *.cpp
+-recursive-include examples/pybullet/gym *.*
+ include examples/ThirdPartyLibs/enet/unix.c
+ include examples/OpenGLWindow/*.*
+ recursive-include examples/SharedMemory/plugins *.*
+ recursive-include examples/ThirdPartyLibs/glad *.*
+-include examples/ThirdPartyLibs/enet/win32.c
+-recursive-include examples/ThirdPartyLibs/Eigen *
diff --git a/devel/bullet/files/patch-examples_CMakeLists.txt b/devel/bullet/files/patch-examples_CMakeLists.txt
new file mode 100644
index 000000000000..fa869d3a95f2
--- /dev/null
+++ b/devel/bullet/files/patch-examples_CMakeLists.txt
@@ -0,0 +1,12 @@
+--- examples/CMakeLists.txt.orig 2021-05-07 18:04:02 UTC
++++ examples/CMakeLists.txt
+@@ -1,8 +1,5 @@
+-SUBDIRS( HelloWorld BasicDemo)
++#SUBDIRS( HelloWorld BasicDemo)
+ IF(BUILD_BULLET3)
+ SUBDIRS( ExampleBrowser RobotSimulator SharedMemory ThirdPartyLibs/Gwen ThirdPartyLibs/BussIK ThirdPartyLibs/clsocket OpenGLWindow TwoJoint )
+ ENDIF()
+
+-IF(BUILD_PYBULLET)
+- SUBDIRS(pybullet)
+-ENDIF(BUILD_PYBULLET)
diff --git a/devel/bullet/files/patch-examples_ThirdPartyLibs_Gwen_Macros.h b/devel/bullet/files/patch-examples_ThirdPartyLibs_Gwen_Macros.h
index d11ff9daa76c..37d16b4aa50b 100644
--- a/devel/bullet/files/patch-examples_ThirdPartyLibs_Gwen_Macros.h
+++ b/devel/bullet/files/patch-examples_ThirdPartyLibs_Gwen_Macros.h
@@ -1,21 +1,11 @@
---- examples/ThirdPartyLibs/Gwen/Macros.h.orig 2017-02-17 23:43:38 UTC
+--- examples/ThirdPartyLibs/Gwen/Macros.h.orig 2021-05-07 18:04:02 UTC
+++ examples/ThirdPartyLibs/Gwen/Macros.h
-@@ -4,9 +4,6 @@
- #define GWEN_MACROS_H
- #include <stdlib.h>
- #include <stdarg.h>
--#ifndef __APPLE__
--#include <malloc.h>
--#endif //__APPLE__
- #include <memory.h>
- #include <algorithm>
+@@ -41,7 +41,7 @@
+ #define GwenUtil_OutputDebugWideString(lpOutputString) //wprintf( lpOutputString )
+ #define GwenUtil_WideStringToFloat(_Str) wcstof(_Str, NULL)
-@@ -38,7 +35,7 @@
- #define GwenUtil_OutputDebugWideString( lpOutputString ) //wprintf( lpOutputString )
- #define GwenUtil_WideStringToFloat( _Str ) wcstof(_Str, NULL)
+-#elif defined(__linux__) || defined(__GNUC__)
++#elif defined(__linux__) || defined(__GNUC__) || defined(__FreeBSD__)
--#elif defined(__linux__)
-+#elif defined(__linux__) || defined(__FreeBSD__)
-
- #define GwenUtil_VSNPrintFSafe( _DstBuf, _DstSize, _MaxCount, _Format, _ArgList ) vsnprintf( _DstBuf, _DstSize, _Format, _ArgList )
- #define GwenUtil_VSWPrintFSafe( _DstBuf, _SizeInWords, _Format, _ArgList ) vswprintf( _DstBuf, _SizeInWords, _Format, _ArgList )
+ #define GwenUtil_VSNPrintFSafe(_DstBuf, _DstSize, _MaxCount, _Format, _ArgList) vsnprintf(_DstBuf, _DstSize, _Format, _ArgList)
+ #ifdef _WIN32
diff --git a/devel/bullet/pkg-plist b/devel/bullet/pkg-plist
index cebc9f0e934d..615c1d48a89f 100644
--- a/devel/bullet/pkg-plist
+++ b/devel/bullet/pkg-plist
@@ -46,6 +46,7 @@ include/bullet/Bullet3Common/b3PoolAllocator.h
include/bullet/Bullet3Common/b3QuadWord.h
include/bullet/Bullet3Common/b3Quaternion.h
include/bullet/Bullet3Common/b3Random.h
+include/bullet/Bullet3Common/b3ResizablePool.h
include/bullet/Bullet3Common/b3Scalar.h
include/bullet/Bullet3Common/b3StackAlloc.h
include/bullet/Bullet3Common/b3Transform.h
@@ -91,7 +92,6 @@ include/bullet/Bullet3OpenCL/NarrowphaseCollision/b3ContactCache.h
include/bullet/Bullet3OpenCL/NarrowphaseCollision/b3ConvexHullContact.h
include/bullet/Bullet3OpenCL/NarrowphaseCollision/b3ConvexPolyhedronCL.h
include/bullet/Bullet3OpenCL/NarrowphaseCollision/b3GjkEpa.h
-include/bullet/Bullet3OpenCL/NarrowphaseCollision/b3GjkPairDetector.h
include/bullet/Bullet3OpenCL/NarrowphaseCollision/b3OptimizedBvh.h
include/bullet/Bullet3OpenCL/NarrowphaseCollision/b3QuantizedBvh.h
include/bullet/Bullet3OpenCL/NarrowphaseCollision/b3StridingMeshInterface.h
@@ -145,6 +145,7 @@ include/bullet/Bullet3OpenCL/RigidBody/kernels/solverSetup2.h
include/bullet/Bullet3OpenCL/RigidBody/kernels/solverUtils.h
include/bullet/Bullet3OpenCL/RigidBody/kernels/updateAabbsKernel.h
include/bullet/BulletCollision/BroadphaseCollision/btAxisSweep3.h
+include/bullet/BulletCollision/BroadphaseCollision/btAxisSweep3Internal.h
include/bullet/BulletCollision/BroadphaseCollision/btBroadphaseInterface.h
include/bullet/BulletCollision/BroadphaseCollision/btBroadphaseProxy.h
include/bullet/BulletCollision/BroadphaseCollision/btCollisionAlgorithm.h
@@ -163,6 +164,7 @@ include/bullet/BulletCollision/CollisionDispatch/btBoxBoxDetector.h
include/bullet/BulletCollision/CollisionDispatch/btCollisionConfiguration.h
include/bullet/BulletCollision/CollisionDispatch/btCollisionCreateFunc.h
include/bullet/BulletCollision/CollisionDispatch/btCollisionDispatcher.h
+include/bullet/BulletCollision/CollisionDispatch/btCollisionDispatcherMt.h
include/bullet/BulletCollision/CollisionDispatch/btCollisionObject.h
include/bullet/BulletCollision/CollisionDispatch/btCollisionObjectWrapper.h
include/bullet/BulletCollision/CollisionDispatch/btCollisionWorld.h
@@ -204,12 +206,14 @@ include/bullet/BulletCollision/CollisionShapes/btCylinderShape.h
include/bullet/BulletCollision/CollisionShapes/btEmptyShape.h
include/bullet/BulletCollision/CollisionShapes/btHeightfieldTerrainShape.h
include/bullet/BulletCollision/CollisionShapes/btMaterial.h
+include/bullet/BulletCollision/CollisionShapes/btMiniSDF.h
include/bullet/BulletCollision/CollisionShapes/btMinkowskiSumShape.h
include/bullet/BulletCollision/CollisionShapes/btMultiSphereShape.h
include/bullet/BulletCollision/CollisionShapes/btMultimaterialTriangleMeshShape.h
include/bullet/BulletCollision/CollisionShapes/btOptimizedBvh.h
include/bullet/BulletCollision/CollisionShapes/btPolyhedralConvexShape.h
include/bullet/BulletCollision/CollisionShapes/btScaledBvhTriangleMeshShape.h
+include/bullet/BulletCollision/CollisionShapes/btSdfCollisionShape.h
include/bullet/BulletCollision/CollisionShapes/btShapeHull.h
include/bullet/BulletCollision/CollisionShapes/btSphereShape.h
include/bullet/BulletCollision/CollisionShapes/btStaticPlaneShape.h
@@ -228,10 +232,13 @@ include/bullet/BulletCollision/Gimpact/btBoxCollision.h
include/bullet/BulletCollision/Gimpact/btClipPolygon.h
include/bullet/BulletCollision/Gimpact/btCompoundFromGimpact.h
include/bullet/BulletCollision/Gimpact/btContactProcessing.h
+include/bullet/BulletCollision/Gimpact/btContactProcessingStructs.h
include/bullet/BulletCollision/Gimpact/btGImpactBvh.h
+include/bullet/BulletCollision/Gimpact/btGImpactBvhStructs.h
include/bullet/BulletCollision/Gimpact/btGImpactCollisionAlgorithm.h
include/bullet/BulletCollision/Gimpact/btGImpactMassUtil.h
include/bullet/BulletCollision/Gimpact/btGImpactQuantizedBvh.h
+include/bullet/BulletCollision/Gimpact/btGImpactQuantizedBvhStructs.h
include/bullet/BulletCollision/Gimpact/btGImpactShape.h
include/bullet/BulletCollision/Gimpact/btGenericPoolAllocator.h
include/bullet/BulletCollision/Gimpact/btGeometryOperations.h
@@ -250,6 +257,7 @@ include/bullet/BulletCollision/Gimpact/gim_hash_table.h
include/bullet/BulletCollision/Gimpact/gim_linear_math.h
include/bullet/BulletCollision/Gimpact/gim_math.h
include/bullet/BulletCollision/Gimpact/gim_memory.h
+include/bullet/BulletCollision/Gimpact/gim_pair.h
include/bullet/BulletCollision/Gimpact/gim_radixsort.h
include/bullet/BulletCollision/Gimpact/gim_tri_collision.h
include/bullet/BulletCollision/NarrowPhaseCollision/btComputeGjkEpaPenetration.h
@@ -276,6 +284,7 @@ include/bullet/BulletCollision/NarrowPhaseCollision/btVoronoiSimplexSolver.h
include/bullet/BulletCollision/btBulletCollisionCommon.h
include/bullet/BulletDynamics/Character/btCharacterControllerInterface.h
include/bullet/BulletDynamics/Character/btKinematicCharacterController.h
+include/bullet/BulletDynamics/ConstraintSolver/btBatchedConstraints.h
include/bullet/BulletDynamics/ConstraintSolver/btConeTwistConstraint.h
include/bullet/BulletDynamics/ConstraintSolver/btConstraintSolver.h
include/bullet/BulletDynamics/ConstraintSolver/btContactConstraint.h
@@ -291,6 +300,7 @@ include/bullet/BulletDynamics/ConstraintSolver/btJacobianEntry.h
include/bullet/BulletDynamics/ConstraintSolver/btNNCGConstraintSolver.h
include/bullet/BulletDynamics/ConstraintSolver/btPoint2PointConstraint.h
include/bullet/BulletDynamics/ConstraintSolver/btSequentialImpulseConstraintSolver.h
+include/bullet/BulletDynamics/ConstraintSolver/btSequentialImpulseConstraintSolverMt.h
include/bullet/BulletDynamics/ConstraintSolver/btSliderConstraint.h
include/bullet/BulletDynamics/ConstraintSolver/btSolve2LinearConstraint.h
include/bullet/BulletDynamics/ConstraintSolver/btSolverBody.h
@@ -309,14 +319,18 @@ include/bullet/BulletDynamics/Featherstone/btMultiBodyConstraint.h
include/bullet/BulletDynamics/Featherstone/btMultiBodyConstraintSolver.h
include/bullet/BulletDynamics/Featherstone/btMultiBodyDynamicsWorld.h
include/bullet/BulletDynamics/Featherstone/btMultiBodyFixedConstraint.h
+include/bullet/BulletDynamics/Featherstone/btMultiBodyGearConstraint.h
+include/bullet/BulletDynamics/Featherstone/btMultiBodyInplaceSolverIslandCallback.h
include/bullet/BulletDynamics/Featherstone/btMultiBodyJointFeedback.h
include/bullet/BulletDynamics/Featherstone/btMultiBodyJointLimitConstraint.h
include/bullet/BulletDynamics/Featherstone/btMultiBodyJointMotor.h
include/bullet/BulletDynamics/Featherstone/btMultiBodyLink.h
include/bullet/BulletDynamics/Featherstone/btMultiBodyLinkCollider.h
+include/bullet/BulletDynamics/Featherstone/btMultiBodyMLCPConstraintSolver.h
include/bullet/BulletDynamics/Featherstone/btMultiBodyPoint2Point.h
include/bullet/BulletDynamics/Featherstone/btMultiBodySliderConstraint.h
include/bullet/BulletDynamics/Featherstone/btMultiBodySolverConstraint.h
+include/bullet/BulletDynamics/Featherstone/btMultiBodySphericalJointMotor.h
include/bullet/BulletDynamics/MLCPSolvers/btDantzigLCP.h
include/bullet/BulletDynamics/MLCPSolvers/btDantzigSolver.h
include/bullet/BulletDynamics/MLCPSolvers/btLemkeAlgorithm.h
@@ -329,15 +343,27 @@ include/bullet/BulletDynamics/Vehicle/btRaycastVehicle.h
include/bullet/BulletDynamics/Vehicle/btVehicleRaycaster.h
include/bullet/BulletDynamics/Vehicle/btWheelInfo.h
include/bullet/BulletDynamics/btBulletDynamicsCommon.h
-include/bullet/BulletFileLoader/autogenerated/bullet.h
-include/bullet/BulletFileLoader/bChunk.h
-include/bullet/BulletFileLoader/bCommon.h
-include/bullet/BulletFileLoader/bDNA.h
-include/bullet/BulletFileLoader/bDefines.h
-include/bullet/BulletFileLoader/bFile.h
-include/bullet/BulletFileLoader/btBulletFile.h
include/bullet/BulletInverseDynamics/btBulletCollisionCommon.h
+include/bullet/BulletSoftBody/DeformableBodyInplaceSolverIslandCallback.h
+include/bullet/BulletSoftBody/btCGProjection.h
+include/bullet/BulletSoftBody/btConjugateGradient.h
+include/bullet/BulletSoftBody/btConjugateResidual.h
include/bullet/BulletSoftBody/btDefaultSoftBodySolver.h
+include/bullet/BulletSoftBody/btDeformableBackwardEulerObjective.h
+include/bullet/BulletSoftBody/btDeformableBodySolver.h
+include/bullet/BulletSoftBody/btDeformableContactConstraint.h
+include/bullet/BulletSoftBody/btDeformableContactProjection.h
+include/bullet/BulletSoftBody/btDeformableCorotatedForce.h
+include/bullet/BulletSoftBody/btDeformableGravityForce.h
+include/bullet/BulletSoftBody/btDeformableLagrangianForce.h
+include/bullet/BulletSoftBody/btDeformableLinearElasticityForce.h
+include/bullet/BulletSoftBody/btDeformableMassSpringForce.h
+include/bullet/BulletSoftBody/btDeformableMousePickingForce.h
+include/bullet/BulletSoftBody/btDeformableMultiBodyConstraintSolver.h
+include/bullet/BulletSoftBody/btDeformableMultiBodyDynamicsWorld.h
+include/bullet/BulletSoftBody/btDeformableNeoHookeanForce.h
+include/bullet/BulletSoftBody/btKrylovSolver.h
+include/bullet/BulletSoftBody/btPreconditioner.h
include/bullet/BulletSoftBody/btSoftBody.h
include/bullet/BulletSoftBody/btSoftBodyConcaveCollisionAlgorithm.h
include/bullet/BulletSoftBody/btSoftBodyData.h
@@ -351,38 +377,8 @@ include/bullet/BulletSoftBody/btSoftRigidCollisionAlgorithm.h
include/bullet/BulletSoftBody/btSoftRigidDynamicsWorld.h
include/bullet/BulletSoftBody/btSoftSoftCollisionAlgorithm.h
include/bullet/BulletSoftBody/btSparseSDF.h
-include/bullet/BulletWorldImporter/btBulletWorldImporter.h
-include/bullet/BulletWorldImporter/btWorldImporter.h
-include/bullet/BulletXmlWorldImporter/btBulletXmlWorldImporter.h
-include/bullet/BulletXmlWorldImporter/string_split.h
-include/bullet/BulletXmlWorldImporter/tinystr.h
-include/bullet/BulletXmlWorldImporter/tinyxml.h
-include/bullet/ConvexDecomposition/ConvexBuilder.h
-include/bullet/ConvexDecomposition/ConvexDecomposition.h
-include/bullet/ConvexDecomposition/bestfit.h
-include/bullet/ConvexDecomposition/bestfitobb.h
-include/bullet/ConvexDecomposition/cd_hull.h
-include/bullet/ConvexDecomposition/cd_vector.h
-include/bullet/ConvexDecomposition/cd_wavefront.h
-include/bullet/ConvexDecomposition/concavity.h
-include/bullet/ConvexDecomposition/fitsphere.h
-include/bullet/ConvexDecomposition/float_math.h
-include/bullet/ConvexDecomposition/meshvolume.h
-include/bullet/ConvexDecomposition/planetri.h
-include/bullet/ConvexDecomposition/raytri.h
-include/bullet/ConvexDecomposition/splitplane.h
-include/bullet/ConvexDecomposition/vlookup.h
-include/bullet/GIMPACTUtils/btGImpactConvexDecompositionShape.h
-include/bullet/HACD/hacdCircularList.h
-include/bullet/HACD/hacdCircularList.inl
-include/bullet/HACD/hacdGraph.h
-include/bullet/HACD/hacdHACD.h
-include/bullet/HACD/hacdICHull.h
-include/bullet/HACD/hacdManifoldMesh.h
-include/bullet/HACD/hacdVector.h
-include/bullet/HACD/hacdVector.inl
-include/bullet/HACD/hacdVersion.h
-include/bullet/InverseDynamics/BulletInverseDynamicsUtilsCommon.h
+include/bullet/BulletSoftBody/poly34.h
+include/bullet/LinearMath/TaskScheduler/btThreadSupportInterface.h
include/bullet/LinearMath/btAabbUtil2.h
include/bullet/LinearMath/btAlignedAllocator.h
include/bullet/LinearMath/btAlignedObjectArray.h
@@ -394,10 +390,12 @@ include/bullet/LinearMath/btGeometryUtil.h
include/bullet/LinearMath/btGrahamScan2dConvexHull.h
include/bullet/LinearMath/btHashMap.h
include/bullet/LinearMath/btIDebugDraw.h
+include/bullet/LinearMath/btImplicitQRSVD.h
include/bullet/LinearMath/btList.h
include/bullet/LinearMath/btMatrix3x3.h
include/bullet/LinearMath/btMatrixX.h
include/bullet/LinearMath/btMinMax.h
+include/bullet/LinearMath/btModifiedGramSchmidt.h
include/bullet/LinearMath/btMotionState.h
include/bullet/LinearMath/btPolarDecomposition.h
include/bullet/LinearMath/btPoolAllocator.h
@@ -405,6 +403,7 @@ include/bullet/LinearMath/btQuadWord.h
include/bullet/LinearMath/btQuaternion.h
include/bullet/LinearMath/btQuickprof.h
include/bullet/LinearMath/btRandom.h
+include/bullet/LinearMath/btReducedVector.h
include/bullet/LinearMath/btScalar.h
include/bullet/LinearMath/btSerializer.h
include/bullet/LinearMath/btSpatialAlgebra.h
@@ -418,40 +417,26 @@ include/bullet/btBulletDynamicsCommon.h
lib/cmake/bullet/BulletConfig.cmake
lib/cmake/bullet/UseBullet.cmake
lib/libBullet2FileLoader.so
-lib/libBullet2FileLoader.so.2.86
+lib/libBullet2FileLoader.so.%%LIB_VERSION%%
lib/libBullet3Collision.so
-lib/libBullet3Collision.so.2.86
+lib/libBullet3Collision.so.%%LIB_VERSION%%
lib/libBullet3Common.so
-lib/libBullet3Common.so.2.86
+lib/libBullet3Common.so.%%LIB_VERSION%%
lib/libBullet3Dynamics.so
-lib/libBullet3Dynamics.so.2.86
+lib/libBullet3Dynamics.so.%%LIB_VERSION%%
lib/libBullet3Geometry.so
-lib/libBullet3Geometry.so.2.86
+lib/libBullet3Geometry.so.%%LIB_VERSION%%
lib/libBullet3OpenCL_clew.so
-lib/libBullet3OpenCL_clew.so.2.86
+lib/libBullet3OpenCL_clew.so.%%LIB_VERSION%%
lib/libBulletCollision.so
-lib/libBulletCollision.so.2.86
+lib/libBulletCollision.so.%%LIB_VERSION%%
lib/libBulletDynamics.so
-lib/libBulletDynamics.so.2.86
-lib/libBulletFileLoader.so
-lib/libBulletFileLoader.so.2.86
+lib/libBulletDynamics.so.%%LIB_VERSION%%
lib/libBulletInverseDynamics.so
-lib/libBulletInverseDynamics.so.2.86
-lib/libBulletInverseDynamicsUtils.so
-lib/libBulletInverseDynamicsUtils.so.2.86
+lib/libBulletInverseDynamics.so.%%LIB_VERSION%%
lib/libBulletSoftBody.so
-lib/libBulletSoftBody.so.2.86
-lib/libBulletWorldImporter.so
-lib/libBulletWorldImporter.so.2.86
-lib/libBulletXmlWorldImporter.so
-lib/libBulletXmlWorldImporter.so.2.86
-lib/libConvexDecomposition.so
-lib/libConvexDecomposition.so.2.86
-lib/libGIMPACTUtils.so
-lib/libGIMPACTUtils.so.2.86
-lib/libHACD.so
-lib/libHACD.so.2.86
+lib/libBulletSoftBody.so.%%LIB_VERSION%%
lib/libLinearMath.so
-lib/libLinearMath.so.2.86
+lib/libLinearMath.so.%%LIB_VERSION%%
libdata/pkgconfig/bullet.pc
@dir include/bullet/BulletInverseDynamics/details