aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-03-28 09:22:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-03-29 12:53:47 +0000
commit23739fa6caa76c81a8c7ca96b46cc9d0ce98a040 (patch)
tree9f270dc9ebc2059e5485dc4db28967ac83b27a2f
parent56574c37ba3b4a96a28b6ffd781c75661c56940e (diff)
downloadports-23739fa6caa76c81a8c7ca96b46cc9d0ce98a040.tar.gz
ports-23739fa6caa76c81a8c7ca96b46cc9d0ce98a040.zip
graphics/mesa-devel: unbreak build with llvm18
Installing spirv-llvm-translator-llvm18-18.1.0... ===> mesa-devel-24.0.b.3778 depends on shared library: libLLVMSPIRVLib.so.18 - not found *** Error code 1
-rw-r--r--graphics/mesa-devel/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/mesa-devel/Makefile b/graphics/mesa-devel/Makefile
index 3897719fc374..765adf008783 100644
--- a/graphics/mesa-devel/Makefile
+++ b/graphics/mesa-devel/Makefile
@@ -112,8 +112,9 @@ OPENCL_BUILD_DEPENDS= bindgen:devel/rust-bindgen-cli \
libclc>0:devel/libclc \
spirv-tools>0:graphics/spirv-tools \
rustc:lang/${RUST_DEFAULT}
-OPENCL_LIB_DEPENDS= libLLVMSPIRVLib.so.${LLVM_VERSION}:devel/spirv-llvm-translator@${LLVM_PORT:T}
+OPENCL_LIB_DEPENDS= libLLVMSPIRVLib.so.${OPENCL_SOVERSION}:devel/spirv-llvm-translator@${LLVM_PORT:T}
OPENCL_RUN_DEPENDS= libclc>0:devel/libclc
+OPENCL_SOVERSION= ${LLVM_VERSION}${${LLVM_VERSION}>=18:?.1:}
OPENCL_CONFIGURE_ENV= PKG_CONFIG_PATH="${LLVM_PREFIX}/libdata/pkgconfig"
OPENCL_MESON_FALSE= b_lundef # environ
OPENCL_MESON_TRUE= gallium-rusticl