aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 16:14:10 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 17:20:03 +0000
commit2b636272ac985fcc3b294a05e6caf87d5a642c52 (patch)
tree05141a1a5aeea2ea04513b879a304c4ad4d1e728
parentd1ebca215e497a57a9e276209b9779dc588e6da6 (diff)
downloadports-2b636272ac985fcc3b294a05e6caf87d5a642c52.tar.gz
ports-2b636272ac985fcc3b294a05e6caf87d5a642c52.zip
games/chessx: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--games/chessx/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/games/chessx/Makefile b/games/chessx/Makefile
index 7ea3139d624b..40234def862d 100644
--- a/games/chessx/Makefile
+++ b/games/chessx/Makefile
@@ -31,6 +31,14 @@ STOCKFISH_DESC= Install Stockfish Chess Engine
CRAFTY_RUN_DEPENDS= crafty:games/crafty
STOCKFISH_RUN_DEPENDS= stockfish:games/stockfish
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+ @${REINPLACE_CMD} -e 's|std::binary_function|std::__binary_function|' \
+ ${WRKSRC}/src/database/polyglotdatabase.cpp
+.endif
+
post-configure:
( cd ${BUILD_WRKSRC} && ${LRELEASE} ${WRKSRC}/${PORTNAME}.pro )
@@ -40,4 +48,4 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/chessx
${FIND} ${STAGEDIR}${PREFIX} -name 'ecp.????????' -delete
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>