aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 11:52:34 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 11:52:34 +0000
commit2e8a7f6a4674d4ee40da1553a19047481f0c6c63 (patch)
treeb7ecdf682afedde046e98ba28c3c3414b980518d
parent87a690f021d23b3ea2a76e537d1733b49bdff3b1 (diff)
downloadports-2e8a7f6a4674d4ee40da1553a19047481f0c6c63.tar.gz
ports-2e8a7f6a4674d4ee40da1553a19047481f0c6c63.zip
print/texlive-base: prepare for freetype2 upgrade
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. Original version by: diizzy PR: 251512 PR: 257576
-rw-r--r--print/texlive-base/Makefile4
-rw-r--r--print/texlive-base/files/patch-configure20
-rw-r--r--print/texlive-base/files/patch-texk_dvipng_configure13
-rw-r--r--print/texlive-base/files/patch-texk_dvisvgm_configure13
-rw-r--r--print/texlive-base/files/patch-texk_ttf2pk2_configure13
5 files changed, 58 insertions, 5 deletions
diff --git a/print/texlive-base/Makefile b/print/texlive-base/Makefile
index 84c45b3787a0..6b68d3437936 100644
--- a/print/texlive-base/Makefile
+++ b/print/texlive-base/Makefile
@@ -65,6 +65,8 @@ SHEBANG_FILES= texk/texlive/linked_scripts/accfonts/mkt1font \
texk/texlive/linked_scripts/urlbst/urlbst \
texk/texlive/linked_scripts/yplan/yplan
+BINARY_ALIAS= freetype-config=true
+
# during build phase gnu configure is run a lot
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-native-texlive-build \
@@ -128,7 +130,7 @@ post-patch:
tl_scripts/texconfig-sys.sh \
linked_scripts/texlive/updmap-sys.sh
${REINPLACE_CMD} -e 's|/usr/bin/python -O|${python_CMD}|' \
- ${WRKSRC}/texk/texlive/linked_scripts/de-macro/de-macro \
+ ${WRKSRC}/texk/texlive/linked_scripts/de-macro/de-macro
post-install-fmtutil:
for D in ${TEXHASHDIRS}; do \
diff --git a/print/texlive-base/files/patch-configure b/print/texlive-base/files/patch-configure
index 429162c7401d..1b7fc3453ca9 100644
--- a/print/texlive-base/files/patch-configure
+++ b/print/texlive-base/files/patch-configure
@@ -1,6 +1,6 @@
--- configure.orig 2015-04-12 11:22:39 UTC
+++ configure
-@@ -5685,6 +5685,15 @@ $as_echo "$as_me: -> installed \`zlib
+@@ -5685,7 +5685,16 @@ $as_echo "$as_me: -> installed \`zlib' headers and
as_fn_error $? "Sorry, \`--with-system-teckit' requires \`--with-system-zlib'" "$LINENO" 5
fi
fi
@@ -8,15 +8,27 @@
+if test "${with_teckit_includes+set}" = set; then :
+ withval=$with_teckit_includes;
+fi
-+
+
+# Check whether --with-teckit-libdir was given.
+if test "${with_teckit_libdir+set}" = set; then :
+ withval=$with_teckit_libdir;
+fi
-
++
test "x$need_teckit" = xyes && {
need_zlib=yes
-@@ -21284,11 +21293,12 @@ elif test "x$need_graphite2:$with_system
+ }
+@@ -21198,8 +21207,8 @@ else
+ FT2_CONFIG="$ac_cv_prog_FT2_CONFIG"
+ fi
+ if $FT2_CONFIG --ftversion >/dev/null 2>&1; then
+- FREETYPE2_INCLUDES=`$FT2_CONFIG --cflags`
+- FREETYPE2_LIBS=`$FT2_CONFIG --libs`
++ FREETYPE2_INCLUDES=`pkg-config freetype2 --cflags`
++ FREETYPE2_LIBS=`pkg-config freetype2 --libs`
+ elif test "x$need_freetype2:$with_system_freetype2" = xyes:yes; then
+ as_fn_error $? "did not find freetype-config required for system freetype2 library" "$LINENO" 5
+ fi
+@@ -21284,11 +21293,12 @@ elif test "x$need_graphite2:$with_system_graphite2" =
as_fn_error $? "did not find graphite2" "$LINENO" 5
fi
diff --git a/print/texlive-base/files/patch-texk_dvipng_configure b/print/texlive-base/files/patch-texk_dvipng_configure
new file mode 100644
index 000000000000..a9e76741119d
--- /dev/null
+++ b/print/texlive-base/files/patch-texk_dvipng_configure
@@ -0,0 +1,13 @@
+--- texk/dvipng/configure.orig 2021-08-02 22:16:56 UTC
++++ texk/dvipng/configure
+@@ -16273,8 +16273,8 @@ else
+ FT2_CONFIG="$ac_cv_prog_FT2_CONFIG"
+ fi
+ if $FT2_CONFIG --ftversion >/dev/null 2>&1; then
+- FREETYPE2_INCLUDES=`$FT2_CONFIG --cflags`
+- FREETYPE2_LIBS=`$FT2_CONFIG --libs`
++ FREETYPE2_INCLUDES=`pkg-config freetype2 --cflags`
++ FREETYPE2_LIBS=`pkg-config freetype2 --libs`
+ elif test "x$need_freetype2:$with_system_freetype2" = xyes:yes; then
+ as_fn_error $? "did not find freetype-config required for system freetype2 library" "$LINENO" 5
+ fi
diff --git a/print/texlive-base/files/patch-texk_dvisvgm_configure b/print/texlive-base/files/patch-texk_dvisvgm_configure
new file mode 100644
index 000000000000..09c66a5ac782
--- /dev/null
+++ b/print/texlive-base/files/patch-texk_dvisvgm_configure
@@ -0,0 +1,13 @@
+--- texk/dvisvgm/configure.orig 2021-08-02 22:17:20 UTC
++++ texk/dvisvgm/configure
+@@ -19748,8 +19748,8 @@ else
+ FT2_CONFIG="$ac_cv_prog_FT2_CONFIG"
+ fi
+ if $FT2_CONFIG --ftversion >/dev/null 2>&1; then
+- FREETYPE2_INCLUDES=`$FT2_CONFIG --cflags`
+- FREETYPE2_LIBS=`$FT2_CONFIG --libs`
++ FREETYPE2_INCLUDES=`pkg-config freetype2 --cflags`
++ FREETYPE2_LIBS=`pkg-config freetype2 --libs`
+ elif test "x$need_freetype2:$with_system_freetype2" = xyes:yes; then
+ as_fn_error $? "did not find freetype-config required for system freetype2 library" "$LINENO" 5
+ fi
diff --git a/print/texlive-base/files/patch-texk_ttf2pk2_configure b/print/texlive-base/files/patch-texk_ttf2pk2_configure
new file mode 100644
index 000000000000..dd8650b1202c
--- /dev/null
+++ b/print/texlive-base/files/patch-texk_ttf2pk2_configure
@@ -0,0 +1,13 @@
+--- texk/ttf2pk2/configure.orig 2021-08-02 22:17:04 UTC
++++ texk/ttf2pk2/configure
+@@ -15108,8 +15108,8 @@ else
+ FT2_CONFIG="$ac_cv_prog_FT2_CONFIG"
+ fi
+ if $FT2_CONFIG --ftversion >/dev/null 2>&1; then
+- FREETYPE2_INCLUDES=`$FT2_CONFIG --cflags`
+- FREETYPE2_LIBS=`$FT2_CONFIG --libs`
++ FREETYPE2_INCLUDES=`pkg-config freetype2 --cflags`
++ FREETYPE2_LIBS=`pkg-config freetype2 --libs`
+ elif test "x$need_freetype2:$with_system_freetype2" = xyes:yes; then
+ as_fn_error $? "did not find freetype-config required for system freetype2 library" "$LINENO" 5
+ fi