aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2023-07-07 09:46:02 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2023-07-07 09:49:02 +0000
commit2f1c5631c708cb9942147f69766626a03dd7bf72 (patch)
tree6e5bfdf28ab6479a4cdb9b74e30b3292f1850a35
parent4344285ad1b344bef27b5b2452d2f2a41f7e9ad0 (diff)
downloadports-2f1c5631c708cb9942147f69766626a03dd7bf72.tar.gz
ports-2f1c5631c708cb9942147f69766626a03dd7bf72.zip
graphics/osg: Cleaner way to force c++11
Reported by: fluffy
-rw-r--r--graphics/osg/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index 7ef96671c88a..4f2eb50d8ac8 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -26,9 +26,9 @@ USES= alias cmake compiler:c11 jpeg gl pkgconfig xorg
USE_GL= gl
USE_XORG= x11
USE_LDCONFIG= yes
+USE_CXXSTD= c++11
CFLAGS+= -I${LOCALBASE}/include/Imath -DInt64=uint64_t
-CXXFLAGS+= -std=c++11
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
OSG_SHLIBVER=161 \