aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-12-10 19:48:47 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-12-10 23:52:50 +0000
commit311bf443f107c37d4043ea691435d4de1e7b0559 (patch)
tree00fe7cdf3dfdadb80c6f57fbcbc42f2c3e2c5ddb
parentf6c8d421d3e9455a7ac291db237b93cce6c712d1 (diff)
downloadports-311bf443f107c37d4043ea691435d4de1e7b0559.tar.gz
ports-311bf443f107c37d4043ea691435d4de1e7b0559.zip
kde-ports: remove runtime-dependency on Qt testlib
Qt testlib is a library for tests; it is not generally needed at runtime. Move it to a _build dependency for the KDE-related ports that use it for their tests.
-rw-r--r--deskutils/charmtimetracker/Makefile6
-rw-r--r--deskutils/libkdepim/Makefile7
-rw-r--r--games/kpat/Makefile3
-rw-r--r--games/kreversi/Makefile3
-rw-r--r--games/ksirk/Makefile3
-rw-r--r--games/ksudoku/Makefile3
-rw-r--r--games/libkdegames/Makefile5
-rw-r--r--graphics/kcolorpicker/Makefile5
-rw-r--r--graphics/spectacle/Makefile7
9 files changed, 25 insertions, 17 deletions
diff --git a/deskutils/charmtimetracker/Makefile b/deskutils/charmtimetracker/Makefile
index d26bb88605f9..4daedc7486cb 100644
--- a/deskutils/charmtimetracker/Makefile
+++ b/deskutils/charmtimetracker/Makefile
@@ -1,6 +1,6 @@
PORTNAME= charmtimetracker
DISTVERSION= 1.12.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= deskutils
# PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -24,8 +24,8 @@ GH_PROJECT= Charm
USE_QT= core dbus gui \
network printsupport script sql sql-sqlite3 \
- testlib widgets xml \
- buildtools_build qmake_build
+ widgets xml \
+ buildtools_build qmake_build testlib_build
USE_XORG= ice x11 xcb xext xscrnsaver
.include <bsd.port.mk>
diff --git a/deskutils/libkdepim/Makefile b/deskutils/libkdepim/Makefile
index 45f27aeb0355..aa89759314af 100644
--- a/deskutils/libkdepim/Makefile
+++ b/deskutils/libkdepim/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libkdepim
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -15,10 +16,10 @@ USE_KDE= auth codecs completion config configwidgets coreaddons \
kio service wallet widgetsaddons \
ecm_build
# pim components
-USE_KDE+= akonadi akonadicontacts akonadisearch contacts ldap mime
-USE_QT= concurrent core dbus designer gui network testlib uiplugin uitools \
+USE_KDE+= akonadi akonadicontacts akonadisearch contacts ldap mime
+USE_QT= concurrent core dbus designer gui network uiplugin uitools \
widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
USE_LDCONFIG= yes
diff --git a/games/kpat/Makefile b/games/kpat/Makefile
index e04e0e20e6e7..8e268b94975b 100644
--- a/games/kpat/Makefile
+++ b/games/kpat/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kpat
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -16,7 +17,7 @@ USE_KDE= attica auth codecs completion config configwidgets coreaddons \
textwidgets widgetsaddons xmlgui \
ecm_build
USE_QT= concurrent core dbus declarative gui network phonon4 svg widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
CMAKE_ON= WITH_BH_SOLVER
OPTIONS_DEFINE= DOCS
diff --git a/games/kreversi/Makefile b/games/kreversi/Makefile
index 4b01535f4029..56a3ce554932 100644
--- a/games/kreversi/Makefile
+++ b/games/kreversi/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kreversi
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +13,7 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
solid widgetsaddons windowsystem xmlgui \
ecm_build
USE_QT= concurrent core dbus declarative gui network svg widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
OPTIONS_DEFINE= DOCS
diff --git a/games/ksirk/Makefile b/games/ksirk/Makefile
index c9746b2427ef..e99444e81ad2 100644
--- a/games/ksirk/Makefile
+++ b/games/ksirk/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ksirk
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,7 @@ USE_KDE= attica auth codecs completion config configwidgets \
coreaddons crash i18n iconthemes kio libkdegames newstuff \
service wallet widgetsaddons xmlgui
USE_QT= concurrent core dbus declarative gui network phonon4 svg widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS
diff --git a/games/ksudoku/Makefile b/games/ksudoku/Makefile
index 0ed1ae962a8f..0a1e3613ed27 100644
--- a/games/ksudoku/Makefile
+++ b/games/ksudoku/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ksudoku
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +14,7 @@ USE_KDE= archive auth codecs completion config configwidgets \
ecm_build
USE_QT= concurrent core dbus declarative gui network opengl printsupport \
svg widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
OPTIONS_DEFINE= DOCS
diff --git a/games/libkdegames/Makefile b/games/libkdegames/Makefile
index a9b3615f8bee..36ae0e5f1943 100644
--- a/games/libkdegames/Makefile
+++ b/games/libkdegames/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libkdegames
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -15,8 +16,8 @@ USE_KDE= archive attica auth bookmarks codecs completion config \
itemviews jobwidgets kdeclarative kdelibs4support kio newstuff \
package service textwidgets widgetsaddons xmlgui \
ecm_build
-USE_QT= core dbus declarative gui network svg testlib widgets xml \
- buildtools_build qmake_build
+USE_QT= core dbus declarative gui network svg widgets xml \
+ buildtools_build qmake_build testlib_build
USE_LDCONFIG= yes
SHLIB_VER= 7.0.0
diff --git a/graphics/kcolorpicker/Makefile b/graphics/kcolorpicker/Makefile
index 40f43d75ed8d..c947f76177a5 100644
--- a/graphics/kcolorpicker/Makefile
+++ b/graphics/kcolorpicker/Makefile
@@ -1,6 +1,7 @@
PORTNAME= kColorPicker
DISTVERSIONPREFIX= v
DISTVERSION= 0.1.6
+PORTREVISION= 1
CATEGORIES= graphics kde
MAINTAINER= kde@FreeBSD.org
@@ -12,8 +13,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake compiler:c++11-lang qt:5
USE_GITHUB= yes
GH_ACCOUNT= ksnip
-USE_QT= core testlib widgets \
- buildtools_build qmake_build
+USE_QT= core widgets \
+ buildtools_build qmake_build testlib_build
CMAKE_ON= BUILD_SHARED_LIBS
diff --git a/graphics/spectacle/Makefile b/graphics/spectacle/Makefile
index 0933ecb8803e..cb9940aae96e 100644
--- a/graphics/spectacle/Makefile
+++ b/graphics/spectacle/Makefile
@@ -1,5 +1,6 @@
PORTNAME= spectacle
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -13,13 +14,13 @@ RUN_DEPENDS= kipi-plugins>=0:graphics/kipi-plugins
USES= cmake compiler:c++11-lang gettext kde:5 pkgconfig qt:5 tar:xz xorg
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
- dbusaddons doctools globalaccel i18n jobwidgets kdeclarative kio \
+ dbusaddons globalaccel i18n jobwidgets kdeclarative kio \
libkipi newstuff notifications package service solid wayland \
widgetsaddons windowsystem xmlgui \
- ecm_build
+ doctools_build ecm_build
USE_QT= core concurrent dbus declarative gui network printsupport \
quickcontrols svg widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
USE_XORG= x11 xcb xext xfixes
OPTIONS_DEFINE= DOCS