aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-07-02 18:41:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-07-02 18:46:51 +0000
commit316a89ed4e72fc2c5c49589c0c797ef535ac11af (patch)
tree470bcfe79ccf4e911b8579a5b171d01059518091
parentdd152219f70da0465ee12edb1feeae5e2f802c51 (diff)
downloadports-316a89ed4e72fc2c5c49589c0c797ef535ac11af.tar.gz
ports-316a89ed4e72fc2c5c49589c0c797ef535ac11af.zip
games/punchy: unbreak build with clang 16 on aarch64
In file included from cargo-crates/v8-0.47.1/v8/src/compiler/backend/instruction-selector.cc:5: In file included from cargo-crates/v8-0.47.1/v8/src/compiler/backend/instruction-selector.h:12: In file included from cargo-crates/v8-0.47.1/v8/src/compiler/backend/instruction-scheduler.h:10: In file included from cargo-crates/v8-0.47.1/v8/src/compiler/backend/instruction.h:13: In file included from cargo-crates/v8-0.47.1/v8/src/codegen/external-reference.h:9: In file included from cargo-crates/v8-0.47.1/v8/src/runtime/runtime.h:11: cargo-crates/v8-0.47.1/v8/src/base/bit-field.h:43:29: error: integer value 31 is outside the valid range of values [0, 15] for the enumeration type 'AddressingMode' [-Wenum-constexpr-conversion] static constexpr T kMax = static_cast<T>(kNumValues - 1); ^ Reported by: pkg-fallout
-rw-r--r--games/punchy/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/punchy/Makefile b/games/punchy/Makefile
index 17041020b6e4..8e1fe489fc11 100644
--- a/games/punchy/Makefile
+++ b/games/punchy/Makefile
@@ -24,10 +24,11 @@ PORTDATA= *
# Bundled v8
BUILD_DEPENDS+= gn:devel/gn
-USES+= ninja:build python:build
+USES+= compiler ninja:build python:build
BINARY_ALIAS+= python=${PYTHON_CMD}
CARGO_ENV+= V8_FROM_SOURCE=1 CLANG_BASE_PATH="/usr" GN_ARGS='${GN_ARGS}'
GN_ARGS+= use_custom_libcxx=false
+CXXFLAGS+= ${${ARCH} == aarch64 && ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160:?-Wno-enum-constexpr-conversion:}
post-patch:
# Search assets under PREFIX instead of current directory