aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-26 14:13:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-26 14:13:05 +0000
commit3d9708732d72f44a1c7a57dc2897182e3bcb1ecf (patch)
tree1d37aa02f9d0e84c7a941f8487c04e07d3524dfd
parent172e6a529db97c8f0582e6cdcbe57d595d19f56b (diff)
downloadports-3d9708732d72f44a1c7a57dc2897182e3bcb1ecf.tar.gz
ports-3d9708732d72f44a1c7a57dc2897182e3bcb1ecf.zip
- Add number of missed files into pkg-plist;
- remove useless USE_LIBTOOL; - hack port to install files properly into GNOME tree.
Notes
Notes: svn path=/head/; revision=45510
-rw-r--r--databases/gnome-db/Makefile6
-rw-r--r--databases/gnome-db/files/patch-configure51
-rw-r--r--databases/gnome-db/files/patch-idl::Makefile.in14
-rw-r--r--databases/gnome-db/files/patch-ltmain.sh18
-rw-r--r--databases/gnome-db/pkg-plist69
-rw-r--r--databases/gnomedb/Makefile6
-rw-r--r--databases/gnomedb/files/patch-configure51
-rw-r--r--databases/gnomedb/files/patch-idl::Makefile.in14
-rw-r--r--databases/gnomedb/files/patch-ltmain.sh18
-rw-r--r--databases/gnomedb/pkg-plist69
-rw-r--r--databases/gnomedb2/Makefile6
-rw-r--r--databases/gnomedb2/files/patch-configure51
-rw-r--r--databases/gnomedb2/files/patch-idl::Makefile.in14
-rw-r--r--databases/gnomedb2/files/patch-ltmain.sh18
-rw-r--r--databases/gnomedb2/pkg-plist69
15 files changed, 372 insertions, 102 deletions
diff --git a/databases/gnome-db/Makefile b/databases/gnome-db/Makefile
index 6636a06c844c..872231cf64ae 100644
--- a/databases/gnome-db/Makefile
+++ b/databases/gnome-db/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= bonobo.2:${PORTSDIR}/devel/bonobo \
USE_X_PREFIX= yes
USE_GNOMECTRL= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -31,6 +31,8 @@ pre-patch:
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ s|\$\(GNOME_datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(GNOME_datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/databases/gnome-db/files/patch-configure b/databases/gnome-db/files/patch-configure
index f9c35b7dfc9b..4c28f6fa60f3 100644
--- a/databases/gnome-db/files/patch-configure
+++ b/databases/gnome-db/files/patch-configure
@@ -1,39 +1,28 @@
---- configure.orig Fri Jun 15 15:39:00 2001
-+++ configure Tue Jun 19 02:24:00 2001
-@@ -5687,4 +5687,19 @@
-
--
--
-+# Actually configure libtool. ac_aux_dir is where install-sh is found.
-+CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
-+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
-+LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
-+DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-+${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
-+|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
-+
-+# Reload cache, that may have been modified by ltconfig
-+if test -r "$cache_file"; then
-+ echo "loading cache $cache_file"
-+ . $cache_file
-+else
-+ echo "creating cache $cache_file"
-+ > $cache_file
-+fi
-
-@@ -5692,3 +5707,3 @@
- # This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
-
-@@ -8823,3 +8838,3 @@
+
+$FreeBSD$
+
+--- configure.orig Thu Jul 26 16:38:59 2001
++++ configure Thu Jul 26 16:50:40 2001
+@@ -8821,7 +8836,7 @@
+
+
-if test $perl_val == true; then
+if [ $perl_val = true ]; then
WITH_PERL_TRUE=
-@@ -8833,3 +8848,3 @@
+ WITH_PERL_FALSE='#'
+ else
+@@ -8831,11 +8846,11 @@
+
+ GNOMEDB_CFLAGS="`gda-config --cflags client` `gnome-config --cflags xml oaf bonobox print`"
GNOMEDB_LIBS="`gda-config --libs client` `gnome-config --libs xml oaf bonobox print`"
-GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${datadir}/locale\\\""
+GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${prefix}/share/locale\\\""
+
+
+-GNOMEDB_oafdir=`oaf-config --prefix`/share/oaf
++GNOMEDB_oafdir=`oaf-config --prefix`/share/gnome/oaf
+
+
+
diff --git a/databases/gnome-db/files/patch-idl::Makefile.in b/databases/gnome-db/files/patch-idl::Makefile.in
new file mode 100644
index 000000000000..da60a4cfbf63
--- /dev/null
+++ b/databases/gnome-db/files/patch-idl::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- idl/Makefile.in 2001/07/26 14:06:24 1.1
++++ idl/Makefile.in 2001/07/26 14:06:37
+@@ -153,7 +153,7 @@
+ EXTRA_DIST = $(IDL_FILES)
+
+
+-idldir = $(prefix)/share/idl
++idldir = $(prefix)/share/gnome/idl
+ idl_DATA = $(IDL_FILES)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
diff --git a/databases/gnome-db/files/patch-ltmain.sh b/databases/gnome-db/files/patch-ltmain.sh
new file mode 100644
index 000000000000..0c594216b0e1
--- /dev/null
+++ b/databases/gnome-db/files/patch-ltmain.sh
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/07/23 09:45:58 1.1
++++ ltmain.sh 2001/07/23 09:46:28
+@@ -4175,10 +4175,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/databases/gnome-db/pkg-plist b/databases/gnome-db/pkg-plist
index ea728fa3943a..368fc53aa312 100644
--- a/databases/gnome-db/pkg-plist
+++ b/databases/gnome-db/pkg-plist
@@ -39,13 +39,73 @@ lib/bonobo/monikers/libdatabase_moniker.so.0
lib/libgnomedb.a
lib/libgnomedb.so
lib/libgnomedb.so.0
+share/gnome/apps/Applications/gnomedb-fe.desktop
+share/gnome/help/gnome-db/C/comlib.html
+share/gnome/help/gnome-db/C/components.html
+share/gnome/help/gnome-db/C/docbook.css
+share/gnome/help/gnome-db/C/fdl-section1.html
+share/gnome/help/gnome-db/C/fdl-section10.html
+share/gnome/help/gnome-db/C/fdl-section2.html
+share/gnome/help/gnome-db/C/fdl-section3.html
+share/gnome/help/gnome-db/C/fdl-section4.html
+share/gnome/help/gnome-db/C/fdl-section5.html
+share/gnome/help/gnome-db/C/fdl-section6.html
+share/gnome/help/gnome-db/C/fdl-section7.html
+share/gnome/help/gnome-db/C/fdl-section8.html
+share/gnome/help/gnome-db/C/fdl-section9.html
+share/gnome/help/gnome-db/C/fdl-using.html
+share/gnome/help/gnome-db/C/fdl.html
+share/gnome/help/gnome-db/C/fe.html
+share/gnome/help/gnome-db/C/index.html
+share/gnome/help/gnome-db/C/introduction.html
+share/gnome/help/gnome-db/C/ln44.html
+share/gnome/help/gnome-db/C/manager-config-components.html
+share/gnome/help/gnome-db/C/manager.html
+share/gnome/help/gnome-db/C/topic.dat
+share/gnome/help/gnome-db/C/widgetlib-overview.html
+share/gnome/help/gnome-db/C/widgetlib.html
+share/gnome/help/gnome-db/es/comlib.html
+share/gnome/help/gnome-db/es/components.html
+share/gnome/help/gnome-db/es/docbook.css
+share/gnome/help/gnome-db/es/fe.html
+share/gnome/help/gnome-db/es/gnome-db.html
+share/gnome/help/gnome-db/es/index.html
+share/gnome/help/gnome-db/es/introduction.html
+share/gnome/help/gnome-db/es/ln50.html
+share/gnome/help/gnome-db/es/manager-config-components.html
+share/gnome/help/gnome-db/es/manager.html
+share/gnome/help/gnome-db/es/topic.dat
+share/gnome/help/gnome-db/es/widgetlib-overview.html
+share/gnome/help/gnome-db/es/widgetlib.html
+share/gnome/help/gnome-db/pt_BR/comlib.html
+share/gnome/help/gnome-db/pt_BR/components.html
+share/gnome/help/gnome-db/pt_BR/docbook.css
+share/gnome/help/gnome-db/pt_BR/fe.html
+share/gnome/help/gnome-db/pt_BR/gnome-db.html
+share/gnome/help/gnome-db/pt_BR/index.html
+share/gnome/help/gnome-db/pt_BR/introduction.html
+share/gnome/help/gnome-db/pt_BR/ln45.html
+share/gnome/help/gnome-db/pt_BR/manager-config-components.html
+share/gnome/help/gnome-db/pt_BR/manager.html
+share/gnome/help/gnome-db/pt_BR/topic.dat
+share/gnome/help/gnome-db/pt_BR/widgetlib-overview.html
+share/gnome/help/gnome-db/pt_BR/widgetlib.html
share/gnome/html/libgnomedb-decl.txt
share/gnome/html/libgnomedb-sections.txt
share/gnome/html/libgnomedb.args
share/gnome/html/libgnomedb.hierarchy
share/gnome/html/libgnomedb.signals
share/gnome/html/libgnomedb.types
-share/idl/GnomeDB.idl
+share/gnome/oaf/GNOME_DB_Builder.oaf
+share/gnome/oaf/GNOME_DB_ComponentFactory.oaf
+share/gnome/oaf/GNOME_DB_Connection.oaf
+share/gnome/oaf/GNOME_DB_Designer.oaf
+share/gnome/oaf/GNOME_DB_Export.oaf
+share/gnome/oaf/GNOME_DB_Log.oaf
+share/gnome/oaf/GNOME_DB_Manager.oaf
+share/gnome/oaf/GNOME_DB_Monikers.oaf
+share/gnome/pixmaps/gnome-db.png
+share/gnome/idl/GnomeDB.idl
share/locale/ca/LC_MESSAGES/gnome-db.mo
share/locale/da/LC_MESSAGES/gnome-db.mo
share/locale/de/LC_MESSAGES/gnome-db.mo
@@ -69,4 +129,11 @@ share/locale/sl/LC_MESSAGES/gnome-db.mo
share/locale/sv/LC_MESSAGES/gnome-db.mo
share/locale/tr/LC_MESSAGES/gnome-db.mo
share/locale/uk/LC_MESSAGES/gnome-db.mo
+@dirrm share/gnome/help/gnome-db/pt_BR/images
+@dirrm share/gnome/help/gnome-db/pt_BR
+@dirrm share/gnome/help/gnome-db/es/images
+@dirrm share/gnome/help/gnome-db/es
+@dirrm share/gnome/help/gnome-db/C/images
+@dirrm share/gnome/help/gnome-db/C
+@dirrm share/gnome/help/gnome-db
@dirrm include/gnome-db
diff --git a/databases/gnomedb/Makefile b/databases/gnomedb/Makefile
index 6636a06c844c..872231cf64ae 100644
--- a/databases/gnomedb/Makefile
+++ b/databases/gnomedb/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= bonobo.2:${PORTSDIR}/devel/bonobo \
USE_X_PREFIX= yes
USE_GNOMECTRL= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -31,6 +31,8 @@ pre-patch:
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ s|\$\(GNOME_datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(GNOME_datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/databases/gnomedb/files/patch-configure b/databases/gnomedb/files/patch-configure
index f9c35b7dfc9b..4c28f6fa60f3 100644
--- a/databases/gnomedb/files/patch-configure
+++ b/databases/gnomedb/files/patch-configure
@@ -1,39 +1,28 @@
---- configure.orig Fri Jun 15 15:39:00 2001
-+++ configure Tue Jun 19 02:24:00 2001
-@@ -5687,4 +5687,19 @@
-
--
--
-+# Actually configure libtool. ac_aux_dir is where install-sh is found.
-+CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
-+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
-+LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
-+DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-+${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
-+|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
-+
-+# Reload cache, that may have been modified by ltconfig
-+if test -r "$cache_file"; then
-+ echo "loading cache $cache_file"
-+ . $cache_file
-+else
-+ echo "creating cache $cache_file"
-+ > $cache_file
-+fi
-
-@@ -5692,3 +5707,3 @@
- # This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
-
-@@ -8823,3 +8838,3 @@
+
+$FreeBSD$
+
+--- configure.orig Thu Jul 26 16:38:59 2001
++++ configure Thu Jul 26 16:50:40 2001
+@@ -8821,7 +8836,7 @@
+
+
-if test $perl_val == true; then
+if [ $perl_val = true ]; then
WITH_PERL_TRUE=
-@@ -8833,3 +8848,3 @@
+ WITH_PERL_FALSE='#'
+ else
+@@ -8831,11 +8846,11 @@
+
+ GNOMEDB_CFLAGS="`gda-config --cflags client` `gnome-config --cflags xml oaf bonobox print`"
GNOMEDB_LIBS="`gda-config --libs client` `gnome-config --libs xml oaf bonobox print`"
-GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${datadir}/locale\\\""
+GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${prefix}/share/locale\\\""
+
+
+-GNOMEDB_oafdir=`oaf-config --prefix`/share/oaf
++GNOMEDB_oafdir=`oaf-config --prefix`/share/gnome/oaf
+
+
+
diff --git a/databases/gnomedb/files/patch-idl::Makefile.in b/databases/gnomedb/files/patch-idl::Makefile.in
new file mode 100644
index 000000000000..da60a4cfbf63
--- /dev/null
+++ b/databases/gnomedb/files/patch-idl::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- idl/Makefile.in 2001/07/26 14:06:24 1.1
++++ idl/Makefile.in 2001/07/26 14:06:37
+@@ -153,7 +153,7 @@
+ EXTRA_DIST = $(IDL_FILES)
+
+
+-idldir = $(prefix)/share/idl
++idldir = $(prefix)/share/gnome/idl
+ idl_DATA = $(IDL_FILES)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
diff --git a/databases/gnomedb/files/patch-ltmain.sh b/databases/gnomedb/files/patch-ltmain.sh
new file mode 100644
index 000000000000..0c594216b0e1
--- /dev/null
+++ b/databases/gnomedb/files/patch-ltmain.sh
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/07/23 09:45:58 1.1
++++ ltmain.sh 2001/07/23 09:46:28
+@@ -4175,10 +4175,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/databases/gnomedb/pkg-plist b/databases/gnomedb/pkg-plist
index ea728fa3943a..368fc53aa312 100644
--- a/databases/gnomedb/pkg-plist
+++ b/databases/gnomedb/pkg-plist
@@ -39,13 +39,73 @@ lib/bonobo/monikers/libdatabase_moniker.so.0
lib/libgnomedb.a
lib/libgnomedb.so
lib/libgnomedb.so.0
+share/gnome/apps/Applications/gnomedb-fe.desktop
+share/gnome/help/gnome-db/C/comlib.html
+share/gnome/help/gnome-db/C/components.html
+share/gnome/help/gnome-db/C/docbook.css
+share/gnome/help/gnome-db/C/fdl-section1.html
+share/gnome/help/gnome-db/C/fdl-section10.html
+share/gnome/help/gnome-db/C/fdl-section2.html
+share/gnome/help/gnome-db/C/fdl-section3.html
+share/gnome/help/gnome-db/C/fdl-section4.html
+share/gnome/help/gnome-db/C/fdl-section5.html
+share/gnome/help/gnome-db/C/fdl-section6.html
+share/gnome/help/gnome-db/C/fdl-section7.html
+share/gnome/help/gnome-db/C/fdl-section8.html
+share/gnome/help/gnome-db/C/fdl-section9.html
+share/gnome/help/gnome-db/C/fdl-using.html
+share/gnome/help/gnome-db/C/fdl.html
+share/gnome/help/gnome-db/C/fe.html
+share/gnome/help/gnome-db/C/index.html
+share/gnome/help/gnome-db/C/introduction.html
+share/gnome/help/gnome-db/C/ln44.html
+share/gnome/help/gnome-db/C/manager-config-components.html
+share/gnome/help/gnome-db/C/manager.html
+share/gnome/help/gnome-db/C/topic.dat
+share/gnome/help/gnome-db/C/widgetlib-overview.html
+share/gnome/help/gnome-db/C/widgetlib.html
+share/gnome/help/gnome-db/es/comlib.html
+share/gnome/help/gnome-db/es/components.html
+share/gnome/help/gnome-db/es/docbook.css
+share/gnome/help/gnome-db/es/fe.html
+share/gnome/help/gnome-db/es/gnome-db.html
+share/gnome/help/gnome-db/es/index.html
+share/gnome/help/gnome-db/es/introduction.html
+share/gnome/help/gnome-db/es/ln50.html
+share/gnome/help/gnome-db/es/manager-config-components.html
+share/gnome/help/gnome-db/es/manager.html
+share/gnome/help/gnome-db/es/topic.dat
+share/gnome/help/gnome-db/es/widgetlib-overview.html
+share/gnome/help/gnome-db/es/widgetlib.html
+share/gnome/help/gnome-db/pt_BR/comlib.html
+share/gnome/help/gnome-db/pt_BR/components.html
+share/gnome/help/gnome-db/pt_BR/docbook.css
+share/gnome/help/gnome-db/pt_BR/fe.html
+share/gnome/help/gnome-db/pt_BR/gnome-db.html
+share/gnome/help/gnome-db/pt_BR/index.html
+share/gnome/help/gnome-db/pt_BR/introduction.html
+share/gnome/help/gnome-db/pt_BR/ln45.html
+share/gnome/help/gnome-db/pt_BR/manager-config-components.html
+share/gnome/help/gnome-db/pt_BR/manager.html
+share/gnome/help/gnome-db/pt_BR/topic.dat
+share/gnome/help/gnome-db/pt_BR/widgetlib-overview.html
+share/gnome/help/gnome-db/pt_BR/widgetlib.html
share/gnome/html/libgnomedb-decl.txt
share/gnome/html/libgnomedb-sections.txt
share/gnome/html/libgnomedb.args
share/gnome/html/libgnomedb.hierarchy
share/gnome/html/libgnomedb.signals
share/gnome/html/libgnomedb.types
-share/idl/GnomeDB.idl
+share/gnome/oaf/GNOME_DB_Builder.oaf
+share/gnome/oaf/GNOME_DB_ComponentFactory.oaf
+share/gnome/oaf/GNOME_DB_Connection.oaf
+share/gnome/oaf/GNOME_DB_Designer.oaf
+share/gnome/oaf/GNOME_DB_Export.oaf
+share/gnome/oaf/GNOME_DB_Log.oaf
+share/gnome/oaf/GNOME_DB_Manager.oaf
+share/gnome/oaf/GNOME_DB_Monikers.oaf
+share/gnome/pixmaps/gnome-db.png
+share/gnome/idl/GnomeDB.idl
share/locale/ca/LC_MESSAGES/gnome-db.mo
share/locale/da/LC_MESSAGES/gnome-db.mo
share/locale/de/LC_MESSAGES/gnome-db.mo
@@ -69,4 +129,11 @@ share/locale/sl/LC_MESSAGES/gnome-db.mo
share/locale/sv/LC_MESSAGES/gnome-db.mo
share/locale/tr/LC_MESSAGES/gnome-db.mo
share/locale/uk/LC_MESSAGES/gnome-db.mo
+@dirrm share/gnome/help/gnome-db/pt_BR/images
+@dirrm share/gnome/help/gnome-db/pt_BR
+@dirrm share/gnome/help/gnome-db/es/images
+@dirrm share/gnome/help/gnome-db/es
+@dirrm share/gnome/help/gnome-db/C/images
+@dirrm share/gnome/help/gnome-db/C
+@dirrm share/gnome/help/gnome-db
@dirrm include/gnome-db
diff --git a/databases/gnomedb2/Makefile b/databases/gnomedb2/Makefile
index 6636a06c844c..872231cf64ae 100644
--- a/databases/gnomedb2/Makefile
+++ b/databases/gnomedb2/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= bonobo.2:${PORTSDIR}/devel/bonobo \
USE_X_PREFIX= yes
USE_GNOMECTRL= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -31,6 +31,8 @@ pre-patch:
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ s|\$\(GNOME_datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(GNOME_datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/databases/gnomedb2/files/patch-configure b/databases/gnomedb2/files/patch-configure
index f9c35b7dfc9b..4c28f6fa60f3 100644
--- a/databases/gnomedb2/files/patch-configure
+++ b/databases/gnomedb2/files/patch-configure
@@ -1,39 +1,28 @@
---- configure.orig Fri Jun 15 15:39:00 2001
-+++ configure Tue Jun 19 02:24:00 2001
-@@ -5687,4 +5687,19 @@
-
--
--
-+# Actually configure libtool. ac_aux_dir is where install-sh is found.
-+CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
-+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
-+LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
-+DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-+${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
-+|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
-+
-+# Reload cache, that may have been modified by ltconfig
-+if test -r "$cache_file"; then
-+ echo "loading cache $cache_file"
-+ . $cache_file
-+else
-+ echo "creating cache $cache_file"
-+ > $cache_file
-+fi
-
-@@ -5692,3 +5707,3 @@
- # This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
-
-@@ -8823,3 +8838,3 @@
+
+$FreeBSD$
+
+--- configure.orig Thu Jul 26 16:38:59 2001
++++ configure Thu Jul 26 16:50:40 2001
+@@ -8821,7 +8836,7 @@
+
+
-if test $perl_val == true; then
+if [ $perl_val = true ]; then
WITH_PERL_TRUE=
-@@ -8833,3 +8848,3 @@
+ WITH_PERL_FALSE='#'
+ else
+@@ -8831,11 +8846,11 @@
+
+ GNOMEDB_CFLAGS="`gda-config --cflags client` `gnome-config --cflags xml oaf bonobox print`"
GNOMEDB_LIBS="`gda-config --libs client` `gnome-config --libs xml oaf bonobox print`"
-GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${datadir}/locale\\\""
+GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${prefix}/share/locale\\\""
+
+
+-GNOMEDB_oafdir=`oaf-config --prefix`/share/oaf
++GNOMEDB_oafdir=`oaf-config --prefix`/share/gnome/oaf
+
+
+
diff --git a/databases/gnomedb2/files/patch-idl::Makefile.in b/databases/gnomedb2/files/patch-idl::Makefile.in
new file mode 100644
index 000000000000..da60a4cfbf63
--- /dev/null
+++ b/databases/gnomedb2/files/patch-idl::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- idl/Makefile.in 2001/07/26 14:06:24 1.1
++++ idl/Makefile.in 2001/07/26 14:06:37
+@@ -153,7 +153,7 @@
+ EXTRA_DIST = $(IDL_FILES)
+
+
+-idldir = $(prefix)/share/idl
++idldir = $(prefix)/share/gnome/idl
+ idl_DATA = $(IDL_FILES)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
diff --git a/databases/gnomedb2/files/patch-ltmain.sh b/databases/gnomedb2/files/patch-ltmain.sh
new file mode 100644
index 000000000000..0c594216b0e1
--- /dev/null
+++ b/databases/gnomedb2/files/patch-ltmain.sh
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/07/23 09:45:58 1.1
++++ ltmain.sh 2001/07/23 09:46:28
+@@ -4175,10 +4175,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/databases/gnomedb2/pkg-plist b/databases/gnomedb2/pkg-plist
index ea728fa3943a..368fc53aa312 100644
--- a/databases/gnomedb2/pkg-plist
+++ b/databases/gnomedb2/pkg-plist
@@ -39,13 +39,73 @@ lib/bonobo/monikers/libdatabase_moniker.so.0
lib/libgnomedb.a
lib/libgnomedb.so
lib/libgnomedb.so.0
+share/gnome/apps/Applications/gnomedb-fe.desktop
+share/gnome/help/gnome-db/C/comlib.html
+share/gnome/help/gnome-db/C/components.html
+share/gnome/help/gnome-db/C/docbook.css
+share/gnome/help/gnome-db/C/fdl-section1.html
+share/gnome/help/gnome-db/C/fdl-section10.html
+share/gnome/help/gnome-db/C/fdl-section2.html
+share/gnome/help/gnome-db/C/fdl-section3.html
+share/gnome/help/gnome-db/C/fdl-section4.html
+share/gnome/help/gnome-db/C/fdl-section5.html
+share/gnome/help/gnome-db/C/fdl-section6.html
+share/gnome/help/gnome-db/C/fdl-section7.html
+share/gnome/help/gnome-db/C/fdl-section8.html
+share/gnome/help/gnome-db/C/fdl-section9.html
+share/gnome/help/gnome-db/C/fdl-using.html
+share/gnome/help/gnome-db/C/fdl.html
+share/gnome/help/gnome-db/C/fe.html
+share/gnome/help/gnome-db/C/index.html
+share/gnome/help/gnome-db/C/introduction.html
+share/gnome/help/gnome-db/C/ln44.html
+share/gnome/help/gnome-db/C/manager-config-components.html
+share/gnome/help/gnome-db/C/manager.html
+share/gnome/help/gnome-db/C/topic.dat
+share/gnome/help/gnome-db/C/widgetlib-overview.html
+share/gnome/help/gnome-db/C/widgetlib.html
+share/gnome/help/gnome-db/es/comlib.html
+share/gnome/help/gnome-db/es/components.html
+share/gnome/help/gnome-db/es/docbook.css
+share/gnome/help/gnome-db/es/fe.html
+share/gnome/help/gnome-db/es/gnome-db.html
+share/gnome/help/gnome-db/es/index.html
+share/gnome/help/gnome-db/es/introduction.html
+share/gnome/help/gnome-db/es/ln50.html
+share/gnome/help/gnome-db/es/manager-config-components.html
+share/gnome/help/gnome-db/es/manager.html
+share/gnome/help/gnome-db/es/topic.dat
+share/gnome/help/gnome-db/es/widgetlib-overview.html
+share/gnome/help/gnome-db/es/widgetlib.html
+share/gnome/help/gnome-db/pt_BR/comlib.html
+share/gnome/help/gnome-db/pt_BR/components.html
+share/gnome/help/gnome-db/pt_BR/docbook.css
+share/gnome/help/gnome-db/pt_BR/fe.html
+share/gnome/help/gnome-db/pt_BR/gnome-db.html
+share/gnome/help/gnome-db/pt_BR/index.html
+share/gnome/help/gnome-db/pt_BR/introduction.html
+share/gnome/help/gnome-db/pt_BR/ln45.html
+share/gnome/help/gnome-db/pt_BR/manager-config-components.html
+share/gnome/help/gnome-db/pt_BR/manager.html
+share/gnome/help/gnome-db/pt_BR/topic.dat
+share/gnome/help/gnome-db/pt_BR/widgetlib-overview.html
+share/gnome/help/gnome-db/pt_BR/widgetlib.html
share/gnome/html/libgnomedb-decl.txt
share/gnome/html/libgnomedb-sections.txt
share/gnome/html/libgnomedb.args
share/gnome/html/libgnomedb.hierarchy
share/gnome/html/libgnomedb.signals
share/gnome/html/libgnomedb.types
-share/idl/GnomeDB.idl
+share/gnome/oaf/GNOME_DB_Builder.oaf
+share/gnome/oaf/GNOME_DB_ComponentFactory.oaf
+share/gnome/oaf/GNOME_DB_Connection.oaf
+share/gnome/oaf/GNOME_DB_Designer.oaf
+share/gnome/oaf/GNOME_DB_Export.oaf
+share/gnome/oaf/GNOME_DB_Log.oaf
+share/gnome/oaf/GNOME_DB_Manager.oaf
+share/gnome/oaf/GNOME_DB_Monikers.oaf
+share/gnome/pixmaps/gnome-db.png
+share/gnome/idl/GnomeDB.idl
share/locale/ca/LC_MESSAGES/gnome-db.mo
share/locale/da/LC_MESSAGES/gnome-db.mo
share/locale/de/LC_MESSAGES/gnome-db.mo
@@ -69,4 +129,11 @@ share/locale/sl/LC_MESSAGES/gnome-db.mo
share/locale/sv/LC_MESSAGES/gnome-db.mo
share/locale/tr/LC_MESSAGES/gnome-db.mo
share/locale/uk/LC_MESSAGES/gnome-db.mo
+@dirrm share/gnome/help/gnome-db/pt_BR/images
+@dirrm share/gnome/help/gnome-db/pt_BR
+@dirrm share/gnome/help/gnome-db/es/images
+@dirrm share/gnome/help/gnome-db/es
+@dirrm share/gnome/help/gnome-db/C/images
+@dirrm share/gnome/help/gnome-db/C
+@dirrm share/gnome/help/gnome-db
@dirrm include/gnome-db