aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2018-04-05 12:55:36 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2018-04-05 12:55:36 +0000
commit45736561e42fd55d34e4265ea96398b827aef232 (patch)
treec7fa3cb4cac7f978c69b35932f6eb56b04459045
parentdb97bfc48e744c109dee9f0e3913c0bd4b29b71f (diff)
downloadports-45736561e42fd55d34e4265ea96398b827aef232.tar.gz
ports-45736561e42fd55d34e4265ea96398b827aef232.zip
databases/couchdb: use lang/erlang-runtime19 in preparation for
the Erlang 20 upgrade.
Notes
Notes: svn path=/head/; revision=466557
-rw-r--r--databases/couchdb/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index 6b22a58621d6..6a0d976b6ff3 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= couchdb
DISTVERSION= 1.7.1
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= databases
MASTER_SITES= APACHE/couchdb/source/${DISTVERSION}
@@ -18,8 +19,8 @@ LIB_DEPENDS= libicudata.so:devel/icu \
libmozjs185.so:lang/spidermonkey185 \
libcurl.so:ftp/curl
BUILD_DEPENDS= ${LOCALBASE}/bin/help2man:misc/help2man \
- erlang>=15.b.01,2:lang/erlang
-RUN_DEPENDS= erlang>=15.b.01,2:lang/erlang
+ erlang-runtime19>=19.3:lang/erlang-runtime19
+RUN_DEPENDS= erlang-runtime19>=19.3:lang/erlang-runtime19
USES= cpe gmake libtool
USE_RC_SUBR= couchdb
@@ -28,11 +29,13 @@ PLIST_SUB= VERSION=${DISTVERSION}
CPE_VENDOR= apache
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-erlang=${LOCALBASE}/lib/erlang/usr/include \
+CONFIGURE_ARGS= --with-erlang=${LOCALBASE}/lib/erlang19/usr/include \
--localstatedir=/var \
--disable-init \
--with-js-include=${LOCALBASE}/include/js \
--with-js-lib=${LOCALBASE}/lib
+CONFIGURE_ENV+= ERL=${LOCALBASE}/lib/erlang19/bin/erl \
+ ERLC=${LOCALBASE}/lib/erlang19/bin/erlc
USERS= couchdb
GROUPS= couchdb