aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2022-05-14 04:00:56 +0000
committerAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2022-05-14 04:00:56 +0000
commit4c0dedf27c82d73b6c00a9f4633dde5c25a91e23 (patch)
tree4bdc3d26fe848f530a22491baed7126811a2ab15
parent1aeecb4c60d01dcaf440c50ac8d15ed2dde09a04 (diff)
downloadports-4c0dedf27c82d73b6c00a9f4633dde5c25a91e23.tar.gz
ports-4c0dedf27c82d73b6c00a9f4633dde5c25a91e23.zip
dns/yandex-ddns: New Port
- Use Yandex DNS as a dynamic DNS service.
-rw-r--r--dns/Makefile1
-rw-r--r--dns/yandex-ddns/Makefile25
-rw-r--r--dns/yandex-ddns/distinfo3
-rw-r--r--dns/yandex-ddns/pkg-descr9
4 files changed, 38 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index c04e015a94a1..b02e7d48fc1f 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -244,6 +244,7 @@
SUBDIR += whoseip
SUBDIR += wrapsrv
SUBDIR += yadifa
+ SUBDIR += yandex-ddns
SUBDIR += zkt
SUBDIR += zonenotify
diff --git a/dns/yandex-ddns/Makefile b/dns/yandex-ddns/Makefile
new file mode 100644
index 000000000000..3534ab3a8cf7
--- /dev/null
+++ b/dns/yandex-ddns/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= yandex-ddns
+DISTVERSION= g20200613
+CATEGORIES= dns
+
+MAINTAINER= rigoletto@FreeBSD.org
+COMMENT= Use Yandex DNS as a dynamic DNS provider
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= thekvs
+GH_TAGNAME= 1fd0d00
+
+PLIST_FILES= bin/yandex-ddns\
+ ${EXAMPLESDIR}/yandex-ddns.example.toml
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/yandex-ddns.example.toml \
+ ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/dns/yandex-ddns/distinfo b/dns/yandex-ddns/distinfo
new file mode 100644
index 000000000000..2ba1cbd205b6
--- /dev/null
+++ b/dns/yandex-ddns/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1652498551
+SHA256 (thekvs-yandex-ddns-g20200613-1fd0d00_GH0.tar.gz) = 19066f7dbe07c5c9e0ea9fbaa402047b01ddb672ee0f530a50a61af7f5185e0a
+SIZE (thekvs-yandex-ddns-g20200613-1fd0d00_GH0.tar.gz) = 35710
diff --git a/dns/yandex-ddns/pkg-descr b/dns/yandex-ddns/pkg-descr
new file mode 100644
index 000000000000..ad00df27ca8f
--- /dev/null
+++ b/dns/yandex-ddns/pkg-descr
@@ -0,0 +1,9 @@
+Use Yandex DNS as a dynamic DNS service.
+
+This utility uses Yandex.Connect DNS service API to set external IP address
+for your domain. You can use this tool to manage external IP for your
+domain if it has internet connection with changeable IP address. To
+determine your external IP address utility uses myexternalip.com and
+ifconfig.co services.
+
+WWW: https://github.com/thekvs/yandex-ddns