aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-19 17:11:58 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-19 17:11:58 +0000
commit5079067642cdaa8d4fa504ad697c33d0e0c117da (patch)
treef5610b6800beb82c0dc7ebca38059e2c6aede541
parent8f2c2048f50555155b1835abcc693832ae639894 (diff)
downloadports-5079067642cdaa8d4fa504ad697c33d0e0c117da.tar.gz
ports-5079067642cdaa8d4fa504ad697c33d0e0c117da.zip
Move devel/py-icu to devel/py-pyicu
* PORTNAME devel/py-pyicu should be used rather than devel/py-icu, per policy [1] * Add LICENSE=MIT as per LICENSE file contained in distfile * Tidy up MAKE_ENV variable assignment (pet portlint) * Update WWW in pkg-descr to point to PyPI site, since the old site is down * Update other ports which depend on devel/py-icu to point to devel/py-pyicu [1] https://wiki.freebsd.org/Python/PortsPolicy PR: 207367 Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=411415
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile2
-rw-r--r--devel/py-pyicu/Makefile (renamed from devel/py-icu/Makefile)14
-rw-r--r--devel/py-pyicu/distinfo (renamed from devel/py-icu/distinfo)0
-rw-r--r--devel/py-pyicu/pkg-descr (renamed from devel/py-icu/pkg-descr)2
-rw-r--r--science/gramps/Makefile4
-rw-r--r--sysutils/py-freenas.cli/Makefile3
7 files changed, 15 insertions, 11 deletions
diff --git a/MOVED b/MOVED
index a2ba575eb991..5882af817264 100644
--- a/MOVED
+++ b/MOVED
@@ -8234,3 +8234,4 @@ security/openvas-libnasl|security/openvas-libraries|2016-03-17|Merged
security/openvas-server|security/openvas-scanner|2016-03-17|Renamed
security/openvas-plugins|security/openvas-scanner|2016-03-17|Merged
security/openvas-client||2016-03-17|Discontinued, try security/greenbone-security-assistant
+devel/py-icu|devel/py-pyicu|2016-03-19|Renamed to match upstream (PyPI) name
diff --git a/devel/Makefile b/devel/Makefile
index e543216f92d1..ab6382e8b0bb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4109,7 +4109,6 @@
SUBDIR += py-hypothesis
SUBDIR += py-icalendar
SUBDIR += py-ice
- SUBDIR += py-icu
SUBDIR += py-iniparse
SUBDIR += py-initgroups
SUBDIR += py-instant
@@ -4268,6 +4267,7 @@
SUBDIR += py-pygit2
SUBDIR += py-pygithub
SUBDIR += py-pygpx
+ SUBDIR += py-pyicu
SUBDIR += py-pyinotify
SUBDIR += py-pyinstaller
SUBDIR += py-pykde4
diff --git a/devel/py-icu/Makefile b/devel/py-pyicu/Makefile
index a58a926d5dcb..640f0944a3a2 100644
--- a/devel/py-icu/Makefile
+++ b/devel/py-pyicu/Makefile
@@ -1,9 +1,9 @@
# Created by: bland@FreeBSD.org
# $FreeBSD$
-PORTNAME= icu
+PORTNAME= pyicu
PORTVERSION= 1.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,13 +12,15 @@ DISTNAME= PyICU-${PORTVERSION}
MAINTAINER= bland@FreeBSD.org
COMMENT= Python extension wrapping IBM's ICU C++ API
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
USES= python
USE_PYTHON= distutils autoplist
-MAKE_ENV+= \
- PYICU_INCLUDES="${PREFIX}/include" \
- PYICU_CFLAGS="-w:-DPYICU_VER=\"$(PORTVERSION)\"" \
- PYICU_LFLAGS="-L${PREFIX}/lib"
+MAKE_ENV+= PYICU_INCLUDES="${PREFIX}/include" \
+ PYICU_CFLAGS="-w:-DPYICU_VER=\"${PORTVERSION}\"" \
+ PYICU_LFLAGS="-L${PREFIX}/lib"
LIB_DEPENDS+= libicudata.so:${PORTSDIR}/devel/icu
diff --git a/devel/py-icu/distinfo b/devel/py-pyicu/distinfo
index 7616aaa4d56b..7616aaa4d56b 100644
--- a/devel/py-icu/distinfo
+++ b/devel/py-pyicu/distinfo
diff --git a/devel/py-icu/pkg-descr b/devel/py-pyicu/pkg-descr
index 280b7aa24ef4..39d55898eec9 100644
--- a/devel/py-icu/pkg-descr
+++ b/devel/py-pyicu/pkg-descr
@@ -1,4 +1,4 @@
PyICU is a python extension wrapping IBM's ICU C++ API.
PyICU is supported on Mac OS X, Linux (32- and 64-bit) and Windows.
-WWW: http://pyicu.osafoundation.org/
+WWW: https://pypi.python.org/pypi/PyICU/
diff --git a/science/gramps/Makefile b/science/gramps/Makefile
index 0175df874c6a..17afb15cfb48 100644
--- a/science/gramps/Makefile
+++ b/science/gramps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gramps
PORTVERSION= 3.4.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science gnome python
MASTER_SITES= SF/${PORTNAME}/Stable/${PORTVERSION}
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:${PORTSDIR}/databases/py-bsddb \
- ${PYTHON_PKGNAMEPREFIX}icu>=1.8:${PORTSDIR}/devel/py-icu
+ ${PYTHON_PKGNAMEPREFIX}pyicu>=1.8:${PORTSDIR}/devel/py-pyicu
NO_ARCH= yes
USE_BDB= 5+
diff --git a/sysutils/py-freenas.cli/Makefile b/sysutils/py-freenas.cli/Makefile
index 95763bcc3372..6427099c061f 100644
--- a/sysutils/py-freenas.cli/Makefile
+++ b/sysutils/py-freenas.cli/Makefile
@@ -2,6 +2,7 @@
PORTNAME= freenas.cli
PORTVERSION= 10.2a6
+PORTREVISION= 1
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +12,7 @@ COMMENT= FreeNAS Command Line Interface
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}freenas.utils>0:${PORTSDIR}/devel/py-freenas.utils
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}columnize>0:${PORTSDIR}/devel/py-columnize \
- ${PYTHON_PKGNAMEPREFIX}icu>0:${PORTSDIR}/devel/py-icu \
+ ${PYTHON_PKGNAMEPREFIX}pyicu>0:${PORTSDIR}/devel/py-pyicu \
${PYTHON_PKGNAMEPREFIX}natural>0:${PORTSDIR}/devel/py-natural \
${PYTHON_PKGNAMEPREFIX}ply>0:${PORTSDIR}/devel/py-ply \
${PYTHON_PKGNAMEPREFIX}termcolor>0:${PORTSDIR}/devel/py-termcolor \