aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-19 00:41:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-19 00:46:31 +0000
commit52fb727e6af98df359be2716ac376f5f44ed9ec3 (patch)
tree8ef6662575dced98c1e4ce2a52db85802bb16488
parent7048b955e46842d4635778fe938baac9c3b8f0b2 (diff)
downloadports-52fb727e6af98df359be2716ac376f5f44ed9ec3.tar.gz
ports-52fb727e6af98df359be2716ac376f5f44ed9ec3.zip
audio/carla: Update 2.4.3 -> 2.5.0
Reported by: portscout
-rw-r--r--audio/carla/Makefile8
-rw-r--r--audio/carla/distinfo8
-rw-r--r--audio/carla/files/patch-source_Makefile.mk13
-rw-r--r--audio/carla/files/patch-source_modules_ysfx_sources_ysfx__utils__fts.cpp13
-rw-r--r--audio/carla/files/patch-source_utils_CarlaPluginUI.cpp13
-rw-r--r--audio/carla/pkg-plist2
6 files changed, 25 insertions, 32 deletions
diff --git a/audio/carla/Makefile b/audio/carla/Makefile
index 758a8787a174..290c7c81bb33 100644
--- a/audio/carla/Makefile
+++ b/audio/carla/Makefile
@@ -1,8 +1,11 @@
PORTNAME= Carla
DISTVERSIONPREFIX= v
-DISTVERSION= 2.4.3
+DISTVERSION= 2.5.0
CATEGORIES= audio
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= 5aba957f3cf0fb4dcef4d2add679603e6c048fb4.diff:-p1
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= Audio plugin host for Jack and PulseAudio
@@ -14,13 +17,14 @@ LIB_DEPENDS= liblo.so:audio/liblo \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyliblo>0:audio/py-pyliblo@${PY_FLAVOR}
USES= compiler:c++11-lib desktop-file-utils gl gmake gnome localbase \
- pkgconfig pyqt:5 python:3.4+ qt:5 shared-mime-info shebangfix \
+ pkgconfig pyqt:5 python:3.4+ qt:5 sdl shared-mime-info shebangfix \
tar:bz2 xorg
USE_PYQT= pyqt5 sip
USE_GNOME= gtk20 gtk30
USE_QT= core gui widgets buildtools_build
USE_GL= gl
USE_XORG= x11
+USE_SDL= sdl2
USE_LDCONFIG= ${PREFIX}/lib/carla
CONFLICTS_BUILD= rtaudio rtmidi
diff --git a/audio/carla/distinfo b/audio/carla/distinfo
index 66dadcecf20e..67cfdc2f7a76 100644
--- a/audio/carla/distinfo
+++ b/audio/carla/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1650173689
-SHA256 (falkTX-Carla-v2.4.3_GH0.tar.gz) = 0092926e5167f3a5eb592f0055e5491803354ae42947e706db0dc548d9e786d3
-SIZE (falkTX-Carla-v2.4.3_GH0.tar.gz) = 10057018
+TIMESTAMP = 1658075318
+SHA256 (falkTX-Carla-v2.5.0_GH0.tar.gz) = f1077caa97b52fedc0d567f7f0e561b466031b5b34b760cd68efe836e19d408d
+SIZE (falkTX-Carla-v2.5.0_GH0.tar.gz) = 11533773
+SHA256 (5aba957f3cf0fb4dcef4d2add679603e6c048fb4.diff) = 1709d27634fc68794b72a200905e1cb6b2dd35aa0df16a9fd3fe7926cfb7d91a
+SIZE (5aba957f3cf0fb4dcef4d2add679603e6c048fb4.diff) = 432
diff --git a/audio/carla/files/patch-source_Makefile.mk b/audio/carla/files/patch-source_Makefile.mk
deleted file mode 100644
index 4ffda8ab2cae..000000000000
--- a/audio/carla/files/patch-source_Makefile.mk
+++ /dev/null
@@ -1,13 +0,0 @@
-- workaround for https://github.com/falkTX/Carla/issues/1608: error: unknown argument: '-fno-gnu-unique'
-
---- source/Makefile.mk.orig 2022-04-17 05:37:05 UTC
-+++ source/Makefile.mk
-@@ -86,7 +86,7 @@ endif
-
- ifneq ($(MACOS),true)
- ifneq ($(WIN32),true)
--BASE_FLAGS += -fno-gnu-unique
-+#BASE_FLAGS += -fno-gnu-unique
- endif
- endif
-
diff --git a/audio/carla/files/patch-source_modules_ysfx_sources_ysfx__utils__fts.cpp b/audio/carla/files/patch-source_modules_ysfx_sources_ysfx__utils__fts.cpp
new file mode 100644
index 000000000000..ece3249b2fa1
--- /dev/null
+++ b/audio/carla/files/patch-source_modules_ysfx_sources_ysfx__utils__fts.cpp
@@ -0,0 +1,13 @@
+- workaround for https://github.com/jpcima/ysfx/issues/61
+
+--- source/modules/ysfx/sources/ysfx_utils_fts.cpp.orig 2022-07-17 16:50:07 UTC
++++ source/modules/ysfx/sources/ysfx_utils_fts.cpp
+@@ -36,7 +36,7 @@ void visit_directories(const char *rootpath, bool (*vi
+ #ifndef __EMSCRIPTEN__
+ char *argv[] = {(char *)rootpath, nullptr};
+
+- auto compar = [](const FTSENT **a, const FTSENT **b) -> int {
++ auto compar = [](const FTSENT * const *a, const FTSENT * const *b) -> int {
+ return strcmp((*a)->fts_name, (*b)->fts_name);
+ };
+
diff --git a/audio/carla/files/patch-source_utils_CarlaPluginUI.cpp b/audio/carla/files/patch-source_utils_CarlaPluginUI.cpp
deleted file mode 100644
index ed5dcda5d2a2..000000000000
--- a/audio/carla/files/patch-source_utils_CarlaPluginUI.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-- fix build on 12, see https://github.com/falkTX/Carla/issues/1597
-
---- source/utils/CarlaPluginUI.cpp.orig 2022-03-06 18:03:22 UTC
-+++ source/utils/CarlaPluginUI.cpp
-@@ -40,6 +40,8 @@
- # error CARLA_PLUGIN_UI_CLASS_PREFIX undefined
- #endif
-
-+#include <pthread.h>
-+
- // ---------------------------------------------------------------------------------------------------------------------
- // X11
-
diff --git a/audio/carla/pkg-plist b/audio/carla/pkg-plist
index 0c8833b0c04f..ccec10c630a0 100644
--- a/audio/carla/pkg-plist
+++ b/audio/carla/pkg-plist
@@ -205,12 +205,12 @@ share/carla/ui_xycontroller.py
share/carla/widgets/__init__.py
share/carla/widgets/canvaspreviewframe.py
share/carla/widgets/collapsablewidget.py
+share/carla/widgets/commondial.py
share/carla/widgets/digitalpeakmeter.py
share/carla/widgets/draggablegraphicsview.py
share/carla/widgets/ledbutton.py
share/carla/widgets/paramspinbox.py
share/carla/widgets/pianoroll.py
-share/carla/widgets/pixmapbutton.py
share/carla/widgets/pixmapdial.py
share/carla/widgets/pixmapkeyboard.py
share/carla/widgets/racklistwidget.py