aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-08 07:22:59 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-08 07:22:59 +0000
commit56fe4d2557abd34277f8940ddd087580cc25950d (patch)
tree5063d8a8d58f9d6f759b9792339dde3b220c76d1
parentc9062744d896f2e8e5b341201cdde1666058c467 (diff)
downloadports-56fe4d2557abd34277f8940ddd087580cc25950d.tar.gz
ports-56fe4d2557abd34277f8940ddd087580cc25950d.zip
security/py-noiseprotocol: Add new port
Python implementation of Noise Protocol Framework. It is compatible with revisions 32 and 33.
-rw-r--r--security/Makefile1
-rw-r--r--security/py-noiseprotocol/Makefile19
-rw-r--r--security/py-noiseprotocol/distinfo3
-rw-r--r--security/py-noiseprotocol/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c2a99520b98d..bf78e1cf2535 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -902,6 +902,7 @@
SUBDIR += py-muacrypt
SUBDIR += py-netbox-secretstore
SUBDIR += py-netmiko
+ SUBDIR += py-noiseprotocol
SUBDIR += py-ntlm-auth
SUBDIR += py-oauth2client
SUBDIR += py-oauthlib
diff --git a/security/py-noiseprotocol/Makefile b/security/py-noiseprotocol/Makefile
new file mode 100644
index 000000000000..6d39559f584f
--- /dev/null
+++ b/security/py-noiseprotocol/Makefile
@@ -0,0 +1,19 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+
+PORTNAME= noiseprotocol
+PORTVERSION= 0.3.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Python implementation of Noise Protocol Framework
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.8:security/py-cryptography@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-noiseprotocol/distinfo b/security/py-noiseprotocol/distinfo
new file mode 100644
index 000000000000..b54200755ac1
--- /dev/null
+++ b/security/py-noiseprotocol/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1647858299
+SHA256 (noiseprotocol-0.3.1.tar.gz) = b092a871b60f6a8f07f17950dc9f7098c8fe7d715b049bd4c24ee3752b90d645
+SIZE (noiseprotocol-0.3.1.tar.gz) = 16890
diff --git a/security/py-noiseprotocol/pkg-descr b/security/py-noiseprotocol/pkg-descr
new file mode 100644
index 000000000000..134c68aa8df1
--- /dev/null
+++ b/security/py-noiseprotocol/pkg-descr
@@ -0,0 +1,4 @@
+Python implementation of Noise Protocol Framework. It is compatible
+with revisions 32 and 33.
+
+WWW: https://pypi.org/project/noiseprotocol/