aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2022-09-16 03:26:18 +0000
committerJason E. Hale <jhale@FreeBSD.org>2022-09-16 03:56:45 +0000
commit5a19c0823bb11a2d2da10a3d92a574a8aafcb661 (patch)
tree9abec8ddedf592d7915de09722fc31908484d1c8
parentbf214dcabe40ff673af9fb152777da8e162a9bc5 (diff)
downloadports-5a19c0823bb11a2d2da10a3d92a574a8aafcb661.tar.gz
ports-5a19c0823bb11a2d2da10a3d92a574a8aafcb661.zip
security/cryptopp: Update to 8.7.0
Drop most of the SIMD logic. The cryptopp Makefile autodetects CPU features regardless if CPUTYPE is set and it is not possible to disable specific instruction sets. It is only possible to completely disable assembly optimizations, which is recommended for package building unless all consumer machines support the build machine's CPU instruction sets. Since version 8.1, it is no longer necessary to export -DCRYPTOPP_DISABLE_ASM to the pkgconfig file. Consumers will now build without it defined if the SIMD option is disabled. Remove old workarounds pertaining to this issue. https://github.com/weidai11/cryptopp/issues/779 Bump PORTREVISION on consumers due to ABI incompatibility. https://www.cryptopp.com/release870.html
-rw-r--r--archivers/ccmix/Makefile1
-rw-r--r--archivers/urbackup-client/Makefile2
-rw-r--r--archivers/urbackup-server/Makefile2
-rw-r--r--graphics/gdal/Makefile2
-rw-r--r--multimedia/kvazaar/Makefile1
-rw-r--r--net-p2p/amule-devel/Makefile3
-rw-r--r--net-p2p/amule/Makefile3
-rw-r--r--net/ceph14/Makefile2
-rw-r--r--net/megacmd/Makefile3
-rw-r--r--security/cryptopp/Makefile22
-rw-r--r--security/cryptopp/distinfo6
-rw-r--r--security/cryptopp/files/patch-GNUmakefile22
-rw-r--r--security/cryptopp/files/patch-misc.h8
13 files changed, 25 insertions, 52 deletions
diff --git a/archivers/ccmix/Makefile b/archivers/ccmix/Makefile
index 7bae252ed46b..3f79a0bb8e00 100644
--- a/archivers/ccmix/Makefile
+++ b/archivers/ccmix/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ccmix
PORTVERSION= g20170612
+PORTREVISION= 1
CATEGORIES= archivers games
MASTER_SITES= SF/xccu/XCC%20Mixer/XCC%20Mixer%201.44:dat
DISTFILES= XCC_Mixer-1.44.zip:dat
diff --git a/archivers/urbackup-client/Makefile b/archivers/urbackup-client/Makefile
index 0cff8d776a4a..a413f9ce015a 100644
--- a/archivers/urbackup-client/Makefile
+++ b/archivers/urbackup-client/Makefile
@@ -1,5 +1,6 @@
PORTNAME= urbackup-client
DISTVERSION= 2.5.20.0
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= https://hndl.urbackup.org/Client/${DISTVERSION:R}/
@@ -22,7 +23,6 @@ GROUPS= urbackup
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-clientupdate \
--without-embedded-sqlite3
-CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
SUB_FILES= pkg-message urbackupclient.conf.sample-daemon
diff --git a/archivers/urbackup-server/Makefile b/archivers/urbackup-server/Makefile
index 87d6c189a8be..05e8969b1d46 100644
--- a/archivers/urbackup-server/Makefile
+++ b/archivers/urbackup-server/Makefile
@@ -1,5 +1,6 @@
PORTNAME= urbackup-server
DISTVERSION= 2.5.26
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= https://hndl.urbackup.org/Server/${DISTVERSION}/
@@ -21,7 +22,6 @@ USE_RC_SUBR= urbackup_server
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-packaging --with-mountvhd --without-embedded-sqlite3 --without-embedded-lmdb --without-embedded-lua
-CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
LDFLAGS+= -L${LOCALBASE}/lib
SUB_FILES= pkg-message urbackupsrv.conf.sample-daemon
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index cba6a9c5622d..e94a2994d91f 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gdal
PORTVERSION= 3.5.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics geography
MASTER_SITES= https://download.osgeo.org/gdal/${PORTVERSION}/ \
LOCAL/sunpoet
diff --git a/multimedia/kvazaar/Makefile b/multimedia/kvazaar/Makefile
index 86a97b5f862d..35e585ddf1e5 100644
--- a/multimedia/kvazaar/Makefile
+++ b/multimedia/kvazaar/Makefile
@@ -1,6 +1,7 @@
PORTNAME= kvazaar
DISTVERSIONPREFIX= v
DISTVERSION?= 2.1.0
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= jbeich@FreeBSD.org
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index 910ffaafb2b4..71b0133156cb 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= amule
PORTVERSION= 11065
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p
MASTER_SITES= http://amule.sourceforge.net/tarballs/
PKGNAMESUFFIX= -devel
@@ -31,7 +31,6 @@ CONFIGURE_ARGS= --with-denoise-level=0
CONFIGURE_ENV= LEX="${FLEX}" PKG_CONFIG="${PKG_CONFIG}" \
docdir='$${prefix}/${DOCSDIR_REL}'
-CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
LDFLAGS+= -lpthread
OPTIONS_DEFINE= ALC ALCC AMULECMD AMULEDAEMON AMULEGUI BOOST CAS DEBUG DOCS \
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index b8554e095498..b035ad7d4426 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -1,6 +1,6 @@
PORTNAME= amule
PORTVERSION= 2.3.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/aMule/${PORTVERSION}
DISTNAME= aMule-${PORTVERSION}
@@ -25,7 +25,6 @@ CONFIGURE_ARGS= --with-denoise-level=0
CONFIGURE_ENV= LEX="${FLEX}" PKG_CONFIG="${PKG_CONFIG}" \
docdir='$${prefix}/${DOCSDIR_REL}'
-CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
LDFLAGS+= -lpthread
SHEBANG_FILES= src/utils/scripts/*.pl src/utils/xas/*.pl src/libs/ec/*.pl
diff --git a/net/ceph14/Makefile b/net/ceph14/Makefile
index 5d74b82bdf7e..211c3c8abc07 100644
--- a/net/ceph14/Makefile
+++ b/net/ceph14/Makefile
@@ -1,7 +1,7 @@
PORTNAME= ceph
DISTVERSIONPREFIX= v
DISTVERSION= 14.2.22
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
PKGNAMESUFFIX= 14
diff --git a/net/megacmd/Makefile b/net/megacmd/Makefile
index c5bfa0264a4d..184f9f9623f0 100644
--- a/net/megacmd/Makefile
+++ b/net/megacmd/Makefile
@@ -1,5 +1,6 @@
PORTNAME= megacmd
DISTVERSION= 1.5.0
+PORTREVISION= 1
DISTVERSIONSUFFIX= _Linux
CATEGORIES= net
@@ -97,6 +98,4 @@ CONFIGURE_ARGS= --disable-examples \
INSTALL_TARGET= install-strip
-CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
-
.include <bsd.port.mk>
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 193bc797cf85..f9fa20a3d824 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -1,5 +1,5 @@
PORTNAME= cryptopp
-PORTVERSION= 8.6.0
+PORTVERSION= 8.7.0
CATEGORIES= security
MASTER_SITES= http://www.cryptopp.com/
DISTNAME= cryptopp${PORTVERSION:S/.//g}
@@ -55,24 +55,8 @@ TOOLS_TEST_TARGET_OFF= test
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSIMD}
-. if ${ARCH} == i386 || ${ARCH} == amd64
-. if !${MACHINE_CPU:Msse2}
-CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM -DCRYPTOPP_DISABLE_SSE2
-. endif
-. if !${MACHINE_CPU:Mssse3}
-CXXFLAGS+= -DCRYPTOPP_DISABLE_SSSE3
-. endif
-. if !${MACHINE_CPU:Msse41}
-CXXFLAGS+= -DCRYPTOPP_DISABLE_SSE4
-. endif
-. elif ${ARCH} == powerpc || ${ARCH:Mpowerpc64*}
-CXXFLAGS+= -DCRYPTOPP_ALTIVEC_AVAILABLE
-. endif
-.else
-CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM -DCRYPTOPP_DISABLE_SSE2 \
- -DCRYPTOPP_DISABLE_SSSE3 -DCRYPTOPP_DISABLE_SSE4 \
- -DCRYPTOPP_DISABLE_ALTIVEC
+.if !${PORT_OPTIONS:MSIMD}
+CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM
.endif
pre-configure-FULL_DEBUG-on:
diff --git a/security/cryptopp/distinfo b/security/cryptopp/distinfo
index 136fac92348f..012fe83214ff 100644
--- a/security/cryptopp/distinfo
+++ b/security/cryptopp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1645715486
-SHA256 (cryptopp860.zip) = 20aa413957d9c8ae353ee2f7747bd7ac392f933c60a53e3fd1e41cadbc48d193
-SIZE (cryptopp860.zip) = 9274149
+TIMESTAMP = 1663283275
+SHA256 (cryptopp870.zip) = d0d3a28fcb5a1f6ed66b3adf57ecfaed234a7e194e42be465c2ba70c744538dd
+SIZE (cryptopp870.zip) = 9277791
diff --git a/security/cryptopp/files/patch-GNUmakefile b/security/cryptopp/files/patch-GNUmakefile
index 1fc8ef2b3017..8ad66cac17b6 100644
--- a/security/cryptopp/files/patch-GNUmakefile
+++ b/security/cryptopp/files/patch-GNUmakefile
@@ -1,10 +1,9 @@
-We need to export the CRYPTOPP_DISABLE_ASM flag if cryptopp was not built
-with SIMD support. Certain functions prototypes are guarded by this
-flag and build failures will arise in other ports if not set appropriately.
+Masquerade as Linux to enable certain build options.
+Always use pthread even if feature detection is disabled.
---- GNUmakefile.orig 2021-01-01 17:22:45 UTC
+--- GNUmakefile.orig 2022-08-07 19:52:03 UTC
+++ GNUmakefile
-@@ -71,7 +71,7 @@ ifeq ($(SYSTEMX),)
+@@ -70,7 +70,7 @@ endif
SYSTEMX := $(shell uname -s 2>/dev/null)
endif
@@ -13,7 +12,7 @@ flag and build failures will arise in other ports if not set appropriately.
IS_HURD := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c -E "GNU|Hurd")
IS_MINGW := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c "MinGW")
IS_CYGWIN := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c "Cygwin")
-@@ -795,7 +795,7 @@ endif
+@@ -848,7 +848,7 @@ endif
# Use -pthread whenever it is available. See http://www.hpl.hp.com/techreports/2004/HPL-2004-209.pdf
# http://stackoverflow.com/questions/2127797/gcc-significance-of-pthread-flag-when-compiling
@@ -21,13 +20,4 @@ flag and build failures will arise in other ports if not set appropriately.
+ifeq (1,1)
ifeq ($(XLC_COMPILER),1)
ifeq ($(findstring -qthreaded,$(CXXFLAGS)),)
- TPROG = TestPrograms/test_pthreads.cxx
-@@ -1450,7 +1450,7 @@ libcryptopp.pc:
- @echo 'Version: 8.4' >> libcryptopp.pc
- @echo 'URL: https://cryptopp.com/' >> libcryptopp.pc
- @echo '' >> libcryptopp.pc
-- @echo 'Cflags: -I$${includedir}' >> libcryptopp.pc
-+ @echo 'Cflags: -I$${includedir} $(findstring -DCRYPTOPP_DISABLE_ASM,$(CXXFLAGS))' >> libcryptopp.pc
- @echo 'Libs: -L$${libdir} -lcryptopp' >> libcryptopp.pc
-
- # This recipe prepares the distro files
+ TPROG = TestPrograms/test_pthreads.cpp
diff --git a/security/cryptopp/files/patch-misc.h b/security/cryptopp/files/patch-misc.h
index 165720d6bef7..7d923019af27 100644
--- a/security/cryptopp/files/patch-misc.h
+++ b/security/cryptopp/files/patch-misc.h
@@ -2,9 +2,9 @@ This fixes a warning triggered by testing an unsigned parameter
against 0. The patch solves this by creating a different template
for signed case. (PR: 178827)
---- misc.h.orig 2021-01-01 17:03:59 UTC
+--- misc.h.orig 2022-08-07 19:52:03 UTC
+++ misc.h
-@@ -700,8 +700,10 @@ inline bool SafeConvert(T1 from, T2 &to)
+@@ -720,8 +720,10 @@ inline bool SafeConvert(T1 from, T2 &to)
/// \param value the value to convert
/// \param base the base to use during the conversion
/// \return the string representation of value in base.
@@ -16,7 +16,7 @@ for signed case. (PR: 178827)
{
// Hack... set the high bit for uppercase.
const unsigned int HIGH_BIT = (1U << 31);
-@@ -712,12 +714,6 @@ std::string IntToString(T value, unsigned int base = 1
+@@ -732,12 +734,6 @@ std::string IntToString(T value, unsigned int base = 1
if (value == 0)
return "0";
@@ -29,7 +29,7 @@ for signed case. (PR: 178827)
std::string result;
while (value > 0)
{
-@@ -725,9 +721,28 @@ std::string IntToString(T value, unsigned int base = 1
+@@ -745,9 +741,28 @@ std::string IntToString(T value, unsigned int base = 1
result = char((digit < 10 ? '0' : (CH - 10)) + digit) + result;
value /= base;
}