aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-07-16 22:42:13 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-07-16 22:42:13 +0000
commit5d5f174a7a5d410d3080c0061932d51031a68f8a (patch)
tree0755569b3beed0cdb0eb93454f43951f25fc0a5c
parentf9f7185b38d9e6b3fe3c40802389c14dbf54fa35 (diff)
downloadports-5d5f174a7a5d410d3080c0061932d51031a68f8a.tar.gz
ports-5d5f174a7a5d410d3080c0061932d51031a68f8a.zip
- New port: seed7
Seed7 is an extensible general purpose high-level programming language.
Notes
Notes: svn path=/head/; revision=216938
-rw-r--r--lang/Makefile1
-rw-r--r--lang/seed7/Makefile47
-rw-r--r--lang/seed7/distinfo3
-rw-r--r--lang/seed7/files/patch-makefile45
-rw-r--r--lang/seed7/pkg-descr16
-rw-r--r--lang/seed7/pkg-plist151
6 files changed, 263 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index d7643d543ddb..3cbe2348db68 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -293,6 +293,7 @@
SUBDIR += sdcc-devel
SUBDIR += see
SUBDIR += see-devel
+ SUBDIR += seed7
SUBDIR += siod
SUBDIR += sisc
SUBDIR += sketchy
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
new file mode 100644
index 000000000000..0918ace01638
--- /dev/null
+++ b/lang/seed7/Makefile
@@ -0,0 +1,47 @@
+# New ports collection Makefile for: seed7
+# Date created: 16 July 2008
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= seed7
+DISTVERSION= 05_20080707
+CATEGORIES= lang
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A high-level, extensible programming language
+
+USE_GMAKE= yes
+USE_XORG= x11
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+MAKEFILE= makefile
+ALL_TARGET= hi
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/makefile
+
+do-configure:
+ (cd ${WRKSRC} && ${GMAKE} depend)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hi ${PREFIX}/bin
+ ${INSTALL} -d ${PREFIX}/lib/${PORTNAME}
+ (cd ${WRKSRC}/../lib && ${COPYTREE_SHARE} \* ${PREFIX}/lib/${PORTNAME})
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d ${DOCSDIR}
+ (cd ${WRKSRC}/../doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${INSTALL} -d ${EXAMPLESDIR}
+ (cd ${WRKSRC}/../prg && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
new file mode 100644
index 000000000000..4fa81da1f04b
--- /dev/null
+++ b/lang/seed7/distinfo
@@ -0,0 +1,3 @@
+MD5 (seed7_05_20080707.tgz) = 9397af2d9bec529eb2338eeca8c38e54
+SHA256 (seed7_05_20080707.tgz) = 30777009089f3524f689310460e71fb5a1fe7c745c99c8b2bdbb4d5154204271
+SIZE (seed7_05_20080707.tgz) = 1077384
diff --git a/lang/seed7/files/patch-makefile b/lang/seed7/files/patch-makefile
new file mode 100644
index 000000000000..423994b6b55a
--- /dev/null
+++ b/lang/seed7/files/patch-makefile
@@ -0,0 +1,45 @@
+--- makefile.orig 2008-07-07 22:39:27.000000000 +0200
++++ makefile 2008-07-17 00:20:55.000000000 +0200
+@@ -7,11 +7,11 @@
+ # CFLAGS =
+ # CFLAGS = -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
+ # CFLAGS = -O2 -fomit-frame-pointer -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
+-CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
++CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -I%%LOCALBASE%%/include
+ # CFLAGS = -O2 -g -pg -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
+ # CFLAGS = -O2 -fomit-frame-pointer -funroll-loops -Wall
+ # CFLAGS = -O2 -funroll-loops -Wall -pg
+-LFLAGS =
++LFLAGS = -L%%LOCALBASE%%/lib
+ # LFLAGS = -pg
+ # LFLAGS = -pg -lc_p
+ # LIBS = /usr/Xlib/libX11.so -lncurses -lm
+@@ -80,7 +80,6 @@
+
+ hi: $(OBJ) $(COMPILER_LIB) $(COMP_DATA_LIB) $(SEED7_LIB)
+ $(CC) $(LFLAGS) $(OBJ) $(COMPILER_LIB) $(COMP_DATA_LIB) $(SEED7_LIB) $(LIBS) -o hi
+- $(MAKE) ../prg/hi
+ ./hi level
+ # cp hi /usr/local/bin/hi
+
+@@ -177,16 +176,16 @@
+ $(CC) $(CFLAGS) -c hi.c
+
+ depend: a_depend b_depend c_depend version.h
+- $(CC) -M $(SRC) > depend
++ $(CC) -M ${CFLAGS} $(SRC) > depend
+
+ a_depend: version.h
+- $(CC) -M $(SEED7_LIB_SRC) > a_depend
++ $(CC) -M ${CFLAGS} $(SEED7_LIB_SRC) > a_depend
+
+ b_depend: version.h
+- $(CC) -M $(COMP_DATA_LIB_SRC) > b_depend
++ $(CC) -M ${CFLAGS} $(COMP_DATA_LIB_SRC) > b_depend
+
+ c_depend: version.h
+- $(CC) -M $(COMPILER_LIB_SRC) > c_depend
++ $(CC) -M ${CFLAGS} $(COMPILER_LIB_SRC) > c_depend
+
+ level.h:
+ hi level
diff --git a/lang/seed7/pkg-descr b/lang/seed7/pkg-descr
new file mode 100644
index 000000000000..a83d659f9893
--- /dev/null
+++ b/lang/seed7/pkg-descr
@@ -0,0 +1,16 @@
+Seed7 is an extensible general purpose programming language
+designed by Thomas Mertes. It is a higher level language
+compared to Ada, C/C++ and Java.
+
+Major features include:
+
+- user defined statements and operators,
+- abstract data types,
+- templates without special syntax,
+- OO with interfaces and multiple dispatch,
+- statically typed,
+- interpreted or compiled,
+- portable,
+- runs under linux/unix/windows.
+
+WWW: http://seed7.sourceforge.net/
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
new file mode 100644
index 000000000000..5122bb3761cb
--- /dev/null
+++ b/lang/seed7/pkg-plist
@@ -0,0 +1,151 @@
+bin/hi
+lib/seed7/COPYING
+lib/seed7/LGPL
+lib/seed7/bigfile.s7i
+lib/seed7/bigint.s7i
+lib/seed7/bigrat.s7i
+lib/seed7/cards.s7i
+lib/seed7/cgi.s7i
+lib/seed7/charsets.s7i
+lib/seed7/complex.s7i
+lib/seed7/dialog.s7i
+lib/seed7/dir.s7i
+lib/seed7/draw.s7i
+lib/seed7/echo.s7i
+lib/seed7/field.s7i
+lib/seed7/float.s7i
+lib/seed7/getf.s7i
+lib/seed7/graph.s7i
+lib/seed7/gtkserver.s7i
+lib/seed7/html_ent.s7i
+lib/seed7/keybd.s7i
+lib/seed7/line.s7i
+lib/seed7/lower.s7i
+lib/seed7/mahjng32.s7i
+lib/seed7/math.s7i
+lib/seed7/more.s7i
+lib/seed7/multiscr.s7i
+lib/seed7/pic16.s7i
+lib/seed7/pic32.s7i
+lib/seed7/progs.s7i
+lib/seed7/rational.s7i
+lib/seed7/reverse.s7i
+lib/seed7/scanfile.s7i
+lib/seed7/scanstri.s7i
+lib/seed7/screen.s7i
+lib/seed7/seed7_05.s7i
+lib/seed7/socket.s7i
+lib/seed7/stars.s7i
+lib/seed7/strifile.s7i
+lib/seed7/stritext.s7i
+lib/seed7/syntax.s7i
+lib/seed7/tee.s7i
+lib/seed7/time.s7i
+lib/seed7/upper.s7i
+lib/seed7/utf8.s7i
+lib/seed7/window.s7i
+lib/seed7/wrinum.s7i
+%%PORTDOCS%%%%DOCSDIR%%/chlog.txt
+%%PORTDOCS%%%%DOCSDIR%%/contact.txt
+%%PORTDOCS%%%%DOCSDIR%%/faq.htm
+%%PORTDOCS%%%%DOCSDIR%%/faq.txt
+%%PORTDOCS%%%%DOCSDIR%%/gtksvdoc.css
+%%PORTDOCS%%%%DOCSDIR%%/gtksvdoc.htm
+%%PORTDOCS%%%%DOCSDIR%%/gtksvdoc.txt
+%%PORTDOCS%%%%DOCSDIR%%/install.txt
+%%PORTDOCS%%%%DOCSDIR%%/inter.txt
+%%PORTDOCS%%%%DOCSDIR%%/manual.htm
+%%PORTDOCS%%%%DOCSDIR%%/manual.txt
+%%PORTDOCS%%%%DOCSDIR%%/problems.txt
+%%PORTDOCS%%%%DOCSDIR%%/robodoc.rc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/COPYING
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/LGPL
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addup.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bas7.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bifurk.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/blue.dna
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calc.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/carddemo.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/castle.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/castle.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cellauto.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/celsius.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chk_all.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkbig.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkbool.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkexc.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkflt.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkhent.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkint.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkprc.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkscan.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkset.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkstr.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clock.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clock2.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clock3.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cmpfil.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comp.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dirtst.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dirx.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dna_base.s7i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dnafight.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eliza.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/err.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fib.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/files
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gcd.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gkbd.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/green.dna
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gtksvtst.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hal.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hamu.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hanoi.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/indigo.dna
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kbd.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lander.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mahjong.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mandelbr.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mind.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ms.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nicoma.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orange.dna
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pac.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pairs.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/panic.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/planets.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/prime.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/printpi1.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/printpi2.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/printpi3.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rand.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/red.dna
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rever.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/roman.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/self.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shisen.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sl.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/snake.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/startrek.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sudoku7.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tak.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tan.dna
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tarx.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tch.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tet.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tetg.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/toutf8.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tst_cli.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tst_srv.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/violet.dna
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wator.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/white.dna
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wiz.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wordcnt.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wrinum.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wumpus.sd7
+@dirrm lib/seed7
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%