aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2022-02-21 13:15:18 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2022-02-21 15:12:19 +0000
commit615703b4b3192ad6e3722889a04f28f631e37e95 (patch)
treeb436c318be37050e7e5abdacb94b8df34a379351
parent05ab0b7b59aad904120f6a07d31a359a50b91b2b (diff)
downloadports-615703b4b3192ad6e3722889a04f28f631e37e95.tar.gz
ports-615703b4b3192ad6e3722889a04f28f631e37e95.zip
editors/diamond: distinguish from biology/diamond
Reported by: jrm
-rw-r--r--editors/diamond/Makefile5
-rw-r--r--editors/diamond/files/patch-src_CMakeLists.txt9
-rw-r--r--editors/diamond/pkg-plist2
3 files changed, 13 insertions, 3 deletions
diff --git a/editors/diamond/Makefile b/editors/diamond/Makefile
index 37f3d8a80606..58562eaf6d2c 100644
--- a/editors/diamond/Makefile
+++ b/editors/diamond/Makefile
@@ -1,7 +1,9 @@
PORTNAME= diamond
DISTVERSIONPREFIX= diamond-
DISTVERSION= 1.3.6
+PORTREVISION= 1
CATEGORIES= editors
+PKGNAMESUFFIX= -cs
MAINTAINER= adridg@FreeBSD.org
COMMENT= Compact programmers editor
@@ -9,7 +11,7 @@ COMMENT= Compact programmers editor
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell
+LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell
BUILD_DEPENDS= copperspice>=1.7:x11-toolkits/copperspice
RUN_DEPENDS= copperspice>=1.7:x11-toolkits/copperspice
@@ -23,4 +25,3 @@ GH_ACCOUNT= copperspice
GH_PROJECT= diamond
.include <bsd.port.mk>
-
diff --git a/editors/diamond/files/patch-src_CMakeLists.txt b/editors/diamond/files/patch-src_CMakeLists.txt
index 2105866af22a..d4f059428f38 100644
--- a/editors/diamond/files/patch-src_CMakeLists.txt
+++ b/editors/diamond/files/patch-src_CMakeLists.txt
@@ -9,6 +9,15 @@
if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
set_target_properties(Diamond PROPERTIES OUTPUT_NAME diamond)
+@@ -160,7 +162,7 @@ if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
+ )
+
+ elseif(CMAKE_SYSTEM_NAME MATCHES "(Linux|OpenBSD|FreeBSD|NetBSD|DragonFly)")
+- set_target_properties(Diamond PROPERTIES OUTPUT_NAME diamond)
++ set_target_properties(Diamond PROPERTIES OUTPUT_NAME diamond-cs)
+
+ find_package(PkgConfig)
+ pkg_check_modules(Hunspell IMPORTED_TARGET hunspell)
@@ -169,8 +171,9 @@ elseif(CMAKE_SYSTEM_NAME MATCHES "(Linux|OpenBSD|FreeB
PRIVATE
PkgConfig::Hunspell
diff --git a/editors/diamond/pkg-plist b/editors/diamond/pkg-plist
index a4f2eb0d70d1..5b66a6d4a53e 100644
--- a/editors/diamond/pkg-plist
+++ b/editors/diamond/pkg-plist
@@ -1,4 +1,4 @@
-bin/diamond
+bin/diamond-cs
share/copperspice/diamond/diamond.png
share/copperspice/diamond/dictionary/en_US.aff
share/copperspice/diamond/dictionary/en_US.dic