aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-01 16:21:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-01 16:21:45 +0000
commit63548c1b8fbdf79171fefdfb3a96f63073eeeb57 (patch)
tree8ea3137f00cc9b7d30f8b69188eeba429e993f86
parent42df9a54a37752254c5730b31428ddd421a7a13f (diff)
downloadports-63548c1b8fbdf79171fefdfb3a96f63073eeeb57.tar.gz
ports-63548c1b8fbdf79171fefdfb3a96f63073eeeb57.zip
- Stage support
Notes
Notes: svn path=/head/; revision=342183
-rw-r--r--graphics/O2-tools/Makefile4
-rw-r--r--graphics/O2-tools/pkg-plist7
-rw-r--r--graphics/gle/Makefile7
-rw-r--r--graphics/gle/pkg-plist14
-rw-r--r--graphics/jpgtn/Makefile5
5 files changed, 23 insertions, 14 deletions
diff --git a/graphics/O2-tools/Makefile b/graphics/O2-tools/Makefile
index bda781a17672..a6406e99e99a 100644
--- a/graphics/O2-tools/Makefile
+++ b/graphics/O2-tools/Makefile
@@ -11,8 +11,4 @@ COMMENT= Huge image processing tools and libraries
GNU_CONFIGURE= yes
-MAN1= bmptopnm-O2.1 breduce.1 lpsmooth.1 makecr.1 makepr.1 prlst2ps.1
-MAN4= d4file.4
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/graphics/O2-tools/pkg-plist b/graphics/O2-tools/pkg-plist
index f50a280d9662..6b58b522e967 100644
--- a/graphics/O2-tools/pkg-plist
+++ b/graphics/O2-tools/pkg-plist
@@ -27,3 +27,10 @@ include/stdps.h
include/ufilep.h
include/utypes.h
include/xiplib.h
+man/man1/bmptopnm-O2.1.gz
+man/man1/breduce.1.gz
+man/man1/lpsmooth.1.gz
+man/man1/makecr.1.gz
+man/man1/makepr.1.gz
+man/man1/prlst2ps.1.gz
+man/man4/d4file.4.gz
diff --git a/graphics/gle/Makefile b/graphics/gle/Makefile
index df734b0fa64d..bd481de3451c 100644
--- a/graphics/gle/Makefile
+++ b/graphics/gle/Makefile
@@ -20,13 +20,6 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= "LIBS=-L${LOCALBASE}/lib -lXext ${PTHREAD_LIBS}"
-MAN3= gle.3gle gleExtrusion.3gle gleHelicoid.3gle gleLathe.3gle \
- glePolyCone.3gle glePolyCylinder.3gle gleScrew.3gle \
- gleSetJoinStyle.3gle gleSetNumSides.3gle gleSpiral.3gle \
- gleSuperExtrusion.3gle gleTextureMode.3gle gleToroid.3gle \
- gleTwistExtrusion.3gle
-
-NO_STAGE= yes
post-patch:
.for file in ex_angle.c ex_cut_round.c ex_raw.c extrude.c round_cap.c segment.c texgen.c
@${REINPLACE_CMD} -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/src/${file}
diff --git a/graphics/gle/pkg-plist b/graphics/gle/pkg-plist
index 0a7072181973..f062e1bdf187 100644
--- a/graphics/gle/pkg-plist
+++ b/graphics/gle/pkg-plist
@@ -3,6 +3,20 @@ lib/libgle.a
lib/libgle.la
lib/libgle.so
lib/libgle.so.4
+man/man3/gle.3gle.gz
+man/man3/gleExtrusion.3gle.gz
+man/man3/gleHelicoid.3gle.gz
+man/man3/gleLathe.3gle.gz
+man/man3/glePolyCone.3gle.gz
+man/man3/glePolyCylinder.3gle.gz
+man/man3/gleScrew.3gle.gz
+man/man3/gleSetJoinStyle.3gle.gz
+man/man3/gleSetNumSides.3gle.gz
+man/man3/gleSpiral.3gle.gz
+man/man3/gleSuperExtrusion.3gle.gz
+man/man3/gleTextureMode.3gle.gz
+man/man3/gleToroid.3gle.gz
+man/man3/gleTwistExtrusion.3gle.gz
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/COPYING
%%DOCSDIR%%/COPYING.artistic
diff --git a/graphics/jpgtn/Makefile b/graphics/jpgtn/Makefile
index 0ea9209760df..07c4d62466e6 100644
--- a/graphics/jpgtn/Makefile
+++ b/graphics/jpgtn/Makefile
@@ -16,14 +16,13 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libjpeg=${LOCALBASE}
-MAN1= jpgtn.1
-PLIST_FILES= bin/jpgtn
+PLIST_FILES= bin/jpgtn \
+ man/man1/jpgtn.1.gz
WITH_MAXSIZE?= 2048
WITH_MINSIZE?= 1
WITH_DEFSIZE?= 128
-NO_STAGE= yes
pre-everything::
@${ECHO_MSG} "===>"
@${ECHO_MSG} "===> You can control program functionality by defining the following variables:"