aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-18 21:53:51 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-18 21:53:51 +0000
commit6afdfbb14808a8585d36beedf93bcd419ad954f9 (patch)
tree3d81fe553f3de4d7933d4760e6c7749aa3d06f9a
parent0b747b6ee6d5c82737fff8ffe604875653ea53bc (diff)
downloadports-6afdfbb14808a8585d36beedf93bcd419ad954f9.tar.gz
ports-6afdfbb14808a8585d36beedf93bcd419ad954f9.zip
- Update to version 0.0.0p3
PR: ports/64427 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=104540
-rw-r--r--sysutils/toshctl/Makefile21
-rw-r--r--sysutils/toshctl/distinfo3
-rw-r--r--sysutils/toshctl/files/patch-Makefile11
-rw-r--r--sysutils/toshctl/files/patch-tosh_bios.cpp11
-rw-r--r--sysutils/toshctl/files/patch-tosh_hci.cpp20
-rw-r--r--sysutils/toshctl/files/patch-tosh_hci.h14
6 files changed, 14 insertions, 66 deletions
diff --git a/sysutils/toshctl/Makefile b/sysutils/toshctl/Makefile
index ae7ed120ecf6..39db6e4973ff 100644
--- a/sysutils/toshctl/Makefile
+++ b/sysutils/toshctl/Makefile
@@ -1,22 +1,25 @@
# New ports collection makefile for: toshctl
# Date created: 22 September 2003
-# Whom: XXX
+# Whom: carl@servicefactory.com
#
# $FreeBSD$
#
-PORTNAME= toshctl
-PORTVERSION= 0.0.0p2
-CATEGORIES= sysutils
-MASTER_SITES= http://freebie.miraclenet.co.th/notebook/toshctl/
-EXTRACT_SUFX= .tgz
+PORTNAME= toshctl
+PORTVERSION= 0.0.0p3
+CATEGORIES= sysutils
+MASTER_SITES= http://freebie.miraclenet.co.th/notebook/toshctl/
+EXTRACT_SUFX= .tgz
-MAINTAINER= carl@servicefactory.se
-COMMENT= A command-line tool to access parts of the Toshiba hardware interface
+MAINTAINER= carl@servicefactory.com
+COMMENT= A command-line tool to access parts of the Toshiba hardware interface
ONLY_FOR_ARCHS= i386
PLIST_FILES= bin/toshctl
-WRKSRC= ${WRKDIR}/toshctl
+WRKSRC= ${WRKDIR}/toshctl
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/sysutils/toshctl/distinfo b/sysutils/toshctl/distinfo
index e3dbdac96f58..fbf83e3a5920 100644
--- a/sysutils/toshctl/distinfo
+++ b/sysutils/toshctl/distinfo
@@ -1 +1,2 @@
-MD5 (toshctl-0.0.0p2.tgz) = 619f3c42160ee7a4cbd01126c710cbd4
+MD5 (toshctl-0.0.0p3.tgz) = 9e888ec5a4ea0c803626e3a5dedc51c0
+SIZE (toshctl-0.0.0p3.tgz) = 10313
diff --git a/sysutils/toshctl/files/patch-Makefile b/sysutils/toshctl/files/patch-Makefile
deleted file mode 100644
index a19075bfdc12..000000000000
--- a/sysutils/toshctl/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Thu Mar 20 02:19:07 2003
-+++ Makefile Fri Aug 22 16:11:21 2003
-@@ -34,5 +34,8 @@
- $(PROGRAM):$(OBJS)
- $(CC) -o $(PROGRAM) $(LDFLAGS) $(OBJS)
-
-+install:
-+ ${INSTALL} ${PROGRAM} ${LOCALBASE}/bin
-+
- clean:
- rm -f *.o *.bak $(PROGRAM)
diff --git a/sysutils/toshctl/files/patch-tosh_bios.cpp b/sysutils/toshctl/files/patch-tosh_bios.cpp
deleted file mode 100644
index 05de81b20f3d..000000000000
--- a/sysutils/toshctl/files/patch-tosh_bios.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- tosh_bios.cpp.orig Fri Aug 22 16:03:37 2003
-+++ tosh_bios.cpp Fri Aug 22 16:03:50 2003
-@@ -130,7 +130,7 @@
- bios_time.tm_mday = str2int(&mem[0xFFFF8],2);
- time_t t = mktime(&bios_time);
-
-- snprintf(buf,32,"%ld",t);
-+ snprintf(buf,32,"%d",t);
- s = "20";s += mem[0xFFFFB];s += mem[0xFFFFC];s += '-';
- s += mem[0xFFFF5]; s+= mem[0xFFFF6];s+= '-';
- s += mem[0xFFFF8]; s+= mem[0xFFFF9];
diff --git a/sysutils/toshctl/files/patch-tosh_hci.cpp b/sysutils/toshctl/files/patch-tosh_hci.cpp
deleted file mode 100644
index 5ad72bf70e92..000000000000
--- a/sysutils/toshctl/files/patch-tosh_hci.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- tosh_hci.cpp.orig Wed Apr 23 17:16:42 2003
-+++ tosh_hci.cpp Fri Oct 3 17:35:48 2003
-@@ -132,7 +132,7 @@
-
- unsigned
- CToshHCIVar::hci_read(HCI_FUNCTION fn,unsigned ecx,unsigned edx)
-- throw (runtime_error)
-+ throw (std::runtime_error)
- {
- unsigned result;
-
-@@ -144,7 +144,7 @@
-
- void
- CToshHCIVar::hci_write(HCI_FUNCTION fn,unsigned ecx,unsigned edx)
-- throw (runtime_error)
-+ throw (std::runtime_error)
- {
- unsigned result;
-
diff --git a/sysutils/toshctl/files/patch-tosh_hci.h b/sysutils/toshctl/files/patch-tosh_hci.h
deleted file mode 100644
index 1a0020e5deba..000000000000
--- a/sysutils/toshctl/files/patch-tosh_hci.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- tosh_hci.h.orig Wed Mar 19 16:53:24 2003
-+++ tosh_hci.h Fri Oct 3 17:34:15 2003
-@@ -80,9 +80,9 @@
- unsigned ecx,unsigned edx) throw();
-
- static unsigned hci_read(HCI_FUNCTION fn,unsigned ecx,unsigned edx)
-- throw(runtime_error);
-+ throw(std::runtime_error);
- static void hci_write(HCI_FUNCTION fn,unsigned ecx,unsigned edx)
-- throw(runtime_error);
-+ throw(std::runtime_error);
- protected:
- typedef std::pair<unsigned,std::string> VAR_INFO;
-