aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-04-26 11:47:19 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-04-26 12:53:35 +0000
commit7504cd137ce8aad85cfd7a17aa5492b4aca9dfbe (patch)
tree5e300130b0f4cd4a6080c14062753c25648991eb
parenta4781a12220e51f01fea3fe97be8e4913ca74e18 (diff)
downloadports-7504cd137ce8aad85cfd7a17aa5492b4aca9dfbe.tar.gz
ports-7504cd137ce8aad85cfd7a17aa5492b4aca9dfbe.zip
lang/ruby31: enable libunwind on powerpc
-rw-r--r--Mk/Uses/ruby.mk2
-rw-r--r--lang/ruby31/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/Mk/Uses/ruby.mk b/Mk/Uses/ruby.mk
index bce78c7ed640..91b9f0147ed5 100644
--- a/Mk/Uses/ruby.mk
+++ b/Mk/Uses/ruby.mk
@@ -155,7 +155,7 @@ RUBY_PORTREVISION= 1
# Ruby 3.1
#
RUBY_DISTVERSION= 3.1.4
-RUBY_PORTREVISION= 0
+RUBY_PORTREVISION= 1
. elif ${RUBY_VER} == 3.2
#
diff --git a/lang/ruby31/Makefile b/lang/ruby31/Makefile
index bc417479ab8c..c5e25adab9cb 100644
--- a/lang/ruby31/Makefile
+++ b/lang/ruby31/Makefile
@@ -92,7 +92,7 @@ _SUF2= ,${PORTEPOCH}
# keep in sync with all platforms where libunwind is available
.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == armv7 || ${ARCH} == \
- i386 || ${ARCH} == powerpc64 || ${ARCH} == powerpc64le
+ i386 || ${ARCH} == powerpc || ${ARCH} == powerpc64 || ${ARCH} == powerpc64le
LIB_DEPENDS+= libunwind.so:devel/libunwind
.endif